Bug 717324 - GDM startup incomplete: gtk_widget_get_mapped: assertion `GTK_IS_WIDGET (widget)' failed
Summary: GDM startup incomplete: gtk_widget_get_mapped: assertion `GTK_IS_WIDGET (widg...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: gtk3
Version: rawhide
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-06-28 14:53 UTC by John Reiser
Modified: 2012-03-07 17:52 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-03-07 17:52:59 UTC


Attachments (Terms of Use)
/var/log/messages beginning at GDM (56.68 KB, text/plain)
2011-06-28 14:53 UTC, John Reiser
no flags Details
/var/log/Xorg.0.log (57.34 KB, text/plain)
2011-06-28 14:56 UTC, John Reiser
no flags Details
gdm failures (75.57 KB, text/plain)
2011-06-29 19:38 UTC, Clyde E. Kunkel
no flags Details

Description John Reiser 2011-06-28 14:53:31 UTC
Created attachment 510296 [details]
/var/log/messages beginning at GDM

Description of problem: Graphical login crashes before choosing userID and getting password.


Version-Release number of selected component (if applicable):
gdm-3.1.2-2.fc16.x86_64


How reproducible: every time (5 times so far)


Steps to Reproduce:
1. boot to default multi-user graphical login
2.
3.
  
Actual results: Background splash screen (night sky, aurora, moon, tree with two birds [one "mechanical"]) appears twice and persists. "Login" appears in style of XFCE (GNOME was default) but then "Login" disappears.  Mouse does move the pointer, but there is nothing to click; keyboard gets no response.  Complaints from gdm-simple-greeter appear in /var/log/messages, with tracebacks.


Expected results: Usual login with no crash.


Additional info:

Comment 1 John Reiser 2011-06-28 14:56:56 UTC
Created attachment 510299 [details]
/var/log/Xorg.0.log

[    40.120] (--) PCI:*(0:1:0:0) 1002:9540:174b:e970 rev 0, Mem @ 0xd0000000/268435456, 0xfe8e0000/65536, I/O @ 0x0000b000/256, BIOS @ 0x????????/131072

01:00.0 VGA compatible controller [0300]: ATI Technologies Inc RV710 [Radeon HD 4550] [1002:9540]

Comment 2 Ray Strode [halfline] 2011-06-28 17:02:49 UTC
it's a bug in the accessibility stack that gdm is hitting because it gets crashy on fatal-criticals in development versions.

I don't like that behaviour, so I've switched it off:

http://git.gnome.org/browse/gdm/commit/?id=fc6ee4aa6d71d2c448a9b62aca24ba318163c590

which i'll build into rawhide shortly.

Reassigning to gail for the actual

 Gtk-CRITICAL: gtk_widget_get_mapped: assertion `GTK_IS_WIDGET (widget)' failed

bug.

Comment 3 Adam Williamson 2011-06-28 17:57:20 UTC

*** This bug has been marked as a duplicate of bug 716365 ***

Comment 4 Ray Strode [halfline] 2011-06-28 18:04:28 UTC
unduping, since bug 716365 is assigned to GDM and I put the bug in gtk3

Comment 5 John Reiser 2011-06-29 13:45:37 UTC
Using today's new gdm-3.1.2-3.fc16.x86_64 I can now login and get Gnome desktop; thank you, Ray.

/var/log/messages still shows the complaints (with traceback):
Jun 29 06:19:07 f16r64 gdm-simple-greeter[1306]: Gtk-CRITICAL: gtk_widget_get_mapped: assertion `GTK_IS_WIDGET (widget)' failed#012aborting...

Comment 6 Clyde E. Kunkel 2011-06-29 19:38:08 UTC
Created attachment 510525 [details]
gdm failures

gdm-3.1.2-3.fc16 did not fix this for me, if this attachment shows the sqme error. Description comment matches what I am seeing.

The last working gdm for me is: gdm-3.0.0-2.fc16.x86_64

Comment 7 Adam Williamson 2011-06-29 21:48:42 UTC
Define 'fix'. The 'fix' in -3.fc16 is simply not to abort when this error happens. So the error still happens and is still logged, but that does not prevent gdm running. If gdm is not working for you, it's probably because of something else, now.

Comment 8 Matthias Clasen 2012-03-07 17:52:59 UTC
The original issue has been fixed here.


Note You need to log in before you can comment on or make changes to this bug.