This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 717303 - RFE: authconfig should support FreeIPA v2 domains
RFE: authconfig should support FreeIPA v2 domains
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: authconfig (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tomas Mraz
Fedora Extras Quality Assurance
: FutureFeature
: 671395 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-28 10:29 EDT by Stephen Gallagher
Modified: 2015-04-20 16:20 EDT (History)
1 user (show)

See Also:
Fixed In Version: authconfig-6.2.1-1.fc17
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-04-20 16:20:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Stephen Gallagher 2011-06-28 10:29:48 EDT
Description of problem:
RFE: authconfig should provide a user-friendly UI for joining client machines to FreeIPA v2 domains. Currently, authconfig support is only for FreeIPA v1.

With FreeIPA v2, clients can be enrolled with the server to provide host identity. We want to integrate with the authconfig UI so that this can be done during firstboot.

This would mean a certain amount of work on both authconfig and the ipa-client package (as the latter is currently dependent on the authconfig cli internally) to accomplish.

Version-Release number of selected component (if applicable):
authconfig-6.1.14-2.fc15.x86_64


Additional info:
Goals:
1) Be able to join a FreeIPA v2 domain by providing the credentials for an admin with join privilege
2) Do this in a consistent and simple GUI (we should probably involve the Fedora UXD team here, like we did for the authconfig 6.x redesign)
3) Be able to join this domain during firstboot (provided of course that we have network access)
Comment 1 Tomas Mraz 2011-09-08 04:36:47 EDT
*** Bug 671395 has been marked as a duplicate of this bug. ***
Comment 2 Stephen Gallagher 2015-04-20 16:20:00 EDT
This has long ago been solved by 'realmd'. Closing this bug.

Note You need to log in before you can comment on or make changes to this bug.