Bug 717405 - Register dialog state is preserved between cancels
Register dialog state is preserved between cancels
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.2
Unspecified Unspecified
unspecified Severity high
: rc
: ---
Assigned To: Michael Stead
J.C. Molet
:
: 717628 (view as bug list)
Depends On:
Blocks: rhsm-rhel62
  Show dependency treegraph
 
Reported: 2011-06-28 14:44 EDT by J.C. Molet
Modified: 2011-12-06 12:15 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-06 12:15:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description J.C. Molet 2011-06-28 14:44:51 EDT
Description of problem:
The cancel button on the system registration dialog in subscription-manager-gui does not fully cancel the registration process.

Version-Release number of selected component (if applicable):
subscription-manager-gnome-0.96.2-1.git.6.a062826.el6.x86_64

How reproducible:
always

Steps to Reproduce:
1. Start up subscription-manager-gui
2. Click "Register System"
3. Enter in a valid user name and password (user must have multiple owners)
4. At the owner selection dialog, hit 'Cancel'
5. Click "Register System"
  
Actual results:
The register system dialog is brought back to the owner selection screen, and there is no way to change the username without actually registering or closing the program.

Expected results:
If you hit cancel during this screen, it brings you back to the screen that asks for your account information when you choose to register again.

Additional info:
Comment 1 J.C. Molet 2011-06-30 13:19:08 EDT
*** Bug 717628 has been marked as a duplicate of this bug. ***
Comment 2 Michael Stead 2011-08-26 08:09:01 EDT
Fixed in master branch: e7a6e5f3c06e6c09585d6f4e088585015a8fb2fb
Comment 4 Shwetha Kallesh 2011-08-29 03:30:13 EDT
moving the bug to verified
Comment 5 errata-xmlrpc 2011-12-06 12:15:35 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1695.html

Note You need to log in before you can comment on or make changes to this bug.