Bug 71752 - up2date-gnome-2.9.33-7.x.9 and up2date-2.9.33-7.x.9 seem broken
up2date-gnome-2.9.33-7.x.9 and up2date-2.9.33-7.x.9 seem broken
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: up2date (Show other bugs)
null
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-17 21:21 EDT by Need Real Name
Modified: 2015-01-07 18:59 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-05 15:24:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace of (null) up2date-2.9.46-1, "Forward" button doesn't seem to work. (37.90 KB, text/plain)
2002-08-22 01:02 EDT, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2002-08-17 21:21:57 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020712

Description of problem:
Bad:  'up2date -i foo.rpm' exits with no installation
Bad:  'up2date-gnome' segfaults

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.run up2date from terminal in X
2.either with no arguments and GUI comes up or with arguments such as '-u' or '-i'
3.up2date doesn't update given package or up2date gui segfaults and there is no
bugzilla option that automagically dumps core file.
	

Actual Results:  up2date and up2date-gnome fail to run (rawhide version -
2.9.33-7.x.9)

Expected Results:  smooth install/remove/update of local software repository

Additional info:

I would like to report more, is there a way to debug this process?
Comment 1 Michael Young 2002-08-18 04:21:20 EDT
Try
strace /usr/sbin/up2date -u
(see bug 71387). But basically 2.9.33 is completely broken.
Comment 2 Adrian Likins 2002-08-19 14:36:29 EDT
Description of problem:
Bad:  'up2date -i foo.rpm' exits with no installation

NOTABUG. use redhat-config-packages or rpm for installing
packages from local repo's. The "-i" flag is used to tell up2date
to install packages (possibly overriding config setttings). 

Bad:  'up2date-gnome' segfaults

there is no executable called "up2date-gnome", so I'm
not sure how it segfaults. Did you mean "up2date-config"
or "up2date-nox" ?
Comment 3 Need Real Name 2002-08-19 14:59:04 EDT
up2date run from command line w/no arguments seems to bring up graphical
interface which segfaults.  If I run up2date from command line with arguments,
say, I have no local copy of given package so I need to grab it from Red Hat,
then up2date -i package.rpm or up2date -u to update system to current from
command line,  both (the gui and from command line) seem to crash with
2.9.33-7.x.9.  I'll run an strace with 2.9.33-7.x.9 when RHN traffic dies down a
bit.
Comment 4 Adrian Likins 2002-08-21 16:21:53 EDT
try this with the versions in (Null) please.

there was some weird issues in 2.9.33 that seem
to be cleared up in newer versions
Comment 5 Need Real Name 2002-08-22 01:00:10 EDT
w/up2date-2.9.46-1, the ui comes up but on "Packages Flagged to be Skipped" ui,
the "Forward" button is unfocused, so there is no way to complete the update. 
Also If "Back" is pressed to channel description ui, "Forward" button stays
unfocused.  1st attempt of an strace crashed X, Galeon also needed to be
restarted with 'killall galeon-bin'.  Attached is strace of up2date-2.9.46-1
when this occured.  It seems constant.

Also, I don't know if this is appropriate or not, but if there were more
channels offered in RHN, I would argue that subscription services would be a
better seller.
I.E. multimedia channel (possibly offering something the likes of
http://www.agnula.org/), office channel (different Linux office suites and tools
like trial version of VMWARE and the like), development channel (alternative
compilers, Intel compiler?, and IBM Linux dev tools, even if trial version),
security channel (security auditing tools as mentioned in the Red Hat Security
Guide.)....if not appropriate, I do apologize, who could I possibly contact to
suggest such criteria?  Only, if you have the time....
Comment 6 Need Real Name 2002-08-22 01:02:49 EDT
Created attachment 72185 [details]
strace of (null) up2date-2.9.46-1, "Forward" button doesn't seem to work.
Comment 7 Need Real Name 2002-09-04 15:24:36 EDT
FWIW, up2date consistently fails for me, too, with the unfocused Forward 
button, when I run the update agent from the Gnome menu.  The update headers 
all get downloaded, but up2date stalls when it gets to the Skipped Packages 
screen.
Comment 8 Need Real Name 2002-09-04 21:28:16 EDT
up2date-2.9.68-1 seems to fix alot of these problems, although "Use GPG to
verify package integrity" doesn't seem to work for most of the updates, which
worries me a bit as I sure hope I'm not downloading cracked versions of updates.
Comment 9 Need Real Name 2002-09-05 15:24:17 EDT
Where can I get up2date-2.9.68-1?  Rawhide has 2.9.61-1, which still exhibits 
the unfocused Forward button.
Comment 10 Adrian Likins 2002-09-12 18:07:08 EDT
new packages should be available soon.

Note You need to log in before you can comment on or make changes to this bug.