Bug 717565 - Perl package tries to touch folder in /usr/local
Summary: Perl package tries to touch folder in /usr/local
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: perl
Version: 6.1
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: rc
: ---
Assignee: perl-maint-list
QA Contact: Lukáš Zachar
URL:
Whiteboard:
: 717567 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-06-29 09:04 UTC by redhat@mrc-epid.cam.ac.uk
Modified: 2014-08-21 11:14 UTC (History)
7 users (show)

Fixed In Version: perl-5.10.1-121.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-06-20 13:47:24 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 707960 high CLOSED perl and perl-libs should not own /usr/local/*/perl5 directories 2020-10-14 00:28:05 UTC
Red Hat Bugzilla 1132321 unspecified CLOSED cpan should offer creating site directories 2020-10-14 00:28:05 UTC
Red Hat Product Errata RHBA-2012:0843 normal SHIPPED_LIVE perl bug fix and enhancement update 2012-06-19 20:48:56 UTC

Internal Links: 707960 732799 1132321

Description redhat@mrc-epid.cam.ac.uk 2011-06-29 09:04:46 UTC
Description of problem:
Perl cannot be updated on machine where /usr/local is an NFS mount without root write permissions, as the packages is trying to touch /usr/local/lib64/perl5

Version-Release number of selected component (if applicable):
4:perl-libs-5.10.1-119.el6.x86_64

How reproducible:
Completely

Steps to Reproduce:
1. yum -y update
2.
3.
  
Actual results:

  Updating   : 4:perl-5.10.1-119.el6.x86_64                                                                      2/4
Error unpacking rpm package 4:perl-5.10.1-119.el6.x86_64
error: unpacking of archive failed on file /usr/local/share/perl5: cpio: chown


Expected results:


Additional info:

rpm -ql perl | grep /usr/local
/usr/local/share/perl5

Comment 2 Petr Pisar 2011-06-29 11:12:17 UTC
*** Bug 717567 has been marked as a duplicate of this bug. ***

Comment 3 RHEL Program Management 2011-07-06 01:35:01 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Comment 4 redhat@mrc-epid.cam.ac.uk 2011-07-06 06:04:06 UTC
Does this mean that installation of perl in RHEL 6.1 is broken and isn't going to be fixed? 

Apart from moving to Oracle Linux what can we do? We have Academic licenses so don't have a support representative.

This is the first time I've used Bugzilla, and I'm very disappointed.

thanks

iain

Comment 5 redhat@mrc-epid.cam.ac.uk 2011-07-06 16:03:41 UTC
A couple of very helpful people on the RHEL 6 mailing list suggested using rpm macros

"The file is /etc/rpm/macros.nfs, and you just need to have the content,

  %_netsharedpath /usr/local

"

This has fixed my problem but RedHat is still broken. 

iain

Comment 6 Elliott Forney 2011-08-23 16:45:28 UTC
The same thing appears broken in Fedora 15.  See Bug 732799.

Comment 7 Elliott Forney 2011-08-23 16:50:03 UTC
I agree with Iain.  Rpm's that come with the distribution should not be writing to /usr/local.  In a shared environment it is commonplace to have an NFS shared /usr/local partition and it should be set to read-only.  Normal updates fail under these conditions.

Comment 8 Marcela Mašláňová 2011-08-24 07:28:36 UTC
It was already filed as #707960, not sure if you can see that one. 

Not only Perl owns directories in /usr/local, so using 
%_netsharedpath /usr/local might be good thing.

I'd like to fix it with next erratum of Perl.

Comment 9 redhat@mrc-epid.cam.ac.uk 2011-08-24 07:36:50 UTC
Hi,
  I can't see 707960. Would be nice if this could be fixed. Why was the initial RedHat response [comment 3] so unhelpful? 

iain

Comment 10 Marcela Mašláňová 2011-08-24 07:57:15 UTC
It was usual triage, not unhelpful comment. Ideas about this bug differs, see for more information #732799.

Comment 11 Petr Pisar 2011-10-27 09:44:55 UTC
We decided to disown /usr/local directories but to keep them in Perl search paths as `site' paths. Also the directories will not be created automatically by any RPM package scriptlet.

Comment 14 RHEL Program Management 2012-02-14 22:09:50 UTC
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux maintenance release. Product Management has 
requested further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed 
products. This request is not yet committed for inclusion in an Update release.

Comment 20 errata-xmlrpc 2012-06-20 13:47:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0843.html


Note You need to log in before you can comment on or make changes to this bug.