Bug 717770 - Need single-request-reopen option documented for resolv.conf
Summary: Need single-request-reopen option documented for resolv.conf
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: man-pages-overrides
Version: 6.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Peter Schiffer
QA Contact: BaseOS QE - Apps
URL:
Whiteboard:
Depends On:
Blocks: 745152 748554
TreeView+ depends on / blocked
 
Reported: 2011-06-29 20:07 UTC by Erinn Looney-Triggs
Modified: 2018-11-14 11:48 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 745152 (view as bug list)
Environment:
Last Closed: 2011-12-06 11:48:17 UTC


Attachments (Terms of Use)
Proposed patch (895 bytes, patch)
2011-09-22 07:58 UTC, Tomas Smetana
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1571 normal SHIPPED_LIVE man-pages-overrides bug fix update 2011-12-06 00:39:05 UTC
Red Hat Bugzilla 505105 None CLOSED getaddrinfo() with AI_ADDRCONFIG doesn't suppress AAAA DNS queries on IPv4-only networks 2019-05-08 05:26:26 UTC

Internal Links: 505105

Description Erinn Looney-Triggs 2011-06-29 20:07:25 UTC
Description of problem:
More of your users are going to be using this option as more deploys of RHEL 6 go out. See here for they why: http://www.linuxquestions.org/questions/showthread.php?p=4399340#post4399340

This option is not currently documented and it needs to be. 

Version-Release number of selected component (if applicable):
man-pages-3.22-17.el6.noarch

How reproducible:
man resolv.conf look for single-request-open


I have filed an upstream bug here: https://bugzilla.kernel.org/show_bug.cgi?id=38542

This issue also effect Fedora 15, and probably rawhide too.

Comment 3 RHEL Product and Program Management 2011-07-06 00:33:16 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Comment 5 Tomas Smetana 2011-09-22 07:58:48 UTC
Created attachment 524346 [details]
Proposed patch

This has been taken from the KCS article attached to the case.

Comment 11 errata-xmlrpc 2011-12-06 11:48:17 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1571.html

Comment 12 Erinn Looney-Triggs 2011-12-06 18:09:59 UTC
Unless I am missing something here, even after updating to RHEL 6.2 I cannot see this in the man page, I can see another overlay the EDNS0 options but not the single-request-open option.

man-pages-3.22-17.el6.noarch
man-pages-overrides-6.2.3-2.el6.noarch

-Erinn

Comment 13 Mihai Harpau 2011-12-06 20:02:31 UTC
I see this sub-paragraph in "man 5 resolv.conf" under options:

    single-request-reopen (since glibc 2.9)
                     The  resolver  uses  the  same  socket for the A and AAAA
                     requests.  Some hardware mistakenly only sends  back  one
                     reply.   When  that happens the client sytem will sit and
                     wait for  the  second  reply.   Turning  this  option  on
                     changes  this  behavior  so that if two requests from the
                     same port are not handled correctly  it  will  close  the
                     socket  and  open  a  new  one  before sending the second
                     request.

man-pages-3.22-17.el6.noarch
man-pages-overrides-6.2.3-2.el6.noarch

Comment 14 Erinn Looney-Triggs 2011-12-06 20:27:12 UTC
Hmm pretty clearly I am doing somehting wrong. Looked on multiple 6.2 systems after the update and was unable to see that paragraph. Glad though that other people can.

Comment 15 Erinn Looney-Triggs 2011-12-06 20:44:45 UTC
manpath was bad, this works just fine, sorry for all the noise.

Comment 16 todd_lewis 2012-09-11 19:24:15 UTC
I see that option documented on a Red Hat Enterprise Linux Server release 6.3 (Santiago) system, which claims at the bottom of the man page: "This page is part of release 3.22 of the Linux man-pages project."

However, it isn't in the Fedora-17 resolv.conf man page, which claims: "This  page is part of release 3.35 of the Linux man-pages project."

Nor is it in the git HEAD at the man-pages project.

I'm not sure what the process is for moving fixes across projects, but something has slipped throught the cracks here that could be better. Just sayin'.

Comment 17 Peter Schiffer 2012-09-12 09:46:12 UTC
Thanks for the notice Todd. I'll fix this in Fedora. (And thanks for submitting this to upstream). I am going to review man-pages bugs in RHEL and fix them in Fedora, it looks like there are more bugs like this one..

peter


Note You need to log in before you can comment on or make changes to this bug.