Bug 717845 - [abrt] ibus-1.3.99.20110419-2.fc15: connection.py:630:call_blocking:DBusException: org.freedesktop.DBus.Error.Failed: Context which does not has focus can not change engine to scj6.
[abrt] ibus-1.3.99.20110419-2.fc15: connection.py:630:call_blocking:DBusExcep...
Status: CLOSED DUPLICATE of bug 707370
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
15
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
abrt_hash:a9737195776ec3f022d1efbd519...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-30 03:17 EDT by John Lau
Modified: 2011-07-21 21:36 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-21 21:36:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Lau 2011-06-30 03:17:41 EDT
abrt version: 2.0.1
architecture:   x86_64
cmdline:        /usr/bin/python /usr/share/ibus/ui/gtk/main.py
component:      ibus
executable:     /usr/share/ibus/ui/gtk/main.py
kernel:         2.6.38.6-26.rc1.fc15.x86_64
os_release:     Fedora release 15 (Lovelock)
package:        ibus-1.3.99.20110419-2.fc15
reason:         connection.py:630:call_blocking:DBusException: org.freedesktop.DBus.Error.Failed: Context which does not has focus can not change engine to scj6.
time:           Thu Jun 30 15:16:30 2011
uid:            500
username:       johnlau

backtrace:
:connection.py:630:call_blocking:DBusException: org.freedesktop.DBus.Error.Failed: Context which does not has focus can not change engine to scj6.
:
:Traceback (most recent call last):
:  File "/usr/share/ibus/ui/gtk/panel.py", line 526, in __im_menu_item_activate_cb
:    self.__focus_ic.set_engine(engine)
:  File "/usr/lib/python2.7/site-packages/ibus/inputcontext.py", line 259, in set_engine
:    return self.__context.SetEngine(engine.name)
:  File "/usr/lib/python2.7/site-packages/dbus/proxies.py", line 140, in __call__
:    **keywords)
:  File "/usr/lib/python2.7/site-packages/dbus/connection.py", line 630, in call_blocking
:    message, timeout)
:DBusException: org.freedesktop.DBus.Error.Failed: Context which does not has focus can not change engine to scj6.
:
:Local variables in innermost frame:
:byte_arrays: False
:self: <dbus.connection.Connection object at 0x128ad10>
:args: (dbus.String(u'scj6'),)
:utf8_strings: False
:bus_name: 'org.freedesktop.IBus'
:get_args_opts: {'byte_arrays': False, 'utf8_strings': False}
:object_path: dbus.ObjectPath('/org/freedesktop/IBus/InputContext_20')
:timeout: -1.0
:signature: u's'
:dbus_interface: 'org.freedesktop.IBus.InputContext'
:message: <dbus.lowlevel.MethodCallMessage object at 0x11f0af8>
:method: 'SetEngine'
Comment 1 John Lau 2011-06-30 03:31:27 EDT
I try this bug a few times. It happened when I use "Ctrl-space" to switch input method.
Comment 2 John Lau 2011-06-30 03:31:58 EDT
I mean I triggered this bug a few times.
Comment 3 fujiwara 2011-07-05 05:45:57 EDT
I cannot reproduce your problem.
Are you able to see the same problem when you use a new user account instead of the current account?
Comment 4 John Lau 2011-07-05 05:51:43 EDT
I will try to create a new user account and test later.

I remember that I hit this problem more frequently when setting "Share the same input method among all applications". And the problem happens when I switch input focus between windows and then use "Ctrl-space" to switch input method. Hope it helps.
Comment 5 fujiwara 2011-07-11 06:36:32 EDT
(In reply to comment #4)
> I remember that I hit this problem more frequently when setting "Share the same
> input method among all applications". And the problem happens when I switch

I don't see any problems with "Share the same input method among all applications".
Do you mean "Use system keyboard layout" instead?
Comment 6 fujiwara 2011-07-21 21:36:22 EDT

*** This bug has been marked as a duplicate of bug 707370 ***

Note You need to log in before you can comment on or make changes to this bug.