Bug 71802 - Unmount of /initrd fails is some cases
Unmount of /initrd fails is some cases
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks: 67218 79579 CambridgeTarget
  Show dependency treegraph
 
Reported: 2002-08-19 10:37 EDT by Jos Vos
Modified: 2014-03-16 22:30 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-29 16:14:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Patch for optionally unmounting /initrd/proc before unmounting /initrd. (402 bytes, patch)
2002-08-19 10:38 EDT, Jos Vos
no flags Details | Diff

  None (edit)
Description Jos Vos 2002-08-19 10:37:14 EDT
Description of Problem:
In case "console=none" is given as boot parameter, /initrd/proc seems to stay
mounted and thus unmounting /initrd (rc.sysinit) fails. I have no idea what the
relation of /proc with console=none, but I leave this as an exercise for the
reader ;-).

Version-Release number of selected component (if applicable):
6.90-1 (in fact, any version, at least since RH 7.3 and up).

How Reproducible:
By specifying "console=none" as boot parameter.

Fix (workaround):
See the patch I'll attach to this bug report (the fix is against 6.67, but that
doesn't matter). I've done the check in the same way as it is checked whether
devfs is still mounted below /initrd.
Comment 1 Jos Vos 2002-08-19 10:38:32 EDT
Created attachment 71424 [details]
Patch for optionally unmounting /initrd/proc before unmounting /initrd.
Comment 2 Bill Nottingham 2005-09-29 16:14:44 EDT
Closing bugs on older, no longer supported, releases. Apologies for any lack of
response.
With the move to initramfs, it is unlikely that this will change for older releases.

Note You need to log in before you can comment on or make changes to this bug.