Bug 71834 - couldn't get focus in entry for providing root password
Summary: couldn't get focus in entry for providing root password
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 8.0
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
: 73441 82718 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-08-19 19:25 UTC by Mikael Hallendal
Modified: 2007-04-18 16:45 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-03-07 22:19:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mikael Hallendal 2002-08-19 19:25:48 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/0

Description of problem:
The root password entries didn't get focus and clicking on them didn't help.
Only way I could give it focus was to right-click (which poped up a menu). Then
I could give it focus and type root password.

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:


Additional info:

No idea what happened, other seems to have had no problem with this.
I'll try to restart the installation later and see if it comes up again.

Comment 1 Michael Fulbright 2002-08-22 17:04:25 UTC
Please let us know if you get a reproducible case.

Comment 2 jrjohns 2002-09-09 00:15:51 UTC
I have seen this problem, I think I know the cause, and I have a workaround (but
strongly suggest you fix the problem).

The problem seems to occur because drag and drop is enabled.  If you highlight a
field and drag slightly with the mouse, you'll see a paper icon for the mouse 
cursor.  Click in the field again and it seems to return to normal but there's no 
more cursor.  You can't type in the field anymore.

After right-clicking over the field and choosing Select All, then clicking in
the field once again, the focus and cursor returns.

This problem happens all over in the interface.  Why is drag and drop enabled
when there is no real need or reason for it?

See also: 72555, 73441 (duplicates)... this is becoming a popular defect.

Comment 3 Michael Fulbright 2002-10-23 20:33:51 UTC
Thanks for the additional information.

Comment 4 Need Real Name 2002-11-22 04:04:32 UTC
In the case of drag and drop you can go back a page and then forward.  This will
reset the field.

Here is how to reproduce the root password field problem:

1- At disk druid create a Volume Group
2- Create 1 logical volumn like /
3- Continue until the root password request

So, it looks like the password entry is conditional on some previous state of a
boundary ( input screen )

Comment 5 Jeremy Katz 2003-01-10 07:32:39 UTC
*** Bug 73441 has been marked as a duplicate of this bug. ***

Comment 6 Michael Fulbright 2003-01-27 16:58:03 UTC
*** Bug 82718 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.