Bug 718453 - [abrt] ibus-1.3.99.20110419-7.fc15: ibus_keymap_lookup_keysym: Process /usr/bin/ibus-daemon was killed by signal 6 (SIGABRT)
[abrt] ibus-1.3.99.20110419-7.fc15: ibus_keymap_lookup_keysym: Process /usr/b...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
15
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
abrt_hash:814146953920ea2837725b17043...
:
: 718497 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-03 02:09 EDT by Insang Ryu
Modified: 2011-07-10 14:05 EDT (History)
4 users (show)

See Also:
Fixed In Version: ibus-1.3.99.20110419-9.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-08 14:00:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Insang Ryu 2011-07-03 02:09:53 EDT
abrt version: 2.0.3
architecture:   x86_64
backtrace_rating: 4
cmdline:        /usr/bin/ibus-daemon -r --xim
component:      ibus
crash_function: ibus_keymap_lookup_keysym
executable:     /usr/bin/ibus-daemon
kernel:         2.6.38.8-32.fc15.x86_64
os_release:     Fedora release 15 (Lovelock)
package:        ibus-1.3.99.20110419-7.fc15
reason:         Process /usr/bin/ibus-daemon was killed by signal 6 (SIGABRT)
time:           Sun Jul  3 15:05:07 2011
uid:            500
username:       routitz

backtrace:
:[New LWP 5143]
:[New LWP 5152]
:[New LWP 5146]
:[Thread debugging using libthread_db enabled]
:Core was generated by `/usr/bin/ibus-daemon -r --xim'.
:Program terminated with signal 6, Aborted.
:#0  0x0000003bcb2352d5 in raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
:64	../nptl/sysdeps/unix/sysv/linux/raise.c: No such file or directory.
:	in ../nptl/sysdeps/unix/sysv/linux/raise.c
:
:Thread 3 (Thread 0x7ff89e401700 (LWP 5146)):
:#0  0x0000003bcba0dfdd in read () at ../sysdeps/unix/syscall-template.S:82
:No locals.
:#1  0x0000003bcd24468b in read (__nbytes=20, __buf=0x7ff89e400db0, __fd=<optimized out>) at /usr/include/bits/unistd.h:45
:No locals.
:#2  child_watch_helper_thread (data=<optimized out>) at gmain.c:4315
:        b = "B", '\000' <repeats 18 times>
:        list = <optimized out>
:#3  0x0000003bcd2683a6 in g_thread_create_proxy (data=0x1a19b60) at gthread.c:1955
:        thread = 0x1a19b60
:        __PRETTY_FUNCTION__ = "g_thread_create_proxy"
:#4  0x0000003bcba07af1 in start_thread (arg=0x7ff89e401700) at pthread_create.c:305
:        __res = <optimized out>
:        pd = 0x7ff89e401700
:        now = <optimized out>
:        unwind_buf = {cancel_jmp_buf = {{jmp_buf = {0, 6959905114855384949, 140737403095296, 140705783617984, 0, 3, -6960400825512286347, 6980891217118832501}, mask_was_saved = 0}}, priv = {pad = {0x0, 0x0, 0x0, 0x0}, data = {prev = 0x0, cleanup = 0x0, canceltype = 0}}}
:        not_first_call = 0
:        pagesize_m1 = <optimized out>
:        sp = <optimized out>
:        freesize = <optimized out>
:#5  0x0000003bcb2dfddd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115
:No locals.
:
:Thread 2 (Thread 0x7ff89d3ff700 (LWP 5152)):
:#0  0x0000003bcb2d74f3 in __poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
:        resultvar = <optimized out>
:        oldtype = 0
:        result = <optimized out>
:#1  0x0000003bcd242d24 in g_main_context_poll (n_fds=17, fds=0x7ff89000ae40, priority=<optimized out>, timeout=-1, context=0x7ff898009b30) at gmain.c:3405
:        poll_func = 0x3bcd251310 <g_poll>
:#2  g_main_context_iterate (context=0x7ff898009b30, block=<optimized out>, dispatch=1, self=<optimized out>) at gmain.c:3087
:        max_priority = 2147483647
:        timeout = -1
:        some_ready = <optimized out>
:        nfds = 17
:        allocated_nfds = <optimized out>
:        fds = 0x7ff89000ae40
:        __PRETTY_FUNCTION__ = "g_main_context_iterate"
:#3  0x0000003bcd24360d in g_main_loop_run (loop=0x7ff898009b10) at gmain.c:3300
:        self = 0x7ff898009c20
:        __PRETTY_FUNCTION__ = "g_main_loop_run"
:#4  0x0000003bceab4564 in gdbus_shared_thread_func (data=<optimized out>) at gdbusprivate.c:276
:No locals.
:#5  0x0000003bcd2683a6 in g_thread_create_proxy (data=0x7ff898009c20) at gthread.c:1955
:        thread = 0x7ff898009c20
:        __PRETTY_FUNCTION__ = "g_thread_create_proxy"
:#6  0x0000003bcba07af1 in start_thread (arg=0x7ff89d3ff700) at pthread_create.c:305
:        __res = <optimized out>
:        pd = 0x7ff89d3ff700
:        now = <optimized out>
:        unwind_buf = {cancel_jmp_buf = {{jmp_buf = {0, 6959905114855384949, 140705775220144, 140705766832576, 0, 3, -6960393847264172171, 6980891217118832501}, mask_was_saved = 0}}, priv = {pad = {0x0, 0x0, 0x0, 0x0}, data = {prev = 0x0, cleanup = 0x0, canceltype = 0}}}
:        not_first_call = 0
:        pagesize_m1 = <optimized out>
:        sp = <optimized out>
:        freesize = <optimized out>
:#7  0x0000003bcb2dfddd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115
:No locals.
:
:Thread 1 (Thread 0x7ff8a4a327c0 (LWP 5143)):
:#0  0x0000003bcb2352d5 in raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
:        resultvar = 0
:        pid = <optimized out>
:        selftid = <optimized out>
:#1  0x0000003bcb236beb in abort () at abort.c:93
:        save_stage = 2
:        act = {__sigaction_handler = {sa_handler = 0x1a6a7d0, sa_sigaction = 0x1a6a7d0}, sa_mask = {__val = {256844884194, 27929760, 256844903457, 0, 32, 27929760, 27929760, 27691008, 27691008, 27669056, 27691008, 122, 1, 0, 256844797763, 27929760}}, sa_flags = -853122918, sa_restorer = 0x63}
:        sigs = {__val = {32, 0 <repeats 15 times>}}
:#2  0x0000003bcd2665bd in g_assertion_message (domain=<optimized out>, file=<optimized out>, line=<optimized out>, func=0x3998c2b980 "ibus_keymap_lookup_keysym", message=0x1a6a7d0 "assertion failed: (IBUS_IS_KEYMAP (keymap))") at gtestutils.c:1358
:        lstr = "282\000\377\177\000\000\260\b\353\372\377\177\000\000\377\377\377\000\000\000\000\000U\271\302\230\071\000\000"
:        s = 0x1a63240 ""
:#3  0x0000003bcd266ae2 in g_assertion_message_expr (domain=0x3998c299d0 "IBUS", file=0x3998c2b948 "ibuskeymap.c", line=282, func=0x3998c2b980 "ibus_keymap_lookup_keysym", expr=<optimized out>) at gtestutils.c:1369
:        s = <optimized out>
:#4  0x0000003998c14107 in ibus_keymap_lookup_keysym (keymap=0x0, keycode=122, state=0) at ibuskeymap.c:282
:        __PRETTY_FUNCTION__ = "ibus_keymap_lookup_keysym"
:#5  0x0000000000414da5 in bus_engine_proxy_process_key_event (engine=0x1ac18e0 [BusEngineProxy], keyval=65329, keycode=122, state=0, callback=0x40f870 <_ic_process_key_event_reply_cb>, user_data=0x1a4b860) at engineproxy.c:919
:        t = <optimized out>
:        keymap = <optimized out>
:        __PRETTY_FUNCTION__ = "bus_engine_proxy_process_key_event"
:#6  0x00000000004124c6 in _ic_process_key_event (context=0x7ff898013b00 [BusInputContext], parameters=<optimized out>, invocation=0x1a4b860 [GDBusMethodInvocation]) at inputcontext.c:739
:        keyval = 65329
:        keycode = 122
:        modifiers = 0
:#7  0x0000003bceaa6080 in call_in_idle_cb (user_data=0x1a4b860) at gdbusconnection.c:4445
:        invocation = 0x1a4b860 [GDBusMethodInvocation]
:        vtable = <optimized out>
:        registration_id = <optimized out>
:        subtree_registration_id = <optimized out>
:        __PRETTY_FUNCTION__ = "call_in_idle_cb"
:#8  0x0000003bcd2427ed in g_main_dispatch (context=0x1a6b800) at gmain.c:2441
:        dispatch = 0x3bcd23e750 <g_idle_dispatch>
:        was_in_call = 0
:        user_data = 0x1a4b860
:        callback = 0x3bceaa5f70 <call_in_idle_cb>
:        cb_funcs = 0x3bcd515c50
:        cb_data = 0x7ff890008160
:        current_source_link = {data = 0x7ff8900080f0, next = 0x0}
:        need_destroy = <optimized out>
:        source = 0x7ff8900080f0
:        current = 0x1a0cc40
:        i = <optimized out>
:#9  g_main_context_dispatch (context=0x1a6b800) at gmain.c:3014
:No locals.
:#10 0x0000003bcd242fc8 in g_main_context_iterate (context=0x1a6b800, block=<optimized out>, dispatch=1, self=<optimized out>) at gmain.c:3092
:        max_priority = 2147483647
:        timeout = -1
:        some_ready = 1
:        nfds = 3
:        allocated_nfds = <optimized out>
:        fds = <optimized out>
:        __PRETTY_FUNCTION__ = "g_main_context_iterate"
:#11 0x0000003bcd24360d in g_main_loop_run (loop=0x19f6fc0) at gmain.c:3300
:        self = 0x19ebd30
:        __PRETTY_FUNCTION__ = "g_main_loop_run"
:#12 0x000000000041893e in bus_server_run () at server.c:137
:        __PRETTY_FUNCTION__ = "bus_server_run"
:#13 0x0000000000406ea8 in main (argc=1, argv=0x7ffffaeb0cf8) at main.c:291
:        context = <optimized out>
:        error = 0x0
:From                To                  Syms Read   Shared Object Library
:0x0000003bcea294a0  0x0000003bcead2b3c  Yes         /lib64/libgio-2.0.so.0
:0x0000003bcde09970  0x0000003bcde39dcc  Yes         /lib64/libgobject-2.0.so.0
:0x0000003bce200fe0  0x0000003bce201f8c  Yes         /lib64/libgmodule-2.0.so.0
:0x0000003bcda01560  0x0000003bcda02a2c  Yes         /lib64/libgthread-2.0.so.0
:0x0000003bcc202160  0x0000003bcc2053ec  Yes         /lib64/librt.so.1
:0x0000003bcd216cd0  0x0000003bcd2adbec  Yes         /lib64/libglib-2.0.so.0
:0x0000003998c0d330  0x0000003998c2998c  Yes         /usr/lib64/libibus-1.0.so.0
:0x0000003bcba05640  0x0000003bcba1038c  Yes         /lib64/libpthread.so.0
:0x0000003bcb21ece0  0x0000003bcb3432ac  Yes         /lib64/libc.so.6
:0x0000003bcbe00de0  0x0000003bcbe0191c  Yes         /lib64/libdl.so.2
:0x0000003bcd603840  0x0000003bcd61354c  Yes         /lib64/libresolv.so.2
:0x0000003bcc601e70  0x0000003bcc60e67c  Yes         /lib64/libz.so.1
:0x0000003bcce05980  0x0000003bcce159dc  Yes         /lib64/libselinux.so.1
:0x0000003bcae00b20  0x0000003bcae18caa  Yes         /lib64/ld-linux-x86-64.so.2
:0x00007ff89e404170  0x00007ff89e40b8ac  Yes         /lib64/libnss_files.so.2
:$1 = 0x0
:$2 = 0x1b01080 "IBUS:ERROR:ibuskeymap.c:282:ibus_keymap_lookup_keysym: assertion failed: (IBUS_IS_KEYMAP (keymap))"
:rax            0x0	0
:rbx            0x1a63240	27669056
:rcx            0xffffffffffffffff	-1
:rdx            0x6	6
:rsi            0x1417	5143
:rdi            0x1417	5143
:rbp            0x3bcd516400	0x3bcd516400
:rsp            0x7ffffaeb0738	0x7ffffaeb0738
:r8             0x20	32
:r9             0x50	80
:r10            0x8	8
:r11            0x206	518
:r12            0x3998c2b980	247376034176
:r13            0x1a6a7d0	27699152
:r14            0x1a4b860	27572320
:r15            0x0	0
:rip            0x3bcb2352d5	0x3bcb2352d5 <raise+53>
:eflags         0x206	[ PF IF ]
:cs             0x33	51
:ss             0x2b	43
:ds             0x0	0
:es             0x0	0
:fs             0x0	0
:gs             0x0	0
:Dump of assembler code for function raise:
:   0x0000003bcb2352a0 <+0>:	mov    %fs:0x2d4,%eax
:   0x0000003bcb2352a8 <+8>:	mov    %fs:0x2d0,%esi
:   0x0000003bcb2352b0 <+16>:	test   %esi,%esi
:   0x0000003bcb2352b2 <+18>:	jne    0x3bcb2352e0 <raise+64>
:   0x0000003bcb2352b4 <+20>:	mov    $0xba,%eax
:   0x0000003bcb2352b9 <+25>:	syscall 
:   0x0000003bcb2352bb <+27>:	mov    %eax,%esi
:   0x0000003bcb2352bd <+29>:	mov    %eax,%fs:0x2d0
:   0x0000003bcb2352c5 <+37>:	movslq %edi,%rdx
:   0x0000003bcb2352c8 <+40>:	movslq %esi,%rsi
:   0x0000003bcb2352cb <+43>:	movslq %eax,%rdi
:   0x0000003bcb2352ce <+46>:	mov    $0xea,%eax
:   0x0000003bcb2352d3 <+51>:	syscall 
:=> 0x0000003bcb2352d5 <+53>:	cmp    $0xfffffffffffff000,%rax
:   0x0000003bcb2352db <+59>:	ja     0x3bcb2352ef <raise+79>
:   0x0000003bcb2352dd <+61>:	repz retq 
:   0x0000003bcb2352df <+63>:	nop
:   0x0000003bcb2352e0 <+64>:	test   %eax,%eax
:   0x0000003bcb2352e2 <+66>:	jg     0x3bcb2352c5 <raise+37>
:   0x0000003bcb2352e4 <+68>:	test   $0x7fffffff,%eax
:   0x0000003bcb2352e9 <+73>:	je     0x3bcb235300 <raise+96>
:   0x0000003bcb2352eb <+75>:	neg    %eax
:   0x0000003bcb2352ed <+77>:	jmp    0x3bcb2352c5 <raise+37>
:   0x0000003bcb2352ef <+79>:	mov    0x35ccb2(%rip),%rdx        # 0x3bcb591fa8
:   0x0000003bcb2352f6 <+86>:	neg    %eax
:   0x0000003bcb2352f8 <+88>:	mov    %eax,%fs:(%rdx)
:   0x0000003bcb2352fb <+91>:	or     $0xffffffffffffffff,%rax
:   0x0000003bcb2352ff <+95>:	retq   
:   0x0000003bcb235300 <+96>:	mov    %esi,%eax
:   0x0000003bcb235302 <+98>:	jmp    0x3bcb2352c5 <raise+37>
:End of assembler dump.

build_ids:
:318d7ebb9ff61bf5d08d070bb0fa793c4c0d9cb0
:e5f626726497a81807681ed0088dbce6d6a1f17b
:0b232e446650ce07a3e70bae4f00a7ad5eda2630
:efa74dfa03cd51579af9c40058d4ee8be29098da
:9ef41f9ca0eabaf3a03dd77eb180e202ab4fe956
:15992a365655e9b7bfbbdf3a127e8e291e6e5a3b
:4c7e95adf3ebf234c3296a412389fb303f4facf0
:8636c65f0fdbdaf22adbf16e63b6a114266e0672
:d2e46f8d00e1d50e7d18f35b586fe5fa173da2be
:27301f5062e80c3247bf89aaf21f0a6e3180168f
:3e7396aeb0cacf83a7416f50cad1ff2d2d5c1594
:f5eaf1025d72d2071112f7f918018e76f3c51c4d
:12b5d2c7adf0feb1491bee87c82156d08f2ce1e5
:9111d9fd40abe07c078feedf80828fe4a638c57e
:ba4eadfae3089189ad24469aeb56bfcb883e6a6c
:0bff8f7286651f2ba4c852161dc2a281a166f907

comment:
:My Hangul Key has not worked since the last update.
:I tryed to handle this by "preference" dialog window.
:after that this crash occurs everytime I try to select input method.

dso_list:
:/lib64/libdl-2.14.so glibc-2.14-3.x86_64 (Fedora Project) 1309021657
:/usr/lib/locale/locale-archive glibc-common-2.14-3.x86_64 (Fedora Project) 1309021644
:/lib64/ld-2.14.so glibc-2.14-3.x86_64 (Fedora Project) 1309021657
:/lib64/libgio-2.0.so.0.2800.8 glib2-2.28.8-1.fc15.x86_64 (Fedora Project) 1307866529
:/lib64/librt-2.14.so glibc-2.14-3.x86_64 (Fedora Project) 1309021657
:/lib64/libresolv-2.14.so glibc-2.14-3.x86_64 (Fedora Project) 1309021657
:/lib64/libpthread-2.14.so glibc-2.14-3.x86_64 (Fedora Project) 1309021657
:/lib64/libgthread-2.0.so.0.2800.8 glib2-2.28.8-1.fc15.x86_64 (Fedora Project) 1307866529
:/lib64/libc-2.14.so glibc-2.14-3.x86_64 (Fedora Project) 1309021657
:/usr/lib64/libibus-1.0.so.0.0.0 ibus-libs-1.3.99.20110419-7.fc15.x86_64 (Fedora Project) 1309603665
:/usr/bin/ibus-daemon ibus-1.3.99.20110419-7.fc15.x86_64 (Fedora Project) 1309603671
:/lib64/libglib-2.0.so.0.2800.8 glib2-2.28.8-1.fc15.x86_64 (Fedora Project) 1307866529
:/lib64/libselinux.so.1 libselinux-2.0.99-4.fc15.x86_64 (Fedora Project) 1302519607
:/lib64/libgmodule-2.0.so.0.2800.8 glib2-2.28.8-1.fc15.x86_64 (Fedora Project) 1307866529
:/lib64/libz.so.1.2.5 zlib-1.2.5-3.fc15.x86_64 (Fedora Project) 1302517242
:/lib64/libnss_files-2.14.so glibc-2.14-3.x86_64 (Fedora Project) 1309021657
:/lib64/libgobject-2.0.so.0.2800.8 glib2-2.28.8-1.fc15.x86_64 (Fedora Project) 1307866529

environ:
:SHELL=/bin/bash
:DBUS_STARTER_ADDRESS=unix:abstract=/tmp/dbus-tIg0wx3BEb,guid=78ecbc96e674ed98b73b402900000333
:XDG_SESSION_COOKIE=bd7a6f3f9dcd6b375a06e4190000000a-1309673089.985259-249517784
:XDG_RUNTIME_DIR=/run/user/routitz
:DISPLAY=:0
:DESKTOP_SESSION=gnome
:WINDOWPATH=7
:PATH=/usr/local/bin:/usr/bin:/bin
:GDMSESSION=gnome
:USERNAME=routitz
:XDG_SESSION_ID=5
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-tIg0wx3BEb,guid=78ecbc96e674ed98b73b402900000333
:XAUTHORITY=/var/run/gdm/auth-for-routitz-VCf4c5/database
:USER=routitz
:DBUS_STARTER_BUS_TYPE=session
:GNOME_KEYRING_PID=4650
:SHLVL=1
:PWD=/home/routitz
:GDM_LANG=en_US.utf8
:GNOME_KEYRING_CONTROL=/tmp/keyring-VHB6Uc
:LANG=en_US.utf8
:_=/usr/bin/dbus-launch
:LOGNAME=routitz
:HOME=/home/routitz
:LC_CTYPE=en_US.utf8
:GTK_IM_MODULE=ibus
:QT_IM_MODULE=xim
:XMODIFIERS=@im=ibus

maps:
:00400000-00429000 r-xp 00000000 fd:01 1315488                            /usr/bin/ibus-daemon
:00629000-0062c000 rw-p 00029000 fd:01 1315488                            /usr/bin/ibus-daemon
:019e8000-01b25000 rw-p 00000000 00:00 0                                  [heap]
:3998c00000-3998c42000 r-xp 00000000 fd:01 1321955                        /usr/lib64/libibus-1.0.so.0.0.0
:3998c42000-3998e41000 ---p 00042000 fd:01 1321955                        /usr/lib64/libibus-1.0.so.0.0.0
:3998e41000-3998e44000 rw-p 00041000 fd:01 1321955                        /usr/lib64/libibus-1.0.so.0.0.0
:3bcae00000-3bcae1f000 r-xp 00000000 fd:01 2752538                        /lib64/ld-2.14.so
:3bcb01e000-3bcb01f000 r--p 0001e000 fd:01 2752538                        /lib64/ld-2.14.so
:3bcb01f000-3bcb020000 rw-p 0001f000 fd:01 2752538                        /lib64/ld-2.14.so
:3bcb020000-3bcb021000 rw-p 00000000 00:00 0 
:3bcb200000-3bcb38f000 r-xp 00000000 fd:01 2752901                        /lib64/libc-2.14.so
:3bcb38f000-3bcb58e000 ---p 0018f000 fd:01 2752901                        /lib64/libc-2.14.so
:3bcb58e000-3bcb592000 r--p 0018e000 fd:01 2752901                        /lib64/libc-2.14.so
:3bcb592000-3bcb593000 rw-p 00192000 fd:01 2752901                        /lib64/libc-2.14.so
:3bcb593000-3bcb599000 rw-p 00000000 00:00 0 
:3bcba00000-3bcba16000 r-xp 00000000 fd:01 2758428                        /lib64/libpthread-2.14.so
:3bcba16000-3bcbc15000 ---p 00016000 fd:01 2758428                        /lib64/libpthread-2.14.so
:3bcbc15000-3bcbc16000 r--p 00015000 fd:01 2758428                        /lib64/libpthread-2.14.so
:3bcbc16000-3bcbc17000 rw-p 00016000 fd:01 2758428                        /lib64/libpthread-2.14.so
:3bcbc17000-3bcbc1b000 rw-p 00000000 00:00 0 
:3bcbe00000-3bcbe02000 r-xp 00000000 fd:01 2758429                        /lib64/libdl-2.14.so
:3bcbe02000-3bcc002000 ---p 00002000 fd:01 2758429                        /lib64/libdl-2.14.so
:3bcc002000-3bcc003000 r--p 00002000 fd:01 2758429                        /lib64/libdl-2.14.so
:3bcc003000-3bcc004000 rw-p 00003000 fd:01 2758429                        /lib64/libdl-2.14.so
:3bcc200000-3bcc207000 r-xp 00000000 fd:01 2758445                        /lib64/librt-2.14.so
:3bcc207000-3bcc406000 ---p 00007000 fd:01 2758445                        /lib64/librt-2.14.so
:3bcc406000-3bcc407000 r--p 00006000 fd:01 2758445                        /lib64/librt-2.14.so
:3bcc407000-3bcc408000 rw-p 00007000 fd:01 2758445                        /lib64/librt-2.14.so
:3bcc600000-3bcc616000 r-xp 00000000 fd:01 2758425                        /lib64/libz.so.1.2.5
:3bcc616000-3bcc816000 ---p 00016000 fd:01 2758425                        /lib64/libz.so.1.2.5
:3bcc816000-3bcc817000 rw-p 00016000 fd:01 2758425                        /lib64/libz.so.1.2.5
:3bcce00000-3bcce1d000 r-xp 00000000 fd:01 2758434                        /lib64/libselinux.so.1
:3bcce1d000-3bcd01c000 ---p 0001d000 fd:01 2758434                        /lib64/libselinux.so.1
:3bcd01c000-3bcd01d000 r--p 0001c000 fd:01 2758434                        /lib64/libselinux.so.1
:3bcd01d000-3bcd01e000 rw-p 0001d000 fd:01 2758434                        /lib64/libselinux.so.1
:3bcd01e000-3bcd01f000 rw-p 00000000 00:00 0 
:3bcd200000-3bcd315000 r-xp 00000000 fd:01 2758447                        /lib64/libglib-2.0.so.0.2800.8
:3bcd315000-3bcd515000 ---p 00115000 fd:01 2758447                        /lib64/libglib-2.0.so.0.2800.8
:3bcd515000-3bcd516000 rw-p 00115000 fd:01 2758447                        /lib64/libglib-2.0.so.0.2800.8
:3bcd516000-3bcd517000 rw-p 00000000 00:00 0 
:3bcd600000-3bcd617000 r-xp 00000000 fd:01 2758433                        /lib64/libresolv-2.14.so
:3bcd617000-3bcd817000 ---p 00017000 fd:01 2758433                        /lib64/libresolv-2.14.so
:3bcd817000-3bcd818000 r--p 00017000 fd:01 2758433                        /lib64/libresolv-2.14.so
:3bcd818000-3bcd819000 rw-p 00018000 fd:01 2758433                        /lib64/libresolv-2.14.so
:3bcd819000-3bcd81b000 rw-p 00000000 00:00 0 
:3bcda00000-3bcda04000 r-xp 00000000 fd:01 2758448                        /lib64/libgthread-2.0.so.0.2800.8
:3bcda04000-3bcdc03000 ---p 00004000 fd:01 2758448                        /lib64/libgthread-2.0.so.0.2800.8
:3bcdc03000-3bcdc04000 rw-p 00003000 fd:01 2758448                        /lib64/libgthread-2.0.so.0.2800.8
:3bcde00000-3bcde4c000 r-xp 00000000 fd:01 2758449                        /lib64/libgobject-2.0.so.0.2800.8
:3bcde4c000-3bce04b000 ---p 0004c000 fd:01 2758449                        /lib64/libgobject-2.0.so.0.2800.8
:3bce04b000-3bce04d000 rw-p 0004b000 fd:01 2758449                        /lib64/libgobject-2.0.so.0.2800.8
:3bce04d000-3bce04e000 rw-p 00000000 00:00 0 
:3bce200000-3bce203000 r-xp 00000000 fd:01 2758450                        /lib64/libgmodule-2.0.so.0.2800.8
:3bce203000-3bce402000 ---p 00003000 fd:01 2758450                        /lib64/libgmodule-2.0.so.0.2800.8
:3bce402000-3bce403000 rw-p 00002000 fd:01 2758450                        /lib64/libgmodule-2.0.so.0.2800.8
:3bcea00000-3bceb21000 r-xp 00000000 fd:01 2758451                        /lib64/libgio-2.0.so.0.2800.8
:3bceb21000-3bced20000 ---p 00121000 fd:01 2758451                        /lib64/libgio-2.0.so.0.2800.8
:3bced20000-3bced26000 rw-p 00120000 fd:01 2758451                        /lib64/libgio-2.0.so.0.2800.8
:3bced26000-3bced27000 rw-p 00000000 00:00 0 
:7ff890000000-7ff890022000 rw-p 00000000 00:00 0 
:7ff890022000-7ff894000000 ---p 00000000 00:00 0 
:7ff898000000-7ff898022000 rw-p 00000000 00:00 0 
:7ff898022000-7ff89c000000 ---p 00000000 00:00 0 
:7ff89cbff000-7ff89cc00000 ---p 00000000 00:00 0 
:7ff89cc00000-7ff89d400000 rw-p 00000000 00:00 0 
:7ff89d400000-7ff89d401000 ---p 00000000 00:00 0 
:7ff89d401000-7ff89dc01000 rw-p 00000000 00:00 0 
:7ff89dc01000-7ff89dc02000 ---p 00000000 00:00 0 
:7ff89dc02000-7ff89e402000 rw-p 00000000 00:00 0 
:7ff89e402000-7ff89e40e000 r-xp 00000000 fd:01 2758409                    /lib64/libnss_files-2.14.so
:7ff89e40e000-7ff89e60d000 ---p 0000c000 fd:01 2758409                    /lib64/libnss_files-2.14.so
:7ff89e60d000-7ff89e60e000 r--p 0000b000 fd:01 2758409                    /lib64/libnss_files-2.14.so
:7ff89e60e000-7ff89e60f000 rw-p 0000c000 fd:01 2758409                    /lib64/libnss_files-2.14.so
:7ff89e60f000-7ff8a4a32000 r--p 00000000 fd:01 1337925                    /usr/lib/locale/locale-archive
:7ff8a4a32000-7ff8a4a3a000 rw-p 00000000 00:00 0 
:7ff8a4a59000-7ff8a4a5a000 rw-p 00000000 00:00 0 
:7ffffae92000-7ffffaeb3000 rw-p 00000000 00:00 0                          [stack]
:7ffffafcb000-7ffffafcc000 r-xp 00000000 00:00 0                          [vdso]
:ffffffffff600000-ffffffffff601000 r-xp 00000000 00:00 0                  [vsyscall]

var_log_messages:
:Jul  3 15:02:19 localhost abrt[3536]: saved core dump of pid 2690 (/usr/bin/ibus-daemon) to /var/spool/abrt/ccpp-2011-07-03-15:02:19-2690.new/coredump (27389952 bytes)
:Jul  3 15:02:21 localhost abrt[3563]: not dumping repeating crash in '/usr/bin/ibus-daemon'
:Jul  3 15:02:23 localhost abrt[3588]: not dumping repeating crash in '/usr/bin/ibus-daemon'
:Jul  3 15:02:25 localhost abrt[3607]: not dumping repeating crash in '/usr/bin/ibus-daemon'
:Jul  3 15:03:05 localhost abrt[4286]: saved core dump of pid 4213 (/usr/bin/ibus-daemon) to /var/spool/abrt/ccpp-2011-07-03-15:03:05-4213.new/coredump (27123712 bytes)
:Jul  3 15:03:07 localhost abrt[4320]: not dumping repeating crash in '/usr/bin/ibus-daemon'
:Jul  3 15:04:00 localhost abrt[4366]: saved core dump of pid 4321 (/usr/bin/ibus-daemon) to /var/spool/abrt/ccpp-2011-07-03-15:04:00-4321.new/coredump (27389952 bytes)
:Jul  3 15:04:10 localhost abrt[4401]: not dumping repeating crash in '/usr/bin/ibus-daemon'
:Jul  3 15:04:12 localhost abrt[4419]: not dumping repeating crash in '/usr/bin/ibus-daemon'
:Jul  3 15:04:18 localhost abrt[4438]: not dumping repeating crash in '/usr/bin/ibus-daemon'
:Jul  3 15:04:20 localhost abrt[4456]: saved core dump of pid 4439 (/usr/bin/ibus-daemon) to /var/spool/abrt/ccpp-2011-07-03-15:04:20-4439.new/coredump (35651584 bytes)
:Jul  3 15:04:26 localhost abrt[4491]: not dumping repeating crash in '/usr/bin/ibus-daemon'
:Jul  3 15:04:27 localhost abrt[4509]: not dumping repeating crash in '/usr/bin/ibus-daemon'
:Jul  3 15:04:28 localhost abrt[4526]: not dumping repeating crash in '/usr/bin/ibus-daemon'
:Jul  3 15:04:29 localhost abrt[4544]: not dumping repeating crash in '/usr/bin/ibus-daemon'
:Jul  3 15:05:07 localhost abrt[5205]: saved core dump of pid 5143 (/usr/bin/ibus-daemon) to /var/spool/abrt/ccpp-2011-07-03-15:05:07-5143.new/coredump (27217920 bytes)
Comment 1 Insang Ryu 2011-07-03 02:36:19 EDT
I believe that key shortcut function is broken between ibus-libs-1.3.99.20110408-2 and ibus-libs-1.3.99.20110419-7.

I can change my input method as I set with shortcut key while I'm using ibus-libs-1.3.99.20110408-2.

But When I'm using ibus-libs-1.3.99.20110419-7, pressing shortcut key crashes ibus or ibus do not work anything.
Comment 2 fujiwara 2011-07-04 03:37:02 EDT
OK, I could reproduce this problem.

The workaround is:
1. Run 'ibus-setup' command
2. Enable "Use system keyboard layout" in "Advanced" tab

Then the problem is no longer happened.

> IBUS:ERROR:ibuskeymap.c:282:ibus_keymap_lookup_keysym: assertion failed: 
> (IBUS_IS_KEYMAP (keymap))

OK, I see the default layout is failed.
Comment 3 Fedora Update System 2011-07-04 23:58:36 EDT
ibus-1.3.99.20110419-8.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/ibus-1.3.99.20110419-8.fc15
Comment 4 fujiwara 2011-07-05 00:01:32 EDT
*** Bug 718497 has been marked as a duplicate of this bug. ***
Comment 5 Fedora Update System 2011-07-06 17:26:48 EDT
Package ibus-1.3.99.20110419-9.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ibus-1.3.99.20110419-9.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/ibus-1.3.99.20110419-9.fc15
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2011-07-08 14:00:31 EDT
ibus-1.3.99.20110419-9.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Insang Ryu 2011-07-10 14:05:07 EDT
Thank you guys. Good luck to you :-)

Note You need to log in before you can comment on or make changes to this bug.