Bug 718721 - [gnome-terminal] fails to run
[gnome-terminal] fails to run
Status: CLOSED DUPLICATE of bug 755992
Product: Fedora
Classification: Fedora
Component: gnome-terminal (Show other bugs)
rawhide
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
: Reopened
: 720119 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-04 08:23 EDT by Joachim Frieben
Modified: 2012-01-12 08:53 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-01-12 08:53:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joachim Frieben 2011-07-04 08:23:30 EDT
Description of problem:
For the latest "rawhide" tree, gnome-terminal fails to start and an error message is returned to the shell from which is was launched:

$ gnome-terminal
**
ERROR:terminal-app.c:1449:terminal_app_init: assertion failed: (app->default_profile_id != NULL)
Abort

Version-Release number of selected component (if applicable):
gnome-terminal-3.0.1-1.fc16

How reproducible:
Always.

Steps to Reproduce:
1. Run 'gnome-terminal' from a shell.

Actual results:
gnome-terminal aborts.

Expected results:
A new instance of gnome-terminal is launched successfully.

Additional info:
None.
Comment 1 Joachim Frieben 2011-07-08 04:19:54 EDT
Fixed in "rawhide" as of 2011-07-07.
Comment 2 Tom London 2011-07-09 13:36:31 EDT
*** Bug 720119 has been marked as a duplicate of this bug. ***
Comment 3 Tom London 2011-07-09 13:39:28 EDT
This continues to not work for me, and I believe my system is up-to-date Rawhide/koji.

Here is the top of the stack trace I get when running 'gdb gnome-terminal':

ERROR:terminal-app.c:1449:terminal_app_init: assertion failed:
(app->default_profile_id != NULL)

Program received signal SIGABRT, Aborted.
0x0000003fe7436305 in __GI_raise (sig=6) at
../nptl/sysdeps/unix/sysv/linux/raise.c:64
64        return INLINE_SYSCALL (tgkill, 3, pid, selftid, sig);
(gdb) bt full
#0  0x0000003fe7436305 in __GI_raise (sig=6) at
../nptl/sysdeps/unix/sysv/linux/raise.c:64
        resultvar = 0
        pid = <optimized out>
        selftid = <optimized out>
#1  0x0000003fe7437c1b in __GI_abort () at abort.c:93
        save_stage = 2
        act = {__sigaction_handler = {sa_handler = 0, sa_sigaction = 0},
sa_mask = {__val = {140737327208466, 
    274462698488, 140737326809088, 2048, 4294967296, 7476512, 7476512,
4294967295, 7722912, 7755792, 7755792, 
    3239992, 0, 0, 7555584, 140737326817280}}, sa_flags = -419372892,
sa_restorer = 0x7fff00000005}
        sigs = {__val = {32, 0 <repeats 15 times>}}
#2  0x00007ffff665964d in g_assertion_message (domain=<optimized out>,
file=<optimized out>, 
    line=<optimized out>, func=0x438390 "terminal_app_init", message=
    0x75bf00 "assertion failed: (app->default_profile_id != NULL)") at
gtestutils.c:1425
        lstr = 
   
"1449\000\177\000\000\060\327\377\377\377\177\000\000\220\200C\000\000\000\000\000\370\200C\000\000\000\000"
        s = 0x765810 ""
#3  0x00007ffff6659b72 in g_assertion_message_expr (domain=0x0, file=0x437c3a
"terminal-app.c", line=1449, func=
    0x438390 "terminal_app_init", expr=<optimized out>) at gtestutils.c:1436
        s = <optimized out>
#4  0x0000000000417e1c in terminal_app_init (app=0x729070 [TerminalApp]) at
terminal-app.c:1449
        error = 0x0

The complete typescript of the gdb run is attached to https://bugzilla.redhat.com/show_bug.cgi?id=720119
Comment 4 Daniel Walsh 2011-07-11 16:21:44 EDT
I am seeing the same thing.  There has not been a new gnome-terminal built since April.  What am I missing?
Comment 5 Daniel Walsh 2011-07-11 16:24:01 EDT
> gconftool-2 -g /apps/gnome-terminal/global/default_profile
No value set for `/apps/gnome-terminal/global/default_profile'
Comment 6 Tom London 2011-07-12 09:26:45 EDT
Yeah, me too:

[tbl@tlondon ~]$ gconftool-2 -g /apps/gnome-terminal/global/default_profile
No value set for `/apps/gnome-terminal/global/default_profile'
[tbl@tlondon ~]$
Comment 7 Tom London 2011-07-13 09:46:59 EDT
OK, I think I figured out how to dig out of this hole....

Appears that the expected [gd]conf settings 'sort of changed'.

I did the following:

1. cd ~/.gconf/apps
2. mv gnome-terminal gnome-terminal.save
3. logout
4. log back in

gnome-terminal now starts for me. And,

[tbl@tlondon apps]$ gconftool-2 -g /apps/gnome-terminal/global/default_profile
Default
[tbl@tlondon apps]$ 

Joy and bliss.....
Comment 8 Fedora Admin XMLRPC Client 2012-01-10 10:49:30 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 9 Fedora Admin XMLRPC Client 2012-01-10 10:51:16 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 10 Matthias Clasen 2012-01-12 08:53:09 EST

*** This bug has been marked as a duplicate of bug 755992 ***

Note You need to log in before you can comment on or make changes to this bug.