Bug 720119 - 1449:terminal_app_init: assertion failed: (app->default_profile_id != NULL)"
1449:terminal_app_init: assertion failed: (app->default_profile_id != NULL)"
Status: CLOSED DUPLICATE of bug 718721
Product: Fedora
Classification: Fedora
Component: gnome-terminal (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Behdad Esfahbod
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-09 12:06 EDT by Tom London
Modified: 2011-07-09 13:36 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-09 13:36:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
output of 'gdb gnome-terminal" (7.48 KB, text/plain)
2011-07-09 12:06 EDT, Tom London
no flags Details

  None (edit)
Description Tom London 2011-07-09 12:06:16 EDT
Created attachment 512049 [details]
output of 'gdb gnome-terminal"

Description of problem:
gnome-terminal won't start (gnome-terminal-3.0.1-1.fc16.x86_64).

I've had to 'revert' to xterm....

Here is the top of the stack trace from gdb.  Complete gdb output attached.

ERROR:terminal-app.c:1449:terminal_app_init: assertion failed: (app->default_profile_id != NULL)

Program received signal SIGABRT, Aborted.
0x0000003fe7436305 in __GI_raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
64        return INLINE_SYSCALL (tgkill, 3, pid, selftid, sig);
(gdb) bt full
#0  0x0000003fe7436305 in __GI_raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
        resultvar = 0
        pid = <optimized out>
        selftid = <optimized out>
#1  0x0000003fe7437c1b in __GI_abort () at abort.c:93
        save_stage = 2
        act = {__sigaction_handler = {sa_handler = 0, sa_sigaction = 0}, sa_mask = {__val = {140737327208466, 
    274462698488, 140737326809088, 2048, 4294967296, 7476512, 7476512, 4294967295, 7722912, 7755792, 7755792, 
    3239992, 0, 0, 7555584, 140737326817280}}, sa_flags = -419372892, sa_restorer = 0x7fff00000005}
        sigs = {__val = {32, 0 <repeats 15 times>}}
#2  0x00007ffff665964d in g_assertion_message (domain=<optimized out>, file=<optimized out>, 
    line=<optimized out>, func=0x438390 "terminal_app_init", message=
    0x75bf00 "assertion failed: (app->default_profile_id != NULL)") at gtestutils.c:1425
        lstr = 
    "1449\000\177\000\000\060\327\377\377\377\177\000\000\220\200C\000\000\000\000\000\370\200C\000\000\000\000"
        s = 0x765810 ""
#3  0x00007ffff6659b72 in g_assertion_message_expr (domain=0x0, file=0x437c3a "terminal-app.c", line=1449, func=
    0x438390 "terminal_app_init", expr=<optimized out>) at gtestutils.c:1436
        s = <optimized out>
#4  0x0000000000417e1c in terminal_app_init (app=0x729070 [TerminalApp]) at terminal-app.c:1449
        error = 0x0


Version-Release number of selected component (if applicable):
gnome-terminal-3.0.1-1.fc16.x86_64

How reproducible:
Every time.

Steps to Reproduce:
1. try to start either from xterm, gdb, or from 'menu'
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Tom London 2011-07-09 13:28:27 EDT
Googling uncovered this: https://bugzilla.gnome.org/show_bug.cgi?id=564649

Related?
Comment 2 Tom London 2011-07-09 13:36:31 EDT

*** This bug has been marked as a duplicate of bug 718721 ***

Note You need to log in before you can comment on or make changes to this bug.