This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 718900 - duplicate ibus icon at the panel after restarting
duplicate ibus icon at the panel after restarting
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-04 23:21 EDT by Akira TAGOH
Modified: 2011-07-14 07:15 EDT (History)
7 users (show)

See Also:
Fixed In Version: ibus-1.3.99.20110419-10.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-14 07:15:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Akira TAGOH 2011-07-04 23:21:11 EDT
Description of problem:
Once restarting ibus from imsettings, the ibus icon is duplicated at the panel.

Version-Release number of selected component (if applicable):
ibus-1.3.99.20110419-7.fc15.x86_64
ibus-gtk2-1.3.99.20110419-7.fc15.x86_64
ibus-gtk3-1.3.99.20110419-7.fc15.x86_64
ibus-gnome3-1.3.99.20110419-7.fc15.x86_64

How reproducible:
always

Steps to Reproduce:
1.run imsettings-switch -rnq on the terminal
2.
3.
  
Actual results:
GTK+2 version of the ibus icon appears at the panel and GNOME3 version of the ibus icon keeps there as well.

Expected results:
only one should be kept there.

Additional info:
I don't know if I should file another bug but the gnome3 version of the ibus icon doesn't go away by killing ibus process. it may be relevant to this issue.
Comment 1 fujiwara 2011-07-05 00:15:45 EDT
This is a known issue.
Actually ibus-gnome3 is a test package.

The candidate patch removes the icon in upstream:
https://bugzilla.gnome.org/show_bug.cgi?id=641531


The workaround is to remove 'ibus-ui-gtk' by manual in:
/usr/share/gnome-shell/js/ui/statusIconDispatcher.js

Probably I think this would be a good bug for f16 integration plan.
Comment 2 Akira TAGOH 2011-07-05 00:46:44 EDT
Well, does it also fix the issue I'm mainly concerned here, which the non-gnome3 icons appears on the panel when restarting?
Comment 3 fujiwara 2011-07-05 03:43:49 EDT
(In reply to comment #2)
> Well, does it also fix the issue I'm mainly concerned here, which the
> non-gnome3 icons appears on the panel when restarting?

OK, I understood the problem now.
Reverting the category again.
Comment 4 fujiwara 2011-07-05 07:04:32 EDT
https://github.com/fujiwarat/ibus/commit/cb9044a0611193d7a7d6ab746da8b93295a44d5a

I updated ui/gjs-g-s/indicator.js .
Comment 5 Fedora Update System 2011-07-08 04:04:39 EDT
ibus-1.3.99.20110419-10.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/ibus-1.3.99.20110419-10.fc15
Comment 6 Fedora Update System 2011-07-08 14:02:48 EDT
Package ibus-1.3.99.20110419-10.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ibus-1.3.99.20110419-10.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/ibus-1.3.99.20110419-10.fc15
then log in and leave karma (feedback).
Comment 7 Akira TAGOH 2011-07-11 04:37:08 EDT
Once installing the updated package and restart the desktop, I don't see gnome3 version of ibus icon anymore even though I have ibus-gnome3 package installed. is it expected behavior in this fix?
Comment 8 Fedora Update System 2011-07-12 01:12:08 EDT
ibus-1.3.99.20110419-10.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 fujiwara 2011-07-12 23:12:47 EDT
(In reply to comment #7)
> Once installing the updated package and restart the desktop, I don't see gnome3
> version of ibus icon anymore even though I have ibus-gnome3 package installed.
> is it expected behavior in this fix?

It's strange with me.
Are all ibus* 1.3.99.20110419-10 ? ibus-gnome3 is also needed.
Comment 10 Akira TAGOH 2011-07-13 01:19:06 EDT
Hmm, behavior isn't stable for me and I still see this issue when:

1. log into the desktop
2. open a terminal
3. imsettings-switch none
4. imsettings-switch ibus

This happens only once after the startup with the above steps. following step 3 and 4 after that still appears the gtk2 version of ibus icon though, it's hidden soon.
Comment 11 fujiwara 2011-07-13 05:53:22 EDT
(In reply to comment #10)
> Hmm, behavior isn't stable for me and I still see this issue when:
> 
> 1. log into the desktop
> 2. open a terminal
> 3. imsettings-switch none
> 4. imsettings-switch ibus
> 
> This happens only once after the startup with the above steps. following step 3
> and 4 after that still appears the gtk2 version of ibus icon though, it's
> hidden soon.

I could understand your issue but probably it may be related with the specs.
The dbus connections are upstreamed except for gjs parts.
Currently the suggestion is we should not close the ibus connection but the connection can be replaced with another connection.
Previously I suggested to check the existence of gnome-shell with a dbus method but the special condition is not agreed.

The current logic is:
1. ibus-daemon launch gtk icon.
2. gnome-shell ibus launch the gjs icon which can replace gtk icon.

So the gtk icon is shown slightly.

Currently I have no idea to have the better specs without the special condition.
If you think this is a critical issue,  we may be able to add an internal patch for Fedora only. Hmm...
I think the logic should work with either classic GNOME(GNOME 2) and gnome-shell.
Comment 12 Akira TAGOH 2011-07-13 06:44:56 EDT
Ideally it should simply appears one icon anyway though, appearing two icons and hiding one may be still acceptable. I just explained what I saw in some testing. so you could ignore that perhaps. but are you saying even keeping two icons in the first case is also not a bug? I'm afraid I can't agree with it since it's working as expected at the end in next restart as I mentioned at the last in comment#10.
Comment 13 fujiwara 2011-07-14 07:15:39 EDT
(In reply to comment #12)
> testing. so you could ignore that perhaps. but are you saying even keeping two
> icons in the first case is also not a bug? I'm afraid I can't agree with it

OK, I revised the logic slightly. The original bug is fixed and other issues can be discussed with bug 720884.

Note You need to log in before you can comment on or make changes to this bug.