Bug 71911 - CD switching does not work
CD switching does not work
Status: CLOSED DUPLICATE of bug 72086
Product: Red Hat Public Beta
Classification: Retired
Component: redhat-config-packages (Show other bugs)
null
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks: 67218
  Show dependency treegraph
 
Reported: 2002-08-20 01:32 EDT by Steve Fox
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-21 03:29:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Fox 2002-08-20 01:32:06 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/0

Description of problem:
Installing packages which exist on multiple CDs fails and requires restarting
the tool several times while CDs are exchanged.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
I tried to install Galeon, Balsa, and Quanta and remove Emacs. Galeon was on the
first CD and the latter were on the third CD. The first time it removed Emacs,
then tried to install Galeon. It prompted me for the CD, but when I put it in,
it kept telling me that it can't find the CD. The dialog box had an empty string
for the label of the CD, but it did say disc 2. Autofs kicked in and a Nautilus
window appeared, but retrying the install kept returning the error. 

I restarted the tool and Emacs was uninstalled. However, none of my new packages
were installed. Disc 2 was still loaded and this time the installer found Galeon
and installed it. Then it tried to install Balsa and Quanta from disc 3, but the
same thing happened (I had to manually unmount disc 2 because the CD-ROM eject
button would not work). This time it tried to load "" disc 3 (again no label)
and failed. Once again I restart the tool and Galeon is installed. I select
Balsa and Quanta after making sure that autofs has loaded disc 3 properly. The
install finishes.

Expected Results:  Something (autofs, or redhat-config-packages) needs to handle
the swapping of CDs better.

Additional info:
Comment 1 Richard Torkar 2002-08-21 03:29:52 EDT

I can confirm this for Red Hat null.

The exact same thing happens on my workstation.

/Richard
Comment 2 Jeremy Katz 2002-08-26 02:38:23 EDT

*** This bug has been marked as a duplicate of 72086 ***

Note You need to log in before you can comment on or make changes to this bug.