Bug 719124 - GFS2: tunegfs2 tries to open device when none specified
Summary: GFS2: tunegfs2 tries to open device when none specified
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: cluster
Version: 6.2
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: ---
Assignee: Andrew Price
QA Contact: Cluster QE
URL:
Whiteboard:
Depends On:
Blocks: 704178
TreeView+ depends on / blocked
 
Reported: 2011-07-05 20:11 UTC by Nate Straz
Modified: 2011-12-06 14:52 UTC (History)
5 users (show)

Fixed In Version: cluster-3.0.12.1-7.el6
Doc Type: Bug Fix
Doc Text:
Cause: Some argument validation functions were not returning error values Consequence: tunegfs2 would needlessly print confusing error messages instead of exiting quietly Fix: Error handling was improved in these validation functions Result: tunegfs2 now exits quietly instead of printing the confusing error messages
Clone Of:
Environment:
Last Closed: 2011-12-06 14:52:22 UTC


Attachments (Terms of Use)
Upstream patch (4.60 KB, patch)
2011-07-14 14:36 UTC, Steve Whitehouse
no flags Details | Diff
Patch for RHEL6 (5.20 KB, patch)
2011-07-25 17:06 UTC, Andrew Price
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1516 normal SHIPPED_LIVE cluster and gfs2-utils bug fix update 2011-12-06 00:51:09 UTC

Description Nate Straz 2011-07-05 20:11:26 UTC
Description of problem:

In cases where tunegfs2 should exit instead of working on a device it prints out an error instead

1. No device specified:
# tunegfs2
Unable to open device (null)

2. List help options
# tunegfs2 -h
Usage: tunegfs2 -L <volume label> -U <UUID> -l -o <mount options> <device>
Unable to open device (null)

3. Print version number
# tunegfs2 -V
tunegfs2 (Jun 23 2011 05:03:50)
Unable to open device (null)

Version-Release number of selected component (if applicable):
gfs2-utils-3.0.12.1-5.el6.x86_64

How reproducible:
Every time

Steps to Reproduce:
1. tunegfs2
2. tunegfs2 -h
3. tunegfs2 -V
  
Actual results:
See above

Expected results:

# tunegfs2
Usage: tunegfs2 -L <volume label> -U <UUID> -l -o <mount options> <device>

# tunegfs2 -h
Usage: tunegfs2 -L <volume label> -U <UUID> -l -o <mount options> <device>

# tunegfs2 -V
tunegfs2 (Jun 23 2011 05:03:50)


Additional info:

Comment 2 Steve Whitehouse 2011-07-06 08:38:34 UTC
Harmless aside from the message, so not a high priority.

Comment 3 Steve Whitehouse 2011-07-14 14:36:35 UTC
Created attachment 513201 [details]
Upstream patch

Comment 4 Andrew Price 2011-07-25 17:06:25 UTC
Created attachment 515112 [details]
Patch for RHEL6

This is the upstream patch with the parts specific to bz#719126 discarded.

Comment 5 Andrew Price 2011-07-25 17:31:37 UTC
Patch is now in RHEL6 branch of cluster.git

Comment 8 Andrew Price 2011-07-27 08:18:27 UTC
Testing with gfs2-utils-3.0.12.1-7.el6.x86_64.rpm:

# tunegfs2
Incorrect number of arguments
Usage: tunegfs2 [-hlV] [-L <volume_label>] [-U <UUID>]
	[-o <mount_options>] <device> 
# tunegfs2 -h
Usage: tunegfs2 [-hlV] [-L <volume_label>] [-U <UUID>]
	[-o <mount_options>] <device> 
# tunegfs2 -V
tunegfs2 (Jul 26 2011 10:11:28)

Comment 9 Andrew Price 2011-10-27 11:55:19 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause:
Some argument validation functions were not returning error values
Consequence:
tunegfs2 would needlessly print confusing error messages instead of exiting quietly
Fix:
Error handling was improved in these validation functions
Result:
tunegfs2 now exits quietly instead of printing the confusing error messages

Comment 10 errata-xmlrpc 2011-12-06 14:52:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1516.html


Note You need to log in before you can comment on or make changes to this bug.