Bug 719126 - GFS2: help and version options are not listed in tunegfs2 usage message
Summary: GFS2: help and version options are not listed in tunegfs2 usage message
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: cluster
Version: 6.2
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: ---
Assignee: Andrew Price
QA Contact: Cluster QE
URL:
Whiteboard:
Depends On:
Blocks: 704178
TreeView+ depends on / blocked
 
Reported: 2011-07-05 20:15 UTC by Nate Straz
Modified: 2011-12-06 14:52 UTC (History)
5 users (show)

Fixed In Version: cluster-3.0.12.1-7.el6
Doc Type: Bug Fix
Doc Text:
Cause: The tunegfs2 command line usage message was not updated to reflect the arguments available, which are documented in the man page. Consequence: tunegfs2 printed an inaccurate usage message. Fix: The usage message was updated. Result: tunegfs2 now prints an accurate usage message.
Clone Of:
Environment:
Last Closed: 2011-12-06 14:52:26 UTC


Attachments (Terms of Use)
Patch to fix usage message (1.05 KB, patch)
2011-07-25 17:07 UTC, Andrew Price
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1516 normal SHIPPED_LIVE cluster and gfs2-utils bug fix update 2011-12-06 00:51:09 UTC

Description Nate Straz 2011-07-05 20:15:15 UTC
Description of problem:

The man page describes the -h and -V options, but they are not listed on the command line.


Version-Release number of selected component (if applicable):
gfs2-utils-3.0.12.1-5.el6.x86_64

How reproducible:
Every time

Steps to Reproduce:
1. tunegfs2
  
Actual results:
# tunegfs2 -h
Usage: tunegfs2 -L <volume label> -U <UUID> -l -o <mount options> <device>

Expected results:
# tunegfs2 -h
Usage: tunegfs2 [-hlV][-L <volume label>][-U <UUID>][-o <mount options>] <device>


Additional info:

Comment 2 Andrew Price 2011-07-25 17:07:54 UTC
Created attachment 515113 [details]
Patch to fix usage message

This is the usage message chunk of the upstream patch from bz#719124

Comment 3 Andrew Price 2011-07-25 17:31:39 UTC
Patch is now in RHEL6 branch of cluster.git

Comment 6 Andrew Price 2011-07-27 08:14:56 UTC
Using gfs2-utils-3.0.12.1-7.el6.x86_64.rpm:

# tunegfs2 
Incorrect number of arguments
Usage: tunegfs2 [-hlV] [-L <volume_label>] [-U <UUID>]
	[-o <mount_options>] <device> 
# tunegfs2 -V
tunegfs2 (Jul 26 2011 10:11:28)
# tunegfs2 -h
Usage: tunegfs2 [-hlV] [-L <volume_label>] [-U <UUID>]
	[-o <mount_options>] <device>

Comment 7 Andrew Price 2011-10-27 12:18:54 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause:
The tunegfs2 command line usage message was not updated to reflect the arguments available, which are documented in the man page.
Consequence:
tunegfs2 printed an inaccurate usage message.
Fix:
The usage message was updated.
Result:
tunegfs2 now prints an accurate usage message.

Comment 8 errata-xmlrpc 2011-12-06 14:52:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1516.html


Note You need to log in before you can comment on or make changes to this bug.