This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 71947 - Make gdm login box scale according to text length
Make gdm login box scale according to text length
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: gdm (Show other bugs)
8.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Owen Taylor
Mike McLean
: Triaged
: 72126 (view as bug list)
Depends On:
Blocks: 67218 79579
  Show dependency treegraph
 
Reported: 2002-08-20 08:58 EDT by Bernd Bartmann
Modified: 2007-04-18 12:45 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-20 14:55:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bernd Bartmann 2002-08-20 08:58:54 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
The login request in german (Bitte geben Sie Ihren Benutzernamen ein) is too 
wide for the dialog box. It't a cosmetic problem but looks strange.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Set german as your default language
2. Look at the login request in GDM
3.
	

Additional info:
Comment 1 Bill Nottingham 2002-08-22 01:32:43 EDT
*** Bug 72126 has been marked as a duplicate of this bug. ***
Comment 2 Havoc Pennington 2002-08-28 19:09:59 EDT
Alex how would we add support for scaling the box to the theme? 
(not sure which code to look at for fixing that)
Comment 3 Alexander Larsson 2002-08-29 03:05:41 EDT
The login "box" is a vbox with stuff packed in it, so it's width is gonna depend
on the width of the strings in it.

I think the best solution is to add a "width" property to the text object and
then pango_layout_set_width() with that. Hmmm. Or would that always make it that
wide and then left-align the text? What we want is some sort of max-width.

This is basically the same problem as the pam-string wrapping. I had to add that
badhack to make it work.
Comment 4 Bernd Bartmann 2002-10-03 09:12:47 EDT
Still not fixed in Red Hat 8.0
Comment 5 Alexander Larsson 2002-10-08 09:00:24 EDT
I thought hp worked on this?
Comment 6 Havoc Pennington 2002-10-08 09:53:12 EDT
Not fixed though.
Comment 7 Owen Taylor 2003-01-16 16:19:49 EST
Taking gdm target/blockers.
Comment 8 Owen Taylor 2003-01-17 12:09:06 EST
Hmm, in testing with current redhat-artwork and GDM, 
"Bitte geben Sie Ihren Benutzernamen ein" seems to fit for all
themes.

Which makes it sort of hard to work on this bug. This is at 800x600,
the highest that tired old monitor will do. I'd expect it to 
be _less_ of a problem at higher resolutions, however.

Does the problem still occur for your with gdm-2.4.1.0 from Raw Hide?

Comment 9 Bernd Bartmann 2003-01-17 14:08:04 EST
Seems to be already fixed for me with gdm-2.4.0.7-14 from Phoebe.
Comment 10 Owen Taylor 2003-01-20 14:55:01 EST
I'm not sure this is actually _fixed_ as opposed to just not a
problem with the current themes (it might show up with other
themes or even longer translations), but since it isn't a problem
currently I'm going to close.

Note You need to log in before you can comment on or make changes to this bug.