Bug 72000 - Xconfigurator does not produce a good XF86config file
Summary: Xconfigurator does not produce a good XF86config file
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: Xconfigurator (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
low
low
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
: 72002 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-08-20 17:08 UTC by Karl F. Larsen
Modified: 2005-10-31 22:00 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-20 19:46:53 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Karl F. Larsen 2002-08-20 17:08:55 UTC
Description of Problem:
For 2 days been trying to get a 1024X768 X window and it always defaults to a
800X600 size. Would look for a hardware problem but my RH 7.2 on the same
computer with same hardware has the 1024X768 size and was no problem.

Version-Release number of selected component (if applicable):
4.10.7

How Reproducible:

Total. It does it every time.


Steps to Reproduce:
1. Load RH 7.3 Set for 1024X768 X windows
 Start it and observe your window is 800X600
2. Ctrl Alt 2 to a root login and run Xconfigurator
3. Set it for and test a good 1024X768 config. Reboot and it comes up 800X600

Actual Results:

Unable to make desired size. Think the Xconfigurator software is buggy.
Expected Results:

I should be using version 7.3 right now.
Additional Information:

Comment 1 Mike A. Harris 2002-08-20 17:49:32 UTC
*** Bug 72002 has been marked as a duplicate of this bug. ***

Comment 2 Mike A. Harris 2002-08-20 17:53:26 UTC
You have not at all given ANY useful information that could remotely
help in debugging or troubleshooting this issue.  For starters,
supplying your X server log file, your generated X config files,
the brand/make/model of your video card might help.

Also include:  lspci -vvn

Without such information, I can do nothing else other than close the
bug as WORKSFORME, since this problem doesn't occur on ANY video
hardware that I have for testing.  It's also not been reported by
any other person so far, implying it isn't a widespread issue.


Comment 3 Karl F. Larsen 2002-08-20 18:03:13 UTC
I will try and find what your asking for. Then try to attch them to this report. 
How do I find lspci -vvn?

Comment 4 Karl F. Larsen 2002-08-20 19:46:49 UTC
OK! found the problem. Red Hat 7.3 loader does NOT load the kernel module tdfx
in 7.3 but does in 7.2. The tdfx module is for my Voodoo video card and without
it Xconfig will not work. 

So please change the bug report to one for the loader which doesn't load this
module. 

I found the problem myself looking at the Xserver log file, and didn't know that
log existed. it had the line "drm failed to load module tdfx".

I tried modprobe tdfx on version 7.3 and got "can't find...." Did the same on
version 7.2 and it loaded.

Thanks for the help. I may be back to find out How to get tdfx loaded in version
7.3 ...:-)

Comment 5 Karl F. Larsen 2002-08-21 01:49:40 UTC
To Red Hat: Close this bug. I entered a new bug for module tdfxfb.o which does
not work in version 7.3, but works fine in version 7.2 The new bug is #7284


Note You need to log in before you can comment on or make changes to this bug.