Bug 720034 - Error: unsupported locale setting
Error: unsupported locale setting
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Andreas Schwab
Fedora Extras Quality Assurance
firstboot_trace_hash:8af9834cddc0e55a...
:
: 721329 722380 (view as bug list)
Depends On:
Blocks: F16Alpha/F16AlphaBlocker
  Show dependency treegraph
 
Reported: 2011-07-08 15:28 EDT by Will Woods
Modified: 2016-11-24 11:15 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-26 07:52:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from firstboot. (4.79 KB, text/plain)
2011-07-08 15:28 EDT, Will Woods
no flags Details

  None (edit)
Description Will Woods 2011-07-08 15:28:45 EDT
The following was filed automatically by firstboot:
firstboot 1.116 exception report
Traceback (most recent call last):
  File "/usr/share/system-config-date/scdMainWindow.py", line 201, in custom_handler
    return module.custom_widgets[function_name] (glade)
  File "/usr/share/system-config-date/timezone_gui.py", line 43, in timezone_widget_create
    widget = TimezoneMap(zonetab.ZoneTab (), default, map=mappath, tzActionLabel = tzActionLabel)
  File "/usr/lib/python2.7/site-packages/scdate/core/zonetab.py", line 153, in __init__
    self.readZoneTab (fn)
  File "/usr/lib/python2.7/site-packages/scdate/core/zonetab.py", line 218, in readZoneTab
    entry = ZoneTabEntry (code, lat, long, tz, comments)
  File "/usr/lib/python2.7/site-packages/scdate/core/zonetab.py", line 59, in __init__
    self.tz = tz.replace ('_', ' ')
  File "/usr/lib/python2.7/site-packages/scdate/core/zonetab.py", line 127, in _set_tz
    self.__translate_tz()
  File "/usr/lib/python2.7/site-packages/scdate/core/zonetab.py", line 85, in __translate_tz
    locale.setlocale(locale.LC_ALL, "")
  File "/usr/lib64/python2.7/locale.py", line 531, in setlocale
    return _setlocale(category, locale)
Error: unsupported locale setting
Comment 1 Will Woods 2011-07-08 15:28:50 EDT
Created attachment 511985 [details]
Attached traceback automatically from firstboot.
Comment 2 Will Woods 2011-07-11 13:05:27 EDT
This happened because (somehow - not sure of the root cause yet) the locale database was missing/broken. After running:
  yum reinstall glibc-common
firstboot/s-c-d worked as expected.
Comment 3 Nils Philippsen 2011-07-12 09:00:48 EDT
I guess there's not much that can be done in this case if the locale database doesn't exist or is broken. Changing component to glibc, assuming that this is the only package that affects (or should affect) the locale database.
Comment 4 Iain Arnell 2011-07-13 08:59:37 EDT
The problem seems to be easily reproducible in mock. And seems particularly apparent when building perl packages (perl moans like hell that "Setting locale failed"). See, for example, http://kojipkgs.fedoraproject.org/packages/perlbrew/0.27/1.fc16/data/logs/noarch/

root.log shows

DEBUG util.py:250:  Non-fatal POSTIN scriptlet failure in rpm package glibc-common-2.14.90-1.i686
DEBUG util.py:250:  Non-fatal <unknown> scriptlet failure in rpm package glibc-common-2.14.90-1.i686
DEBUG util.py:250:  warning: %post(glibc-common-2.14.90-1.i686) scriptlet failed, exit status 127
DEBUG util.py:250:  warning: %triggerin(glibc-common-2.14.90-1.i686) scriptlet failed, exit status 127
Comment 5 Andreas Schwab 2011-07-14 08:01:34 EDT
*** Bug 721329 has been marked as a duplicate of this bug. ***
Comment 6 James Laska 2011-07-14 08:32:13 EDT
Carrying forward proposed Alpha blocker ... this is causing also causing the installer to crash when starting the live image which impacts the F16 Alpha criteria ...

 "The installer must boot (if appropriate) and run on all primary architectures from default live image, DVD, and boot.iso install media "
Comment 7 Andreas Schwab 2011-07-15 05:31:11 EDT
*** Bug 722380 has been marked as a duplicate of this bug. ***
Comment 8 Adam Williamson 2011-07-15 13:33:17 EDT
Discussed at the 2011-07-15 Alpha blocker review meeting. Accepted as a blocker under criterion "The installer must boot (if appropriate) and run on all primary architectures from default live image, DVD, and boot.iso install media".
Comment 9 Tim Flink 2011-07-22 18:02:39 EDT
Discussed at the 2011-07-22 alpha blocker bug review meeting.

There have been no new reports of this bug in a week. Is this still happening or can this bug be closed?
Comment 10 Iain Arnell 2011-07-23 00:05:47 EDT
I don't see it in mock any more since glibc-2.14.90-2.

Note You need to log in before you can comment on or make changes to this bug.