This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 721329 - Error: unsupported locale setting
Error: unsupported locale setting
Status: CLOSED DUPLICATE of bug 720034
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
rawhide
i386 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Andreas Schwab
Fedora Extras Quality Assurance
anaconda_trace_hash:e2e794540314b4503...
:
Depends On:
Blocks: F16Alpha/F16AlphaBlocker
  Show dependency treegraph
 
Reported: 2011-07-14 06:12 EDT by Tao Wu
Modified: 2014-10-28 19:45 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-14 08:01:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (354.84 KB, text/plain)
2011-07-14 06:12 EDT, Tao Wu
no flags Details

  None (edit)
Description Tao Wu 2011-07-14 06:12:34 EDT
The following was filed automatically by anaconda:
anaconda 16.11 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/locale.py", line 531, in setlocale
    return _setlocale(category, locale)
  File "/usr/lib/python2.7/site-packages/scdate/core/zonetab.py", line 85, in __translate_tz
    locale.setlocale(locale.LC_ALL, "")
  File "/usr/lib/python2.7/site-packages/scdate/core/zonetab.py", line 127, in _set_tz
    self.__translate_tz()
  File "/usr/lib/python2.7/site-packages/scdate/core/zonetab.py", line 59, in __init__
    self.tz = tz.replace ('_', ' ')
  File "/usr/lib/python2.7/site-packages/scdate/core/zonetab.py", line 218, in readZoneTab
    entry = ZoneTabEntry (code, lat, long, tz, comments)
  File "/usr/lib/python2.7/site-packages/scdate/core/zonetab.py", line 153, in __init__
    self.readZoneTab (fn)
  File "/usr/lib/python2.7/site-packages/pyanaconda/iw/timezone_gui.py", line 44, in __init__
    self.zonetab = zonetab.ZoneTab()
  File "/usr/lib/python2.7/site-packages/pyanaconda/gui.py", line 1267, in display_step
    self.currentWindow = newScreenClass(ics)
  File "/usr/lib/python2.7/site-packages/pyanaconda/gui.py", line 1156, in display_step
    return self.icw.display_step(step)
  File "/usr/lib/python2.7/site-packages/pyanaconda/dispatch.py", line 342, in dispatch
    rc = self.anaconda.intf.display_step(self.step)
  File "/usr/lib/python2.7/site-packages/pyanaconda/dispatch.py", line 235, in go_forward
    self.dispatch()
  File "/usr/lib/python2.7/site-packages/pyanaconda/gui.py", line 1200, in nextClicked
    self.anaconda.dispatch.go_forward()
Error: unsupported locale setting
Comment 1 Tao Wu 2011-07-14 06:12:40 EDT
Created attachment 512849 [details]
Attached traceback automatically from anaconda.
Comment 2 Tao Wu 2011-07-14 06:50:50 EDT
Hi folks,

The test used Fedora-16-Nightly-20110710.08-i686-Live-xfce.iso[1] under Virtual Machine Manager 0.8.7.  I select the 'Install to Hard Drive' after the live cd had been loaded and started up, then the anaconda runs and just crashed.


[1]http://koji.fedoraproject.org/koji/getfile?taskID=3189467&name=Fedora-16-Nightly-20110710.08-i686-Live-xfce.iso
Comment 3 Andreas Schwab 2011-07-14 08:01:34 EDT

*** This bug has been marked as a duplicate of bug 720034 ***

Note You need to log in before you can comment on or make changes to this bug.