Bug 72027 - double click on launcher in list view launches item twice
Summary: double click on launcher in list view launches item twice
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: nautilus   
(Show other bugs)
Version: null
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
: 73278 (view as bug list)
Depends On:
Blocks: 67218
TreeView+ depends on / blocked
 
Reported: 2002-08-20 19:46 UTC by Ben Levenson
Modified: 2015-01-07 23:59 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-23 13:15:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ben Levenson 2002-08-20 19:46:21 UTC
Description of Problem:
view as list
double click on item
2 items are launched

Version-Release number of selected component (if applicable):
nautilus-2.0.4-3

How Reproducible:
100%

Steps to Reproduce:
1. start here: applications: accessories
2. view as list
3. double click on calculator
4. 2 calcs are launched
5. close calcs and switch view to icons
6. double click on calc -> works as expected (only 1 item is launched)

Additional Information:
this isn't limited to items in this folder. I originally noticed it while
launching several of the gnome-preferences tools.

Comment 1 Havoc Pennington 2002-08-22 00:02:57 UTC
strange, I wonder if this was intentional

Comment 2 Alexander Larsson 2002-08-22 08:27:48 UTC
It's probaby a bug. I'll look into it.


Comment 3 Alexander Larsson 2002-08-23 13:15:21 UTC
This is a bug in the list view in combination with eggmultitreednd. the egg code
replays events when there wasn't a drag started. But the listview code listens
to event-after, so it gets two signals. Looks semi-nontrivial to fix.


Comment 4 Ben Levenson 2002-09-25 16:23:03 UTC
can't reproduce w/ nautilus-2.0.6-6. 
CLOSING -> RAWHIDE

Comment 5 Havoc Pennington 2002-10-01 16:36:53 UTC
*** Bug 73278 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.