Bug 72040 - ifup-post ifup-ppp ifup should test "$PEERDNS"="yes" instead of "$PEERDNS" != "no"
ifup-post ifup-ppp ifup should test "$PEERDNS"="yes" instead of "$PEERDNS" !=...
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
7.3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-20 16:43 EDT by Jhon H. Caicedo
Modified: 2014-03-16 22:30 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-29 16:15:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jhon H. Caicedo 2002-08-20 16:43:58 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020710

Description of problem:
As a result of bug #62127, redhat-config-network application 
doesn't add PEERDNS='no' to ifcfg-XXX file when the option 
"Automatically obtain DNS information from provider" is left 
unchecked. (It adds a line PEERDNS="yes") when you check this
option, which is ok)

The scripts ifup-post, ifup-ppp) check for "$PEERDNS" != "no", and 
since PEERDNS is NULL the conditional gets true and the 
/etc/resolv.conf is overwritten. I have tested this
with dialup and DHCP connections

The script ifup on the other hand checks for "$PEERDNS" = "no" 
in order to add the PUMPARGS and DHCPCDARGS to prevent the
overwrite of /etc/resolv.conf, it should be changed to 
"$PEERDNS" != "yes"


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Start redhat-config-network
2.Add or Edit a dialup, dhcp or boop device, try the option 
  "Automatically obtain DNS information from provider" unchecked
  and checked.
3.Enable/Disable this device to see changes in /etc/resolv.conf

Actual Results:  The ifcfg-XXX file doesn't contain a PEERDNS='no' 
line, and the /etc/resolv.conf file gets overwritten when you enable
the device.


Expected Results:  When I left uncheck the "Automatically.... provider" option,
I expect to use my own DNS servers and /etc/resolv.conf should not get
overwritten everytime.

Additional info:

The bug 62127 changes the behaviour of redhat-config-network
so it doesn't add the line PEERDNS='no'.

Maybe we should get redhat-config-network fixed instead of the
initscripts ?
Comment 1 Bill Nottingham 2005-09-29 16:15:03 EDT
Closing bugs on older, no longer supported, releases. Apologies for any lack of
response.

If this persists on a current release, such as Fedora Core 4, please open a new bug.

Note You need to log in before you can comment on or make changes to this bug.