Bug 62127 - PEERDNS=no should not be set, and saying 'yes' to chmod 644 should work
PEERDNS=no should not be set, and saying 'yes' to chmod 644 should work
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: redhat-config-network (Show other bugs)
skipjack-beta1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
:
: 62839 (view as bug list)
Depends On:
Blocks: 61590
  Show dependency treegraph
 
Reported: 2002-03-27 14:33 EST by Forrest
Modified: 2008-05-01 11:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-04 15:34:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Forrest 2002-03-27 14:33:56 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.7) Gecko/20020115

Description of problem:
Whenever I bring up redhat-config-network and click Apply (even though I haven't
changed anything), it will add 'PEERDNS=no' to
/etc/sysconfig/network-scripts/ifcfg-eth0.  For the corporate environment, this
should not be the case.  This is possibly related to the 'fix' for Bug #58110.

Also when I click Apply, it asks if I want to change the file from chmod 600 to
chmod 644.  I click Yes, and the file has not changed permissions.  If I click
No, the file is then changed to chmod 644.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Click Apply in redhat-config-network


Actual Results:  1. It adds 'PEERDNS=no' to
/etc/sysconfig/network-scripts/ifcfg-eth0
2. It ask to change the permissions on the above file, and clicking Yes does
nothing, while clicking No changed the permissions.

Expected Results:  The best result in #1 would probably be to add nothing to
ifcfg-eth0.  I understand that some ppp connections do not want PEERDNS=yes, but
I certainly do not want PEERDNS=no.

In #2, clicking Yes should change the file permissions, and clicking No should
leave the permissions as they are.

Additional info:
Comment 1 Harald Hoyer 2002-04-03 04:58:38 EST
should be fixed in >0.9.22
Comment 2 Jay Turner 2002-04-04 15:34:44 EST
Harald, I'm not seeing this package anywhere in the build system . . . am I
missing something?
Comment 3 Jay Turner 2002-04-05 13:22:28 EST
Fix confirmed with redhat-config-network-0.9.22-1.
Comment 4 Harald Hoyer 2002-04-08 08:01:26 EDT
*** Bug 62839 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.