Bug 720497 - w/ lots of compat groups defined, scrolling quickly to bottom of table on #Inventory/Groups/AllGroups view, causes gwt RequestTimeoutException
w/ lots of compat groups defined, scrolling quickly to bottom of table on #In...
Status: CLOSED WORKSFORME
Product: RHQ Project
Classification: Other
Component: Core UI (Show other bugs)
4.0.1
Unspecified Unspecified
urgent Severity high (vote)
: ---
: ---
Assigned To: Robert Buck
Mike Foley
:
Depends On:
Blocks: jon3 jon30-perf rhq-gui-timeouts rhq41 rhq41-ui
  Show dependency treegraph
 
Reported: 2011-07-11 16:00 EDT by Ian Springer
Modified: 2015-07-07 19:14 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-12 15:54:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ian Springer 2011-07-11 16:00:20 EDT
In the perf env, I have 358 compat groups defined. When I go to the #Inventory/Groups/AllGroups, the view loads fine. But if I then scroll quickly to the bottom of the table, I get the following error and the table is blank:

Failed to load group composite data. This occurred because the server is taking a long time to complete this request. Please be aware that the server may still be processing your request and it may complete shortly. You can check the server logs to see if any abnormal errors occurred.
Severity :	
Warning
	
Time :	
Monday, July 11, 2011 3:47:51 PM Etc/GMT+4
Detail :	
com.google.gwt.http.client.RequestTimeoutException:A request timeout has expired after 10000 ms
--- STACK TRACE FOLLOWS ---
A request timeout has expired after 10000 ms
    at Unknown.com_google_gwt_http_client_RequestTimeoutException_$RequestTimeoutException__Lcom_google_gwt_http_client_RequestTimeoutException_2Lcom_google_gwt_http_client_Request_2ILcom_google_gwt_http_client_RequestTimeoutException_2(Unknown source:0)
    at Unknown.com_google_gwt_http_client_Request_$fireOnTimeout__Lcom_google_gwt_http_client_Request_2Lcom_google_gwt_http_client_RequestCallback_2V(Unknown source:0)
    at Unknown.com_google_gwt_http_client_Request$3_run__V(Unknown source:0)
    at Unknown.com_google_gwt_user_client_Timer_fire__V(Unknown source:0)
    at Unknown.anonymous(Unknown source:0)
    at Unknown.com_google_gwt_core_client_impl_Impl_entry0__Ljava_lang_Object_2Ljava_lang_Object_2Ljava_lang_Object_2Ljava_lang_Object_2(Unknown source:0)
    at Unknown.anonymous(Unknown source:0)
    at Unknown.anonymous(Unknown source:0)

We'll need to increase the 10000 timeout to a much larger number to find out how long the RPC call takes to complete. Once we have that info, we can decide whether we want to permanently increase the timeout and/or tune the performance of the underlying SLSB method.
Comment 1 Charles Crouch 2011-10-10 16:04:12 EDT
Should try to reproduce first and then fix/mitigate as appropriate
Comment 2 Robert Buck 2011-10-11 15:05:45 EDT
I could not reproduce this. I had 579 compat groups and scrolling was good enough for me. I could scroll across the whole group in 3 seconds or so. Please confirm this as an issue, Ian. This worked perfectly for me.

Note You need to log in before you can comment on or make changes to this bug.