Bug 720577 - Backintime gnome does not start, missing gnome dependency
Summary: Backintime gnome does not start, missing gnome dependency
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: backintime
Version: 15
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tim Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 733611 756813 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-07-12 06:59 UTC by Sergio Pascual
Modified: 2011-11-26 12:59 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-10-09 20:23:44 UTC


Attachments (Terms of Use)

Description Sergio Pascual 2011-07-12 06:59:35 UTC
After doing:

# yum install backintime-gnome

I get an error starting the gui

$ backintime-gnome
Traceback (most recent call last):
  File "/usr/share/backintime/gnome/app.py", line 33, in <module>
    import gnome
ImportError: No module named gnome

so there's a missing dependency

Comment 1 Tim Jackson 2011-10-09 19:21:17 UTC
*** Bug 733611 has been marked as a duplicate of this bug. ***

Comment 2 Tim Jackson 2011-10-09 19:24:19 UTC
Sergio, it certainly sounds like a problem but it works for me, and backintime-gnome requires gnome-python2 (at least on F14). Did you solve this? Any idea what the missing package is?

Comment 3 Sergio Pascual 2011-10-09 20:05:33 UTC
I had to install by hand gnome-python2-gnome. That solved the problem

Comment 4 Tim Jackson 2011-10-09 20:23:44 UTC
Thanks for the report!
Fixed in http://koji.fedoraproject.org/koji/taskinfo?taskID=3418146

Comment 5 Tim Jackson 2011-11-24 19:44:52 UTC
*** Bug 756813 has been marked as a duplicate of this bug. ***

Comment 6 Raphael Groner 2011-11-26 12:35:13 UTC
I did see this bug in Fedora 16. Is it possible to get a fix also for fc16? 
I think most users will appreciate to see it fixed via normal updates, then they wouldn't have to look into this bug report and detect the need to install gnome-python2 manually.

Comment 7 Raphael Groner 2011-11-26 12:59:46 UTC
(In reply to comment #6)
Sorry, I wanted to say that installing the package gnome-python2-gnome fixes this bug.


Note You need to log in before you can comment on or make changes to this bug.