Bug 72064 - Complete hang of anaconda executing scripts from bash rpm
Complete hang of anaconda executing scripts from bash rpm
Status: CLOSED DUPLICATE of bug 71889
Product: Red Hat Public Beta
Classification: Retired
Component: anaconda (Show other bugs)
null
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-20 19:02 EDT by Telsa Gwynne
Modified: 2007-04-18 12:45 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-20 19:02:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Telsa Gwynne 2002-08-20 19:02:13 EDT
Description of Problem:

GUI install on (null)
Selected UK kb, en_GB system locale, workstation and then tweaked a few
packages. 

Left it to perform install. Returned to find it apparently stuck on
bash, two minutes into an alleged 16-minute install (yeah, I know not
to believe those in first few packages).

Flipped to F2. free, df fine. ps had a shell script running as
"sh var/tmp/rpm-something.number 1" This script was the one to put
/etc/shells there. There is a loop in it. Killed this PID (ran out
of ideas!), watched ps again. Again it got stuck running another bash rpm
post-install script, this time one with no loops in it. Killed this PID,
watched it again. Again stuck on a script running ld-config. 

Could not think of anything left to do and needed the CD for another
box. Anaconda didn't crash so no stack trace. Just hit control-alt-delete.

This box is an AMD K6. Suggestion made that it may have installed 
"the wrong libraries" -- Alan has gone to try on another K6 to find out.
Comment 1 Jeremy Katz 2002-08-21 00:16:57 EDT

*** This bug has been marked as a duplicate of 71889 ***

Note You need to log in before you can comment on or make changes to this bug.