Bug 71889 - Install hangs after installing bash
Install hangs after installing bash
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: anaconda (Show other bugs)
null
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
: 72064 72358 72767 73635 (view as bug list)
Depends On: 71878
Blocks: 67217
  Show dependency treegraph
 
Reported: 2002-08-19 20:38 EDT by Jay Turner
Modified: 2015-01-07 18:59 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-29 00:22:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
to make this kickstart file fail, just uncomment the longer langsupport line and comment out the shorter one. (3.25 KB, text/plain)
2002-08-21 13:04 EDT, Michael E Brown
no flags Details

  None (edit)
Description Jay Turner 2002-08-19 20:38:19 EDT
Description of Problem:
With the Milan-re0819.nightly tree, I'm getting hangs after the installation of
the bash package.  A couple of people have reported this on limbo-list as well.
 One tester even pinned this down to deselecting and selecting again the
audiofile package (the next package to be installed after bash.)

Version-Release number of selected component (if applicable):


How Reproducible:


Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:
Comment 1 Jason Montleon 2002-08-19 21:19:53 EDT
I had a problem with the installation of Limbo Beta 2 (7.2.93) that sounds 
similar though not sure if related.  In my case the installation stopped after 
the gnome-mime-data package.  Everything seemed fine but there was no disk 
access for well in excess of 15 minutes.  Tried the installation 3 times to no 
avail.

The installation was to a set of SCSI disks on a RAID controller.  1 logical 
drive made up of 3 4GB disks in a RAID 5 configuration.  Media check on the CD 
turned up fine, the RAID controller did not report any errors, reformatted the 
logical drive checking for bad blocks, nothing found, and I'm not really sure 
what the problem was.  I ended up creating a new logical drive out of different 
disks and the installation worked fine.
Comment 2 Jeremy Katz 2002-08-19 23:14:25 EDT
I think that the deselecting and selecting audiofile is just a red herring,
fwiw.  Since you weren't reliably reproducing it this afternoon, he could have
just gotten lucky on the "it worked this time" bit
Comment 3 Christopher A. Williams 2002-08-20 01:28:00 EDT
I'm the one where it worked after deselecting and reselecting audiofile and it
worked. I agree it must have been something else. I was able to consistently
reproduce the problem on another machine. Bash install finishes and the system
just stops. Audiofile seems like it's next but never starts installing. I'm not
sure why it worked for me eventually on the one system, other than just pure luck.

It does this consistently after selecting a Personal Workstation or a Custom
install - I have not tried with the other configurations.

In once case, I was installing to 3 partitions (/boot, swap and /) and in the
other case where it did finally work, I have /boot, swap, /, and then /opt,
/home, /usr and /usr/local in an extended partition.

Chris Williams
Comment 4 Geert Noel 2002-08-20 10:14:16 EDT
I've had the same problem. I tried the Personal Desktop twice and then tried
Custom - Everything. It always hanged after bash. Then I tried the text
installer and everything went smoothly...
Comment 5 Jeremy Katz 2002-08-21 00:16:53 EDT
*** Bug 72064 has been marked as a duplicate of this bug. ***
Comment 6 Gene Czarcinski 2002-08-21 08:11:37 EDT
Question:  are all of these installs from cdrom?  I have done a number of nfs
installs and seen nothing like this.
Comment 7 Michael E Brown 2002-08-21 13:02:22 EDT
I have this occur when I do a kickstart install.

My langsupport line has several languages listed, if I change it so that it has
on ly en_US, it works just fine. 

I will attach my failing kickstart file
Comment 8 Michael E Brown 2002-08-21 13:04:26 EDT
Created attachment 71944 [details]
to make this kickstart file fail, just uncomment the longer langsupport line and comment out the shorter one.
Comment 9 Michael E Brown 2002-08-21 13:37:12 EDT
ps ax during the hang shows that the file /var/tmp/rpm-tmp.### is running. This
looks like the %post script for the bash package. If you kill this script, the
install continues to the next package that has a %post, and it, too, hangs. Same
thing, kill it and it continues.

If you "chroot /mnt/sysimage /bin/sh" into the installed system and run the
hanging shell script, it runs just fine.
--
Michael
Comment 10 Jeremy Katz 2002-08-21 22:51:45 EDT
Current theory is that it's due to the locale archive support in glibc
(backtrace in gdb definitely implies a case that Jakub fixed earlier in the
week).  Building a tree with a fixed glibc now
Comment 11 Jeremy Katz 2002-08-21 23:43:39 EDT
And with the glibc fix in, it appears to be fixed...  waiting on fixed glibc to
go into the tree to close this
Comment 12 richard mullens 2002-08-22 21:01:11 EDT
I had the same problem.  Using the text installer made no difference.  I did not have the problem on Limbo.
When I omitted the additional languages English(GB) French(France) German(Germany) Spanish(Spain) and just went with English(USA) the installation proceeded 
OK.
Comment 13 Michael Redinger 2002-08-23 03:48:50 EDT
*** Bug 72358 has been marked as a duplicate of this bug. ***
Comment 14 Henrik Lynggaard 2002-08-24 19:25:00 EDT
I seeing this too, it hangs directly after the bash install

My info:
Version: null
Install type: CDROM
Locales chosen: English (US) and Danish. English being standard
im using 2 partitions both on the same IDE device (one 2.5 for / and 256 for swap)

is there a known workaround, so that I may actually install the beta ?
should i try to select only the english locale (i read the comments as that may
be the culprint)


Comment 15 Jeremy Katz 2002-08-26 18:03:15 EDT
Fixed with new glibc package
Comment 16 Mike McLean 2002-08-29 15:09:59 EDT
CLOSED->RAWHIDE

I'm not seeing this.  Please reopen if this occurs with the next release.
Comment 17 Jeremy Katz 2002-09-20 16:05:40 EDT
*** Bug 72767 has been marked as a duplicate of this bug. ***
Comment 18 Jeremy Katz 2002-09-20 16:05:50 EDT
*** Bug 73635 has been marked as a duplicate of this bug. ***
Comment 19 Michael Fulbright 2002-12-20 12:38:25 EST
Time tracking values updated

Note You need to log in before you can comment on or make changes to this bug.