This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 720791 - grid data on autodiscovery queue view (#Inventory/Resources/AutodiscoveryQueue) takes unacceptably long to load when there are lots of NEW Resources
grid data on autodiscovery queue view (#Inventory/Resources/AutodiscoveryQueu...
Status: CLOSED WONTFIX
Product: RHQ Project
Classification: Other
Component: Core UI (Show other bugs)
4.1
Unspecified Unspecified
high Severity medium (vote)
: ---
: ---
Assigned To: Ian Springer
Mike Foley
:
Depends On:
Blocks: jon3 jon30-perf rhq41beta rhq41 rhq41-ui
  Show dependency treegraph
 
Reported: 2011-07-12 15:01 EDT by Ian Springer
Modified: 2013-08-05 20:39 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-06 12:35:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ian Springer 2011-07-12 15:01:15 EDT
For example, in the performance environment, it took 65 seconds for the data to load when there were 1500 NEW Resources (300 platforms and 1200 top-level servers). It appears the reason for this is that the datasource is configured to not do paging (the PageControl page size is set to -1 == unlimited). Instead, we should be initializing the PageControl the same way it is done by RPCDataSource.getPageControl(), i.e.: 

PageControl.getExplicitPageControl(request.getStartRow(), request.getEndRow()
                - request.getStartRow());
Comment 1 Ian Springer 2011-07-12 17:19:54 EDT
Note, once we switch over to paging the data on this view, the recently added Select All and Deselect All buttons may no longer work, because I don't think SmartGWT supports selecting grid records that have not been loaded yet. If this ends up being the case, we'll probably need to replace those buttons with Import All, Ignore All, and Unignore All buttons.
Comment 2 Ian Springer 2011-09-06 12:35:51 EDT
TreeGrids do not support paging of results as ListGrids do. This is documented in the Javadoc for TreeGrid.setDataFetchMode(). As stated there, the alternative is to load child nodes on demand (see the Javadoc for TreeGrid.setLoadDataOnDemand()). So in our case, when the user expands a platform node, the child server nodes would be loaded at that time. I do not think we should pursue switching to on demand loading, since I think it would complicate node selection, where nodes must be loaded before they can be selected, and it would also make expanding platform nodes less snappy.

We can load 250 NEW platforms/servers in around 10s, which isn't terrible, and I don't think most users will have more NEW Resources than that at one time.

Note You need to log in before you can comment on or make changes to this bug.