Bug 72087 - Altered dhcp behaviour sets hostname by default, means Gnome 2 won't start with many ISPs
Altered dhcp behaviour sets hostname by default, means Gnome 2 won't start w...
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: dhcpcd (Show other bugs)
null
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Elliot Lee
:
: 72622 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-20 22:02 EDT by Mike MacCana
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-26 11:03:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike MacCana 2002-08-20 22:02:29 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020809

Description of problem:
Many ISPs have a silly habit of setting unresolvable hostnames for their DHCP
clients. Yes, this is stupid, but its also quite common. Red Hat 7.3 wouldn't
set the systems definitive hostname from DHCP, which meant that the hostname
would be set to localhost unless changed, and GNOME 2 would happily start.

7.3.94 changes this behavior. Because of this, customers who run RHL on an ISP
like Optus@Home will get an unresolvable hostname, and Gnome 2 won't start
properly, popping up a nasty error message. 

It would be better to revert back to 7.3 behaviour of not setting the local
hostname by default, and allow people to turn this option on is they need it.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install RHL on Optus@Home cable or any ISP which issues unresolvable hostnames
for clients
2.Attempt to log into Gnome
	

Additional info:
Comment 1 John Reiser 2002-08-22 15:01:09 EDT
Some DSL hardware router/firewalls such as NetGear RT314 also do this, and for a
"good" reason: they don't provide DNS, only DHCP server.  Even if you [try to]
tell it your prefered hostname in your DHCP request, the router/firewall just
gives you an IP4 with a name such as "dhcppc5".  And even if the router/firewall
were to honor your prefered hostname, it might be restricted in length so that a
FQDN would be too long in most cases.

So, it is better to let the HOSTNAME in /etc/sysconfig/network be the default,
and override it only with explicit user OK.
Comment 2 Elliot Lee 2002-08-26 07:43:26 EDT
If you are getting a bad hostname, the DHCP server is in error...

It seems that there needs to be an option of not setting the hostname (which I need to 
add), but the default of following the instructions from the DHCP server is correct.
Comment 3 Elliot Lee 2002-08-26 11:03:30 EDT
*** Bug 72622 has been marked as a duplicate of this bug. ***
Comment 4 Elliot Lee 2002-08-26 11:03:41 EDT
*** Bug 72622 has been marked as a duplicate of this bug. ***
Comment 5 Elliot Lee 2002-08-26 11:04:32 EDT
HOSTNAME= takes precedence in 3.0pl1-8

Note You need to log in before you can comment on or make changes to this bug.