Bug 72622 - dhclient always sets the hostname
Summary: dhclient always sets the hostname
Status: CLOSED DUPLICATE of bug 72087
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: dhcp (Show other bugs)
(Show other bugs)
Version: null
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Elliot Lee
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-08-26 05:43 UTC by James Ralston
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-26 12:56:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description James Ralston 2002-08-26 05:43:36 UTC
Description of Problem:

The "dhclient" DHCP client program seems to always set the hostname of the
machine on which it is run to whatever value is returned by the DHCP server.

If there is a way to inhibit this behavior, I haven't found it.

For example, here is my /etc/sysconfig/network file:

    NETWORKING=yes
    HOSTNAME=farslayer.l33tskillz.org

Here is my /etc/hosts file:

    # Do not remove the following line, or various programs
    # that require network functionality will fail.
    127.0.0.1       localhost       localhost.localdomain

My hostname:

    $ hostname
    farslayer.l33tskillz.org

When dhclient runs, it changes the hostname to whatever value the DHCP server
returns.  This is bogus.

Version-Release number of selected component (if applicable):

dhclient-3.0pl1-7

How Reproducible:

Run dhclient.

Comment 1 Elliot Lee 2002-08-26 12:56:37 UTC
The "right" solution is to fix your DHCP server to send back the correct hostname...

But an option may be added, we'll see.

Comment 2 Elliot Lee 2002-08-26 15:03:47 UTC

*** This bug has been marked as a duplicate of 72087 ***


Note You need to log in before you can comment on or make changes to this bug.