Bug 72088 - graphic install fails: Cannot open display: :1
graphic install fails: Cannot open display: :1
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
Brock Organ
Depends On:
Blocks: 79579 82779 CambridgeTarget
  Show dependency treegraph
Reported: 2002-08-20 22:05 EDT by Need Real Name
Modified: 2007-04-18 12:45 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-01-10 11:30:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
XFree86.setup.log (1.55 KB, text/plain)
2003-02-26 00:51 EST, Need Real Name
no flags Details
XFree86.0.log (29.88 KB, text/plain)
2003-02-26 01:02 EST, Need Real Name
no flags Details
XF86Config from RH8.0 (3.16 KB, text/plain)
2003-02-26 01:03 EST, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2002-08-20 22:05:18 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020809

Description of problem:
The default, graphic install fails on my laptop (Dell Latitude c800, with ATI,
not nVidia graphic card).  The
installer exits to a text screen (console) with these lines left visible:

1...2...3...4... X server started successfully.

(mini-wm:106):Gtk-WARNING**: Cannot open display: :1
Traceback (most recent call last):
	File "/usr/bin/anaconda", line 535, in ?
		from plashscreen import splashScreenShow
	File "/usr/bin/anaconda/splashscreen.py", line 20 in ?
		import gtk
	File "/usr/lib/python2.2/site-packages/gtk/__init__.py", line 19 in ?
		from _gtk import *

RuntimeError: could not open display
install exited abnormally
sending termination signals...done
sending kill signals...done
disabling swap...
unmounting filesystems...
	/mnt/runtime	done
	disabling	/dev/loop0
	/proc/bus/usb	done
	/proc	done
	/dev/pts	done
	/mnt/source	done
ejecting /tml/cdrom...
you may safely reboot your system

I tried doing a graphic install twice, with identical results.  I
subsequently tried a text install, and it worked.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Put first CD in the drive
2. Boot 
3. Hit enter at the first screen (ie, accept default, graphic install)

Actual Results:  install fails (see above for details)

Expected Results:  successful install

Additional info:

1. I have successfully done graphic installs of these RedHat releases on this
laptop:  7.2, 7.3, limbo1, limbo2

2. This was a CD install

3. All CDs "passed" the mediacheck
Comment 1 Jeremy Katz 2002-08-21 02:33:12 EDT
If you boot with 'linux nokill', what sort of error is in /tmp/X.log if you look
from tty2 after the install dies?
Comment 2 Need Real Name 2002-08-22 08:33:33 EDT
This was a bit of a pain to get, since >90% of the keyboard was nonfunctional
after the installer crashed (even with the 'nokill' option).  The only keys/key
combinations that appeared to function were Alt-Fn, Ctl-Alt-Del and
Shift-PageUp/PageDown.  So I had to cat the log file in the short time between
when the X server started and when it crashed.  

Anyway, here's the file (/tmp/X.log), I'm pretty sure it's complete:

XFree86 Version 4.2.0 (RedHat Linux release: 4.2.0-65)/X Window System
(protocol Version 11, revision 0, vendor release 6600)
Release Date: 23 January 2002
	If the server is older that 6-12 months, or if your card is 
	newer that the above date, look for a newer version before
	reporting problems. (See http://www.XFree86.Org/)
Build Operating System: Linux 2.4.18-11smp I686 [ELF]
Build Host: daffy.perf.redhat.com

Module Loader present
Markers:	(--) probed, (**) from config file, (==) default setting,
			(++) from command line, (!!) notice, (II) informational,
			(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(++) Log file: "/dev/null/", Time: Wed Aug 21 20:38:59 2002
(++) using config file: "/tmp/XF86Config.test"
(EE) Failed to load module "glx" (module does not exist, 0)
Color, Single, TFT
(EE) R128(0): No valid modes found
(EE) Screen(s) found, abut none have a usable configuration

Fatal server error:
no screens found
When reporting a problem related to a server crash, please send
the full server output, not just the last messages.
This can be found in the log file "/dev/null".
Please report problems to xfree86@xfree86.org.
Comment 3 Michael Fulbright 2002-08-23 12:04:39 EDT
Can you try booting with 'resolution=<mode>', where <mode> is the mode your LCD
uses?  For example, if it runs at 1024x768, try

linux resolution=1024x768
Comment 4 Need Real Name 2002-08-24 09:37:58 EDT
My LCD screen is 1600x1200; I tried booting with:
linux resolution=1600x1200
But the installer still failed with the same "could not open display" error.
Comment 5 Michael Fulbright 2002-08-28 13:11:10 EDT
What model is the LCD?
Comment 6 Preston Brown 2002-08-28 15:40:49 EDT
here's the answer to the problem:   
It appears the vertical refresh range being pegged at 60 is too narrow a   
range, and the driver wants to use a 65 Hz refresh rate. 
You could kludge this for now by manually using a wider VertRefresh range. 
Comment 7 Mike A. Harris 2003-01-22 18:36:52 EST
Does this problem occur in the latest beta release (phoebe)?
Alternatively, does it occur using the XFree86 from rawhide in 8.0?
Comment 8 Need Real Name 2003-01-27 19:00:44 EST
I've tried installing the 2 phoebe betas (8.0.92 and 8.0.93):

beta 1 (8.0.92) -- graphic install worked if I used the "linux
resolution=1600x1200" boot parameter

beta 2 (8.0.93) -- graphic install fails, even with the "linux
resolution=1600x1200" boot parameter.  The install dies with these lines left on
the console:

Attempting to start native X server
waiting for X server to start...log located in /tmp/X.log
1...2...3...4...5... X server started successfully
XIO:  fatal IO error 104 (Connection reset by peer) on X server ":1.0"
      after 0 requests (0 known processed) with 0 events remaining.
install exited abnormally
.          -snipped-
you may safely reboot your system. 
Comment 9 Need Real Name 2003-02-20 23:59:36 EST
I just tried phoebe beta 3 on this laptop.  I get the same result when I try the
graphic install, it fails with "XIO:  fatal IO error..."
Comment 10 Mike A. Harris 2003-02-25 13:26:11 EST
It's next to impossible for me to test problems reported with X in the
installer.  Can you do a text mode installation please, and then
configure X post-install with redhat-config-xfree86 and report back
what problems you have, with file attachments for your X server log
and config file?
Comment 11 Need Real Name 2003-02-26 00:51:03 EST
Created attachment 90371 [details]
Comment 12 Need Real Name 2003-02-26 00:51:54 EST
OK, I did a fresh text mode install of 8.0.94 (phoebe beta 3).  I skipped the X
configuration option during the install.  After the install was over and
following a reboot, I ran "redhat-config-xfree86", which failed, leaving these
console messages:
* ddcprobe returned bogus values:
ID:  None
Name:  None
HorizSync:  None
VertSync:  None

Couldn't start X server, trying with a fresh configuration
* ddcprobe returned bogus values:
ID:  None
Name:  None
HorizSync:  None
VertSync:  None

Trying with card ATI rage 128 Mobility
Error, cannot start X server.

"redhat-config-xfree86" did not create an /etc/X11/F86config file.

I am attaching my /var/log/XFree86.setup.log file.
Comment 13 Need Real Name 2003-02-26 01:02:15 EST
I copied over the XF86config file from an existing install of RH8.0 on the same
laptop, and X will start with this file.  I am attaching the RH8 XF86config and
/var/log/XFree86.0.log file from the first run of X using this config file.
Comment 14 Need Real Name 2003-02-26 01:02:49 EST
Created attachment 90372 [details]
Comment 15 Need Real Name 2003-02-26 01:03:24 EST
Created attachment 90373 [details]
XF86Config from RH8.0
Comment 16 Mike A. Harris 2004-01-10 11:30:40 EST
This problem is probably fixed in Fedora Core 1, although I can't
test it personally.  Please upgrade to Fedora Core 1, or Red Hat
Enterprise Linux 3, and if the problem persists, reopen the bug
report and change the version number to reflect the OS release,
and provide updated config/log data, etc. and I'll re-investigate.

Red Hat Linux 8.0 and earlier OS releases are no longer supported
by Red Hat.  Closing as CURRENTRELEASE.

Note You need to log in before you can comment on or make changes to this bug.