Bug 720976 - Provide native systemd unit file
Provide native systemd unit file
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: krb5 (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Nalin Dahyabhai
Fedora Extras Quality Assurance
:
Depends On: 740393
Blocks: SysVtoSystemd
  Show dependency treegraph
 
Reported: 2011-07-13 07:44 EDT by Jóhann B. Guðmundsson
Modified: 2011-10-12 17:38 EDT (History)
3 users (show)

See Also:
Fixed In Version: krb5-1.9.1-15.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-10 23:15:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Native systemd service file kprop (218 bytes, text/plain)
2011-07-13 07:45 EDT, Jóhann B. Guðmundsson
no flags Details
Native systemd service file kadmin (437 bytes, text/plain)
2011-07-13 07:46 EDT, Jóhann B. Guðmundsson
no flags Details
Native systemd service file krb5kdc (305 bytes, text/plain)
2011-07-13 07:48 EDT, Jóhann B. Guðmundsson
no flags Details

  None (edit)
Description Jóhann B. Guðmundsson 2011-07-13 07:44:32 EDT
Description of problem:

https://fedoraproject.org/wiki/Features/SysVtoSystemd

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jóhann B. Guðmundsson 2011-07-13 07:45:44 EDT
Created attachment 512639 [details]
Native systemd service file kprop
Comment 2 Jóhann B. Guðmundsson 2011-07-13 07:46:37 EDT
Created attachment 512640 [details]
Native systemd service file kadmin
Comment 3 Jóhann B. Guðmundsson 2011-07-13 07:48:13 EDT
Created attachment 512641 [details]
Native systemd service file krb5kdc

This unit files should be a enough to get the ball rolling on this one.. 

https://fedoraproject.org/wiki/Packaging:Guidelines:Systemd
https://fedoraproject.org/wiki/Packaging:ScriptletSnippets#Systemd
https://fedoraproject.org/wiki/Packaging:Tmpfiles.d
Comment 4 Fedora Update System 2011-09-19 15:01:47 EDT
krb5-1.9.1-13.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/krb5-1.9.1-13.fc16
Comment 5 Fedora Update System 2011-09-20 15:06:00 EDT
Package krb5-1.9.1-13.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing krb5-1.9.1-13.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/krb5-1.9.1-13.fc16
then log in and leave karma (feedback).
Comment 6 Nalin Dahyabhai 2011-09-27 14:44:44 EDT
The unit files appear to have replaced
  ${KRB5REALM:+-r $KRB5REALM}
with
  -r ${KRB5REALM}
which makes the value mandatory where it was optional before.  This isn't the desired effect (the default is to pick up the default_realm setting from krb5.conf, and this was an optional way to override that), and since the -r flag can be added to $KRB5KDC_FLAGS, I think it's better dropped.

As noted in bug #740393, the pid file in krb5kdc.systemd is listed as a relative path, which systemd rejects.  The ExecStart line also references an undefined $pidfile variable.

The conversion for kadmind currently regresses bug #723723, which is quite understandable due to the timing of when these two bugs were opened.  It also requires kpropd.acl to be around, when it's not expected to be there on master KDCs.  This is changed to a negated check ("|"->"!") in the update, which brings it more in line with what I'd expect.

The conversion for kprop is missing Type=forking, which causes systemd to assume "Type=simple", and the update replaces ConditionPathExists=| with ConditionPathExists=!, which has a different effect.  I'm not really convinced that we need to trigger based on the presence of an ACL file, but the candidate update is getting it wrong.
Comment 7 Fedora Update System 2011-09-30 09:33:00 EDT
krb5-1.9.1-14.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/krb5-1.9.1-14.fc16
Comment 8 Fedora Update System 2011-10-02 11:39:10 EDT
krb5-1.9.1-15.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/krb5-1.9.1-15.fc16
Comment 9 Fedora Update System 2011-10-10 23:15:10 EDT
krb5-1.9.1-15.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Nalin Dahyabhai 2011-10-12 17:36:46 EDT
(In reply to comment #9)
> krb5-1.9.1-15.fc16 has been pushed to the Fedora 16 stable repository.  If
> problems still persist, please make note of it in this bug report.

Most of the problems noted in comment #6 weren't fixed by this update.
Comment 11 Fedora Update System 2011-10-12 17:38:40 EDT
krb5-1.9.1-16.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/krb5-1.9.1-16.fc16

Note You need to log in before you can comment on or make changes to this bug.