Bug 721314 - Pulp packages are missing documentation
Summary: Pulp packages are missing documentation
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Pulp
Classification: Retired
Component: rel-eng
Version: unspecified
Hardware: Unspecified
OS: Unspecified
low
unspecified
Target Milestone: ---
: 2.6.0
Assignee: Chris Duryee
QA Contact: Preethi Thomas
URL:
Whiteboard:
: 1010214 (view as bug list)
Depends On: 637874
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-07-14 09:16 UTC by Šimon Lukašík
Modified: 2015-02-28 21:01 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-28 20:59:28 UTC


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Pulp Redmine 330 0 None None None Never

Description Šimon Lukašík 2011-07-14 09:16:10 UTC
Description of problem:


Version-Release number of selected component (if applicable):
pulp-client-0.0.206-1.fc14.noarch
pulp-common-0.0.206-1.fc14.noarch
pulp-cds-0.0.206-1.fc14.noarch
pulp-0.0.206-1.fc14.noarch

How reproducible:
deterministic

Steps to Reproduce:
1. rpm -qld pulp-client pulp-common pulp-cds pulp
2.
3.
  
Actual results:
None

Expected results:
readme files and man pages

Additional info:

Comment 1 Sayli Karmarkar 2011-07-20 15:54:32 UTC
We currently do not have man pages for pulp and there is an RFE open for that.

Comment 2 Jay Dobies 2012-07-11 20:31:01 UTC
Closing out as not a bug. It's not that they aren't included, it's that they aren't written yet :) We'll be adding them as a separate RFE.

Comment 3 Šimon Lukašík 2012-07-12 09:19:55 UTC
(In reply to comment #2)
> Closing out as not a bug. It's not that they aren't included, it's that they
> aren't written yet :)

This is not a fun. It is actually the reason why this ticket exists.

>                       We'll be adding them as a separate RFE.

I don't want to see any bug being closed without resolution
or link to another tracking ticket.

Comment 4 Michael Hrivnak 2013-09-26 20:56:22 UTC
http://www.pulpproject.org/docs/

https://github.com/pulp/pulp/pull/638

That's a start, but we still don't have man pages.

Comment 5 Michael Hrivnak 2013-09-27 15:07:21 UTC
*** Bug 1010214 has been marked as a duplicate of this bug. ***

Comment 6 Chris Duryee 2014-11-14 00:05:44 UTC
https://github.com/pulp/pulp/pull/1298

Comment 7 Šimon Lukašík 2014-11-14 08:33:59 UTC
Oh my!

Thank You very much, sir!

Comment 8 Chris Duryee 2014-11-19 23:20:25 UTC
No problem:)

Merged to 2.6-dev and master

Comment 9 Chris Duryee 2014-12-23 20:52:31 UTC
fixed in pulp 2.6.0-0.2.beta

Comment 10 Irina Gulina 2015-01-12 08:00:51 UTC
>> rpm -qa pulp-server
pulp-server-2.6.0-0.2.beta.el6.noarch


>> man pulp-admin | head -n 15
PULP-ADMIN(1)                    Pulp Project                    PULP-ADMIN(1)



NAME
       pulp-admin - Pulp Documentation

       Contents:

INTRODUCTION
       The  admin client is used to remotely manage a Pulp server. This client
       is used to manage the operation of the server itself as well as trigger
       remote operations on registered consumers.

       For more information on the client that runs on Pulp consumers, see the


>> man pulp-consumer | head -n 15
PULP-CONSUMER(1)                 Pulp Project                 PULP-CONSUMER(1)



NAME
       pulp-consumer - Pulp Documentation

       Contents:

INTRODUCING THE PULP CONSUMER CLIENT
       The  Pulp  consumer  client, pulp-consumer, is a command line tool that
       allows administrators to register a consumer,  bind  that  consumer  to
       Pulp  managed  repositories, and install content onto the consumer from
       those bound repositories.

Comment 11 Brian Bouterse 2015-02-28 20:59:28 UTC
Moved to https://pulp.plan.io/issues/330


Note You need to log in before you can comment on or make changes to this bug.