Bug 72162 - tcsh-6.12-2: problem with German "umlauts"
tcsh-6.12-2: problem with German "umlauts"
Status: CLOSED DUPLICATE of bug 89549
Product: Red Hat Linux
Classification: Retired
Component: tcsh (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Miloslav Trmač
David Lawrence
: i18n
Depends On:
Blocks: 67218 79579 CambridgeTarget
  Show dependency treegraph
 
Reported: 2002-08-21 13:03 EDT by Joachim Frieben
Modified: 2007-04-18 12:45 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:49:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joachim Frieben 2002-08-21 13:03:45 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020809

Description of problem:
"gnome-terminal" or "xterm" do not display the characater "_" correctly in
"tcsh-6.12-2". For instance, instead of "|vd_", one obtains "|vd ?". 

Version-Release number of selected component (if applicable):
6.12-2

How reproducible:
Always

Steps to Reproduce:
1. Log in to GNOME session.
2. Open "gnome-terminal".
3. Type some German "umlauts".

Actual Results:  German "umlauts" do not display correctly, e.g. "|vd_" becomes
"|vd ?"

Expected Results:  One should see the text appear as it was typed.

Additional info:

Switching to "sh" or "bash" makes this erroneous behaviour disappear
instantaneously! The responsible component may of course be a different one, and
the problem may only become manifest in certain circumstances. For example,
"umlauts" are not displayed correctly by "xedit" or "gvim" either. In other
cases, e.g. "mozilla" everything is fine. I had to downgrade "glibc" to version
"2.2.90-17" because of some problem with the "umount" command.

The content of my "/etc/sysconfig/i18n" file reads

LANG="en_US.UTF-8"
SUPPORTED="en_US.UTF-8:en_US:en:es_ES.UTF-8:es_ES:es"
SYSFONT="LatArCyrHeb-16"
SYSFONTACM="utf8"

I thought I had checkmarked "French" and "German" during install, too, but they
have not been installed - another bug?
Anyway, I never added other languages to the default "American English" one in
the past, and everything always worked great in this respect.
Comment 1 Tobias Ringstrom 2002-09-13 12:05:08 EDT
I bet this is the same problem as bug 43383
Comment 2 Tobias Ringstrom 2002-09-13 12:35:14 EDT
...which is a duplicate of bug 41991
Comment 3 Joachim Frieben 2003-04-01 19:47:45 EST
Hum, Red Hat Linux 9 is out, and to my great deception, the "umlaut" bug is
still there!
Comment 4 Aleksey Nogin 2003-08-28 13:05:42 EDT
If you "set dspmbyte=utf8", does the problem go away? See also bug 73627.
Comment 5 Joachim Frieben 2003-09-22 07:57:51 EDT
"set dspmbyte=utf8" seems to cure the problem. Thanks :)
Comment 6 Miloslav Trmač 2004-08-17 10:42:46 EDT

*** This bug has been marked as a duplicate of 89549 ***
Comment 7 Red Hat Bugzilla 2006-02-21 13:49:27 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.