Bug 72172 - Anaconda will install an i686 kernel on an athlon system
Summary: Anaconda will install an i686 kernel on an athlon system
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: anaconda (Show other bugs)
(Show other bugs)
Version: null
Hardware: i386 Linux
medium
low
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Brock Organ
URL: N/A
Whiteboard:
Keywords:
: 68509 (view as bug list)
Depends On:
Blocks: 67217
TreeView+ depends on / blocked
 
Reported: 2002-08-21 17:22 UTC by Need Real Name
Modified: 2007-04-18 16:45 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-29 05:46:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2002-08-21 17:22:48 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020809

Description of problem:
Hardware: Tyan S2460, 2xAMD Athlon MP 1.6 GHz, 512 MB RECC RAM.
Anaconda (text mode, install from ISO's on HD) will install an i686 kernel on
this machine.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install null.
2.
3.
	

Actual Results:  [ghouls@WKS ghouls]$ rpm -q kernel-smp --qf '%{ARCH}\n'
i686

This shows that the i686 kernel is installed. Just to make sure, I did this:

[ghouls@WKS ghouls]$ rpm -qp /iso/1/RedHat/RPMS/kernel-smp-2.4.18-11.athlon.rpm
--qf '%{ARCH}\n' --nosignature
athlon

So the kernel-smp rpm for the athlon returns a good arch.

Expected Results:  The athlon kernel should be installed.

Additional info:

Of course this applies to both kernel and kernel-smp packages.

Marking this bug as low priority as the kernel(-smp) rpms for the athlon arch
can be installed in seconds.

Keep up the good work!

Comment 1 Jeremy Katz 2002-08-29 05:46:37 UTC
Should be fixed with newer librpm404

Comment 2 Mike McLean 2002-08-29 19:14:12 UTC
I'm not seeing this with current trees on the athlon here.
(also weren't there some athlon chipsets that were so broken that the installer
chooses the i686 kernel for them?)

CLOSED->RAWHIDE
(please reopen if you see this problem with the next release)

Comment 3 Mike McLean 2002-08-29 19:42:12 UTC
*** Bug 68509 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.