Bug 72201 - up2date --force or -f doesn't work
up2date --force or -f doesn't work
Status: CLOSED DUPLICATE of bug 72166
Product: Red Hat Public Beta
Classification: Retired
Component: up2date (Show other bugs)
null
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-21 18:09 EDT by Barry K. Nathan
Modified: 2015-01-07 18:59 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-21 18:09:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Barry K. Nathan 2002-08-21 18:09:17 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20020818

Description of problem:
--force or -f fails to ignore the package-skip list, even though that's one
thing the option is supposed to do

Version-Release number of selected component (if applicable):
up2date 2.9.46-1 (since 2.9.50 or later doesn't seem to be on rawhide yet)

How reproducible:
Always

Steps to Reproduce:
1. Install (null) and do the initial up2date run (with registration etc.) but
don't update any of the skipped (kernel) packages
2. Open a terminal
3. Try "up2date -f kernel". It will fail because the kernel is on the skipped
packages list, even though -f is supposed to ignore that list and update it anyway.
4. Try "up2date --force kernel". Same result.

Actual Results:  Package gets skipped.

Expected Results:  -f or --force should disregard the skip list and install the
package anyway.

Additional info:

As far as I know, I'm using the correct command line option. I could be
mistaken, of course.
Comment 1 Adrian Likins 2002-08-21 18:28:41 EDT
fixed in 2.9.50
dup of #72166

*** This bug has been marked as a duplicate of 72166 ***

Note You need to log in before you can comment on or make changes to this bug.