Bug 722363 - Adding font and background support
Adding font and background support
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: grub2 (Show other bugs)
rawhide
Unspecified Linux
unspecified Severity low
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
: 814421 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-14 21:48 EDT by Zoran Pericic
Modified: 2012-05-09 18:11 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-30 18:25:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch for f14-f15 branches (9.74 KB, patch)
2011-07-14 21:50 EDT, Zoran Pericic
no flags Details | Diff

  None (edit)
Description Zoran Pericic 2011-07-14 21:48:16 EDT
This patch add support for configurable font and background.

Also there is new /etc/default/grub with all available options and description.
Comment 1 Zoran Pericic 2011-07-14 21:50:11 EDT
Created attachment 513305 [details]
Patch for f14-f15 branches
Comment 2 Fedora Admin XMLRPC Client 2011-09-16 15:08:20 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 3 Mads Kiilerich 2011-10-17 17:33:25 EDT
Zoran: The patch seems to be mangled somehow. Could you upload an updated version?
Comment 4 Sergio Monteiro Basto 2011-11-11 02:27:09 EST
hi , I saw this patch and 
we don't have /boot/grub2/backgrounds/grub.png for Fedora 16 ? 
so we don't have background image in grub2 ? 

thanks,
Comment 5 Hedayat Vatankhah 2011-11-15 07:41:52 EST
AFAIK, the Grub2 in Fedora 16 already supports font and background, so I think what we need is to add corresponding options/files in grub2 package and probably requesting a custom background for Grub 2 (sine legacy grub's support was very limited, it is not possible to use high quality backgrounds).
Thanks to http://ask.fedoraproject.org/question/74/vga0x307-is-deprecated-but-cant-get-gfxmode-to I'm currently using Fedora's own background with the following options:

GRUB_GFXMODE=1024X768x32
GRUB_GFXPAYLOAD_LINUX=keep
GRUB_BACKGROUND=/usr/share/backgrounds/verne/default/normalish/verne.png

Note: as given in the above link, a font file should be also added to grub2.
Comment 6 Hedayat Vatankhah 2011-11-15 07:43:00 EST
Also, since grub 2 now supports themes, it would be great if a Fedora grub theme is designed...:D
Comment 7 Frank Murphy 2011-12-30 08:35:19 EST
(In reply to comment #5)
> AFAIK, the Grub2 in Fedora 16 already supports font and background, so I think
> what we need is to add corresponding options/files in grub2 package and
> probably requesting a custom background for Grub 2 (sine legacy grub's support
> was very limited, it is not possible to use high quality backgrounds).
> Thanks to
> http://ask.fedoraproject.org/question/74/vga0x307-is-deprecated-but-cant-get-gfxmode-to
> I'm currently using Fedora's own background with the following options:
> 
> GRUB_GFXMODE=1024X768x32
> GRUB_GFXPAYLOAD_LINUX=keep
> GRUB_BACKGROUND=/usr/share/backgrounds/verne/default/normalish/verne.png
> 
> Note: as given in the above link, a font file should be also added to grub2.

Trying to get a bg for this:

Is /etc/grub.d/05_debian* required?
http://www.dedoimedo.com/computers/grub-2.html#mozTocId930378

Currently have:
# GRUB_GFXPAYLOAD_LINUX=keep
GRUB_GFXMODE=1024X768
GRUB_BACKGROUND=/usr/share/backgrounds/default.png
Comment 8 Hedayat Vatankhah 2011-12-30 08:45:00 EST
No, not at all. You just need to use appropriate settings and also create a font file using grub2-mkfont as described. Also, use small 'x' for the resolution part: 1024x768 rather than 1024X768 
(I've used big X in above mistakenly).
Using the correct settings, you should be able to get a graphical Grub2 after running grub2-mkconfig -o /boot/grub2/grub.cfg
Comment 9 Hedayat Vatankhah 2012-02-26 07:05:34 EST
It'd be great if it is fixed for Fedora 17 and it comes with a colorful grub.
Comment 10 Mads Kiilerich 2012-04-16 09:40:49 EDT
A proper graphical boot requires a font ... and Fedora doesn't have the default font and will place fonts in a place where grub doesn't look.

http://www.mail-archive.com/grub-devel@gnu.org/msg18492.html will add the necessary knobs upstream.
Comment 11 Mads Kiilerich 2012-04-19 17:15:31 EDT
*** Bug 814421 has been marked as a duplicate of this bug. ***
Comment 12 Mads Kiilerich 2012-04-30 18:25:50 EDT
grub2-2.0-0.24.beta4.fc17 has been pushed to f17 stable and upstreams way of doing it now work. The patch offered here is thus not relevant.
Comment 13 Sergio Monteiro Basto 2012-04-30 19:16:05 EDT
so it is fixed upstream !
Comment 14 Account closed by user 2012-05-09 18:11:06 EDT
grub2-2.0-0.25.beta4:

- missing line in /etc/default/grub (grub.default):
  GRUB_THEME=/boot/grub2/themes/system/theme.txt

- the theme makes the menu be slooooww

- and add fedora-logos-17.0.2-1 to "Requires:" in spec file.

Note You need to log in before you can comment on or make changes to this bug.