Bug 72268 - hang during NTP configuration
hang during NTP configuration
Status: CLOSED DUPLICATE of bug 72012
Product: Red Hat Public Beta
Classification: Retired
Component: firstboot (Show other bugs)
null
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-22 13:03 EDT by Mike Gerdts
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-22 13:03:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Gerdts 2002-08-22 13:03:08 EDT
After installing from CD, I rebooted.  During firstboot's NTP configuration I
entered an IP address.  After waiting on it to do something for over a minute, I
realized that the ethernet cable was unplugged.  I plugged it in, and waited a
bit longer.  During this time I had switched to a different virtual console, and
upon returning to VC7, firstboot did not repaint the screen.... ever.

Upon going to another computer, I got in via ssh.  I found that the cause of the
hang was ping -c 2 <ipaddress> had been running for quite some time.  Upon using
kill to get rid of the ping, firstboot repainted the screen and popped up an
error dialog.  A retry made everything go OK.

There are a couple problems here... 

1) If you are trying to see if a machine is a suitable NTP server, use an NTP
command rather than ping to see if it is alive.  Ping tests ICMP ECHO REQUEST
and ECHO REPLY packets.  A different command such as ntpdate will test NTP
packets.  Since ICMP ECHO REQUEST or ECHO REPLY packets may be firewalled, this
is a bad test to do.

2) If you really insist on using ping, consider the -w option.  I have not
tested to see if it would help in this situation or not, but the info in the man
page suggests that it should.
Comment 1 Brent Fox 2002-08-22 15:44:00 EDT

*** This bug has been marked as a duplicate of 72012 ***

Note You need to log in before you can comment on or make changes to this bug.