Bug 72012 - graceful failure on bad NTP servers
Summary: graceful failure on bad NTP servers
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: redhat-config-date (Show other bugs)
(Show other bugs)
Version: null
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact:
URL:
Whiteboard:
Keywords:
: 72109 72268 (view as bug list)
Depends On:
Blocks: 67218
TreeView+ depends on / blocked
 
Reported: 2002-08-20 18:38 UTC by Jack Neely
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-26 16:12:21 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jack Neely 2002-08-20 18:38:23 UTC
Description of Problem:
If you point first boot at an NTP server that doesn't exist it hangs.  There
doesn't seem to be a way to get firstboot to respond again.  Seems like
terrapin.csc.ncsu.edu doesn't exist right now.  Its also more than possible I
didn't wait until the TCP timeout occured, however, firstboot should come back
with an error in a reasonable amount of time.

Version-Release number of selected component (if applicable):
firstboot-0.9.9-13

How Reproducible:
always

Steps to Reproduce:
1. start first boot
2. at NTP configuration point it a terrapin
3. click forward

Comment 1 Jack Neely 2002-08-20 18:49:43 UTC
I thought this was a different issue but its related.  When this bug occures and
I kill X with ctrl+alt+backspace the init script does not detect this.  It just
waits.  Using ctrl+alt+del to reboot and rerun firstboot seems the only way out.

Comment 2 Brent Fox 2002-08-22 19:43:53 UTC
*** Bug 72268 has been marked as a duplicate of this bug. ***

Comment 3 Brent Fox 2002-08-26 16:12:14 UTC
redhat-config-date should now raise a dialog if the NTP server cannot be
contacted and give you a chance to pick a different server.

QA, please verify in redhat-config-date-1.5.2-5.

Comment 4 Jay Turner 2002-09-04 03:28:17 UTC
Fix confirmed with redhat-config-date-1.5.2-9.

Comment 5 Jay Turner 2002-09-04 03:29:06 UTC
*** Bug 72109 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.