Bug 722682 - [abrt] ibus-1.3.99.20110419-10.fc15: connection.py:630:call_blocking:DBusException: org.freedesktop.DBus.Error.Failed: Context which does not has focus can not change engine to xkb:layout:de.
[abrt] ibus-1.3.99.20110419-10.fc15: connection.py:630:call_blocking:DBusExce...
Status: CLOSED DUPLICATE of bug 707370
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
15
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
abrt_hash:6410fd30388bae0bf60977c4152...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-16 09:16 EDT by hoppi13484
Modified: 2011-07-31 22:28 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-31 22:28:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description hoppi13484 2011-07-16 09:16:45 EDT
abrt version: 2.0.3
architecture:   x86_64
cmdline:        /usr/bin/python /usr/share/ibus/ui/gtk/main.py
comment:        tried to change keyboard layout to german with the taskbar item in the upper right corner
component:      ibus
executable:     /usr/share/ibus/ui/gtk/main.py
kernel:         2.6.38.8-35.fc15.x86_64
os_release:     Fedora release 15 (Lovelock)
package:        ibus-1.3.99.20110419-10.fc15
reason:         connection.py:630:call_blocking:DBusException: org.freedesktop.DBus.Error.Failed: Context which does not has focus can not change engine to xkb:layout:de.
time:           Sat Jul 16 15:09:20 2011
uid:            500
username:       michael

backtrace:
:connection.py:630:call_blocking:DBusException: org.freedesktop.DBus.Error.Failed: Context which does not has focus can not change engine to xkb:layout:de.
:
:Traceback (most recent call last):
:  File "/usr/share/ibus/ui/gtk/panel.py", line 651, in __im_menu_item_activate_cb
:    self.__focus_ic.set_engine(engine)
:  File "/usr/lib/python2.7/site-packages/ibus/inputcontext.py", line 284, in set_engine
:    return self.__context.SetEngine(engine.name)
:  File "/usr/lib/python2.7/site-packages/dbus/proxies.py", line 140, in __call__
:    **keywords)
:  File "/usr/lib/python2.7/site-packages/dbus/connection.py", line 630, in call_blocking
:    message, timeout)
:DBusException: org.freedesktop.DBus.Error.Failed: Context which does not has focus can not change engine to xkb:layout:de.
:
:Local variables in innermost frame:
:byte_arrays: False
:self: <dbus.connection.Connection object at 0x148be90>
:args: (dbus.String(u'xkb:layout:de'),)
:utf8_strings: False
:bus_name: 'org.freedesktop.IBus'
:get_args_opts: {'byte_arrays': False, 'utf8_strings': False}
:object_path: dbus.ObjectPath('/org/freedesktop/IBus/InputContext_18')
:timeout: -1.0
:signature: u's'
:dbus_interface: 'org.freedesktop.IBus.InputContext'
:message: <dbus.lowlevel.MethodCallMessage object at 0x1712498>
:method: 'SetEngine'
Comment 1 fujiwara 2011-07-19 01:47:01 EDT
I cannot reproduce your problem.
Are you still able to reproduce your problem?
Comment 2 hoppi13484 2011-07-19 04:13:18 EDT
yes, but only once per login. i click on the german keyboard layout, nothing happens and this error occurs
Comment 3 fujiwara 2011-07-19 21:24:58 EDT
(In reply to comment #2)
Currently I have no idea to reproduce this problem.
It would be great if you could give the furthermore info since I have seen several similar bugs but I don't get the condition to reproduce the problem.

Are you able to see your problem with a new user account instead of the current your account?
Which processes exhaust CPUs or memories when you see your problem?
Do you have any special conditions?

> :DBusException: org.freedesktop.DBus.Error.Failed: Context which does not has
focus can not change engine to xkb:layout:de.

Which application has the input focus when you see your problem?
The SetEngine will call '/usr/libexec/ibus-engine-xkb --ibus'.
Comment 4 hoppi13484 2011-07-20 10:46:55 EDT
I created a new user account and the problem is the same.

The problem occures even after booting. So after login I switch to german keyboard layout and the bug-reporter opens. No other application is open.

The problem you see in the backtrace only appears once. After every following login the Problem is: "connection.py:630:call_blocking:DBusException: org.freedesktop.DBus.Error.Failed: Can not find engine xkb:layout:de."
Comment 5 fujiwara 2011-07-21 04:09:16 EDT
(In reply to comment #4)
> I created a new user account and the problem is the same.

OK, I see.

> The problem occures even after booting. So after login I switch to german
> keyboard layout and the bug-reporter opens. No other application is open.

But if you don't open any applications, I think ibus panel menu shows "No input window" and you cannot choose the German layout.
I guess you focused on a text application to be able to select 'de' layout?
Comment 6 fujiwara 2011-07-31 22:28:31 EDT

*** This bug has been marked as a duplicate of bug 707370 ***

Note You need to log in before you can comment on or make changes to this bug.