Bug 722756 - [abrt] ibus-1.3.99.20110419-10.fc15: connection.py:630:call_blocking:DBusException: org.freedesktop.DBus.Error.Failed: Context which does not has focus can not change engine to xkb:layout:us.
[abrt] ibus-1.3.99.20110419-10.fc15: connection.py:630:call_blocking:DBusExce...
Status: CLOSED DUPLICATE of bug 720567
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
15
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
abrt_hash:fce607ed93ccaaae8268d722594...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-17 08:48 EDT by nomnex
Modified: 2011-07-19 00:53 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-19 00:53:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description nomnex 2011-07-17 08:48:43 EDT
abrt version: 2.0.3
architecture:   i686
cmdline:        /usr/bin/python /usr/share/ibus/ui/gtk/main.py
comment:        I use a software called Puddletag (Audio tag). It conflicts with iBus. After some time (randomely) I lose input in the Puddletag GUI. Unless to close/re-open Puddletag, if I want to re-gain input, I have to quit iBus. Then I can type text in Puddgletag.
component:      ibus
executable:     /usr/share/ibus/ui/gtk/main.py
kernel:         2.6.38.8-35.fc15.i686
os_release:     Fedora release 15 (Lovelock)
package:        ibus-1.3.99.20110419-10.fc15
reason:         connection.py:630:call_blocking:DBusException: org.freedesktop.DBus.Error.Failed: Context which does not has focus can not change engine to xkb:layout:us.
time:           Sun Jul 17 21:44:56 2011
uid:            500
username:       mt

backtrace:
:connection.py:630:call_blocking:DBusException: org.freedesktop.DBus.Error.Failed: Context which does not has focus can not change engine to xkb:layout:us.
:
:Traceback (most recent call last):
:  File "/usr/share/ibus/ui/gtk/panel.py", line 651, in __im_menu_item_activate_cb
:    self.__focus_ic.set_engine(engine)
:  File "/usr/lib/python2.7/site-packages/ibus/inputcontext.py", line 284, in set_engine
:    return self.__context.SetEngine(engine.name)
:  File "/usr/lib/python2.7/site-packages/dbus/proxies.py", line 140, in __call__
:    **keywords)
:  File "/usr/lib/python2.7/site-packages/dbus/connection.py", line 630, in call_blocking
:    message, timeout)
:DBusException: org.freedesktop.DBus.Error.Failed: Context which does not has focus can not change engine to xkb:layout:us.
:
:Local variables in innermost frame:
:byte_arrays: False
:self: <dbus.connection.Connection object at 0x91915cc>
:args: (dbus.String(u'xkb:layout:us'),)
:utf8_strings: False
:bus_name: 'org.freedesktop.IBus'
:get_args_opts: {'byte_arrays': False, 'utf8_strings': False}
:object_path: dbus.ObjectPath('/org/freedesktop/IBus/InputContext_150')
:timeout: -1.0
:signature: u's'
:dbus_interface: 'org.freedesktop.IBus.InputContext'
:message: <dbus.lowlevel.MethodCallMessage object at 0x91609c0>
:method: 'SetEngine'
Comment 1 fujiwara 2011-07-19 00:53:01 EDT

*** This bug has been marked as a duplicate of bug 720567 ***

Note You need to log in before you can comment on or make changes to this bug.