Bug 720567 - [abrt] ibus-1.3.99.20110419-9.fc15: connection.py:630:call_blocking:DBusException: org.freedesktop.DBus.Error.Failed: Timeout was reached
[abrt] ibus-1.3.99.20110419-9.fc15: connection.py:630:call_blocking:DBusExcep...
Status: CLOSED DUPLICATE of bug 707370
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
15
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
abrt_hash:7c7107375190f58f49210f04e56...
:
: 722636 722637 722756 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-12 00:55 EDT by nomnex
Modified: 2011-07-31 22:29 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-31 22:29:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description nomnex 2011-07-12 00:55:06 EDT
abrt version: 2.0.3
architecture:   i686
cmdline:        /usr/bin/python /usr/share/ibus/ui/gtk/main.py
comment:        Changing language generates an error msg.
component:      ibus
executable:     /usr/share/ibus/ui/gtk/main.py
kernel:         2.6.38.8-32.fc15.i686
os_release:     Fedora release 15 (Lovelock)
package:        ibus-1.3.99.20110419-9.fc15
reason:         connection.py:630:call_blocking:DBusException: org.freedesktop.DBus.Error.Failed: Timeout was reached
time:           Tue Jul 12 13:52:49 2011
uid:            500
username:       mt

backtrace:
:connection.py:630:call_blocking:DBusException: org.freedesktop.DBus.Error.Failed: Timeout was reached
:
:Traceback (most recent call last):
:  File "/usr/share/ibus/ui/gtk/panel.py", line 651, in __im_menu_item_activate_cb
:    self.__focus_ic.set_engine(engine)
:  File "/usr/lib/python2.7/site-packages/ibus/inputcontext.py", line 284, in set_engine
:    return self.__context.SetEngine(engine.name)
:  File "/usr/lib/python2.7/site-packages/dbus/proxies.py", line 140, in __call__
:    **keywords)
:  File "/usr/lib/python2.7/site-packages/dbus/connection.py", line 630, in call_blocking
:    message, timeout)
:DBusException: org.freedesktop.DBus.Error.Failed: Timeout was reached
:
:Local variables in innermost frame:
:byte_arrays: False
:self: <dbus.connection.Connection object at 0x8f0f5cc>
:args: (dbus.String(u'anthy'),)
:utf8_strings: False
:bus_name: 'org.freedesktop.IBus'
:get_args_opts: {'byte_arrays': False, 'utf8_strings': False}
:object_path: dbus.ObjectPath('/org/freedesktop/IBus/InputContext_270')
:timeout: -1.0
:signature: u's'
:dbus_interface: 'org.freedesktop.IBus.InputContext'
:message: <dbus.lowlevel.MethodCallMessage object at 0x8ede960>
:method: 'SetEngine'
Comment 1 fujiwara 2011-07-12 22:48:45 EDT
I cannot reproduce your problem.
Are you still able to reproduce this?
Comment 2 nomnex 2011-07-13 20:16:43 EDT
Hello, the bug report has been automatically generated by ABRT. I have been waiting to see if it would occur again. So far so good. I'll revive the thread if a new report is generated.
Comment 3 fujiwara 2011-07-19 00:44:18 EDT
*** Bug 722636 has been marked as a duplicate of this bug. ***
Comment 4 fujiwara 2011-07-19 00:46:49 EDT
*** Bug 722637 has been marked as a duplicate of this bug. ***
Comment 5 fujiwara 2011-07-19 00:53:01 EDT
*** Bug 722756 has been marked as a duplicate of this bug. ***
Comment 6 fujiwara 2011-07-19 21:28:03 EDT
You have filed several similar bugs but I cannot reproduce your problem.
All bugs are caused by the time out of SetEngine dbus method.

(In reply to comment #2)
Currently I have no idea to reproduce this problem.
It would be great if you could give the furthermore info since I have seen
several similar bugs but I don't get the condition to reproduce the problem.

Are you able to see your problem with a new user account instead of the current
your account?
Which processes exhaust CPUs or memories when you see your problem?
Do you have any special conditions?

> :DBusException: org.freedesktop.DBus.Error.Failed: Context which does not has
focus can not change engine to xkb:layout:de.

Which application has the input focus when you see your problem?
The SetEngine will call '/usr/libexec/ibus-engine-xkb --ibus'.
Comment 7 nomnex 2011-07-21 22:32:23 EDT
(In reply to comment #6)
> You have filed several similar bugs but I cannot reproduce your problem.
> All bugs are caused by the time out of SetEngine dbus method.

I have noticed this time out message. Can I extend the time-out limit?
 
> (In reply to comment #2)
> Currently I have no idea to reproduce this problem.
> It would be great if you could give the furthermore info since I have seen
> several similar bugs but I don't get the condition to reproduce the problem.

I use ABRT, every time the situation occurs, a new report is generated (no duplicate), sorry about it.

> Are you able to see your problem with a new user account instead of the current

I haven't yet.

> Which processes exhaust CPUs or memories when you see your problem?
> Do you have any special conditions?

How can I see that when it occurs?
 
> > :DBusException: org.freedesktop.DBus.Error.Failed: Context which does not has
> focus can not change engine to xkb:layout:de.

what the ":de" stands for? > Deutsch? if so, I don't use german kb layout.
 
> Which application has the input focus when you see your problem?
> The SetEngine will call '/usr/libexec/ibus-engine-xkb --ibus'.

I use puddletag a lot lately. It use a QT tookit. I often loose keyboard input when I use PT with Ibus. Could it be related?
Comment 8 fujiwara 2011-07-21 23:12:29 EDT
(In reply to comment #7)
> (In reply to comment #6)
> > You have filed several similar bugs but I cannot reproduce your problem.
> > All bugs are caused by the time out of SetEngine dbus method.
> 
> I have noticed this time out message. Can I extend the time-out limit?

ibus-daemon supports to set the time out value.
% ibus-daemon --help
You could modify XIM_ARGS in /etc/X11/xinit/xinput.d/ibus.conf
XIM_ARGS="-r --xim --timeout 10000"

However I think this would be a workaround and does not fix the root cause.

> 
> > (In reply to comment #2)
> > Currently I have no idea to reproduce this problem.
> > It would be great if you could give the furthermore info since I have seen
> > several similar bugs but I don't get the condition to reproduce the problem.
> 
> I use ABRT, every time the situation occurs, a new report is generated (no
> duplicate), sorry about it.
> 
> > Are you able to see your problem with a new user account instead of the current
> 
> I haven't yet.
> 
> > Which processes exhaust CPUs or memories when you see your problem?
> > Do you have any special conditions?
> 
> How can I see that when it occurs?

Ah, I mean to use 'top' command during the login session.

> 
> > > :DBusException: org.freedesktop.DBus.Error.Failed: Context which does not has
> > focus can not change engine to xkb:layout:de.
> 
> what the ":de" stands for? > Deutsch? if so, I don't use german kb layout.

Sorry, I mistook to paste the different bug.

From this bug and bug 722637:
> :connection.py:630:call_blocking:DBusException:
> org.freedesktop.DBus.Error.Failed: Can not find engine anthy.

From bug 722636:
> :connection.py:630:call_blocking:DBusException:
> org.freedesktop.DBus.Error.Failed: Can not find engine xkb:layout:ca.

From bug 722756:
> :connection.py:630:call_blocking:DBusException:
org.freedesktop.DBus.Error.Failed: Context which does not has focus can not
> change engine to xkb:layout:us.

> 
> > Which application has the input focus when you see your problem?
> > The SetEngine will call '/usr/libexec/ibus-engine-xkb --ibus'.
> 
> I use puddletag a lot lately. It use a QT tookit. I often loose keyboard input
> when I use PT with Ibus. Could it be related?

Maybe. Hmm..
Comment 9 nomnex 2011-07-22 00:07:15 EDT
(In reply to comment #7)
 
> > I have noticed this time out message. Can I extend the time-out limit?
> 
> ibus-daemon supports to set the time out value.
> % ibus-daemon --help
> You could modify XIM_ARGS in /etc/X11/xinit/xinput.d/ibus.conf
> XIM_ARGS="-r --xim --timeout 10000"
> 
> However I think this would be a workaround and does not fix the root cause.

ibus.conf modified. It worth trying this workaround, because I am not positive I can reproduce the issue on my other notebook with a different hardware.

> > > Which processes exhaust CPUs or memories when you see your problem?
> > > Do you have any special conditions?
> > 
> > How can I see that when it occurs?
> 
> Ah, I mean to use 'top' command during the login session.

dunno how to use the top command during a login session? I use a GUI log-gin. I do however run "top" in a tab of my terminal window, to monitor the processes. I will double check next time. Except flash cpu-killer add-on (unlikely), and puddle tag, I dind't see anything special lately.

> > 
> > > > :DBusException: org.freedesktop.DBus.Error.Failed: Context which does not has
> > > focus can not change engine to xkb:layout:de.
> > 
> > what the ":de" stands for? > Deutsch? if so, I don't use german kb layout.
> 
> Sorry, I mistook to paste the different bug.

np

> > I use puddletag a lot lately. It use a QT tookit. I often loose keyboard input
> > when I use PT with Ibus. Could it be related?
> 
> Maybe. Hmm..

If I am the only one affected by this problem, on this notebook, let's keep finger crossed the workaround works :)

Thank you for the feedback.
Comment 10 fujiwara 2011-07-22 00:31:56 EDT
(In reply to comment #9)
> > > > Which processes exhaust CPUs or memories when you see your problem?
> > > > Do you have any special conditions?
> > > 
> > > How can I see that when it occurs?
> > 
> > Ah, I mean to use 'top' command during the login session.
> 
> dunno how to use the top command during a login session? I use a GUI log-gin. I
> do however run "top" in a tab of my terminal window, to monitor the processes.
> I will double check next time. Except flash cpu-killer add-on (unlikely), and
> puddle tag, I dind't see anything special lately.
> 

I meant to prepare another machine, log in the problem machine with ssh and run top command.
If you have only one machine, maybe Control + Alt + F2 and Control + Alt + F7 could be used.

> If I am the only one affected by this problem, on this notebook, let's keep
> finger crossed the workaround works :)

OK, another test may be to compare the performances to rename $HOME/.anthy .

> 
> Thank you for the feedback.
Comment 11 fujiwara 2011-07-31 22:29:39 EDT

*** This bug has been marked as a duplicate of bug 707370 ***

Note You need to log in before you can comment on or make changes to this bug.