Bug 72277 - M-x man in xemacs generates unreadable pages
M-x man in xemacs generates unreadable pages
Status: CLOSED DUPLICATE of bug 71646
Product: Red Hat Public Beta
Classification: Retired
Component: xemacs (Show other bugs)
null
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-22 13:35 EDT by ctm
Modified: 2015-01-07 18:59 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-27 12:01:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ctm 2002-08-22 13:35:32 EDT
Description of Problem:

M-x man now creates pages with a lot of carriage control (or color
contorl) characters embedded in it.


Version-Release number of selected component (if applicable):

21.4.8-14, but maybe it's man or some configuration info that's changed.

How Reproducible:
Trivial, for me.  It happens on two different null installations, both
when xemacs is using an X Window and when xemacs is invoked with "-nw"


Steps to Reproduce:
1. start xemacs
2. M-x man
3. man

Actual Results:

[[1mNAME^[[0m



Expected Results:

NAME


Additional Information:
Comment 1 Trond Eivind Glomsrxd 2002-08-23 18:46:42 EDT
Same problem in emacs, I'm suspecting groff (since installing the old groff
works just fine...). Florian?
Comment 2 Bill Nottingham 2002-08-27 01:14:42 EDT
man started using a different pager, or something like that (mentioned on a
mailing list; this could be the reason?)
Comment 3 Florian La Roche 2002-08-27 08:23:49 EDT
Might also depend on bug 71646

Florian La Roche
Comment 4 Trond Eivind Glomsrxd 2002-08-27 11:56:21 EDT
Yes, it's the same problem. Both work if you install groff from RHL 7.3 and do
no other changes.
Comment 5 Florian La Roche 2002-08-27 12:01:22 EDT
Are they calling groff directly or calling "man"? If groff is called and
utf8 is enabled, groff currently does not switch to it automatically,
but you need to set "-Tutf8" on the command line.

Is this fixing it? Then we need to think about a "good" fix for this
problem...

Thanks,

Florian La Roche
Comment 6 Trond Eivind Glomsrxd 2002-08-29 18:58:00 EDT
Same problem as the other bug, duping this.

*** This bug has been marked as a duplicate of 71646 ***

Note You need to log in before you can comment on or make changes to this bug.