This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 722963 - TypeError: %d format: a number is required, not str
TypeError: %d format: a number is required, not str
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
anaconda_trace_hash:1d52b7902d8c7a2b9...
:
: 727688 (view as bug list)
Depends On:
Blocks: F16Blocker/F16FinalBlocker
  Show dependency treegraph
 
Reported: 2011-07-18 11:47 EDT by John Dulaney
Modified: 2014-06-18 05:06 EDT (History)
8 users (show)

See Also:
Fixed In Version: anaconda-16.15-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-14 16:11:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (496.57 KB, text/plain)
2011-07-18 11:47 EDT, John Dulaney
no flags Details

  None (edit)
Description John Dulaney 2011-07-18 11:47:32 EDT
The following was filed automatically by anaconda:
anaconda 16.12 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/partitioning.py", line 1077, in allocatePartitions
    _part.format.maxSize))
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/partitioning.py", line 921, in doPartitioning
    allocatePartitions(storage, disks, partitions, free, bootloader=bootloader)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/iw/partition_gui.py", line 1549, in refresh
    doPartitioning(self.storage)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/iw/partition_gui.py", line 1648, in editPartition
    if self.refresh(justRedraw=not actions):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/iw/partition_gui.py", line 1606, in editCB
    self.editPartition(device)
TypeError: %d format: a number is required, not str
Comment 1 John Dulaney 2011-07-18 11:47:41 EDT
Created attachment 513641 [details]
Attached traceback automatically from anaconda.
Comment 2 Adam Williamson 2011-07-18 13:43:13 EDT
can you provide a bit more information about the context in which you encountered this, and which release criterion it infringes? thanks!
Comment 3 David Lehman 2011-07-18 15:11:09 EDT
This occurs when the user tries to create a new partition that is not within the size limits for the type of formatting selected. In this case the formatting is BIOS Boot, which must be between 512KB and 2MB in size. I have posted a simple patch for review.
Comment 4 John Dulaney 2011-07-18 16:06:51 EDT
@Adam, I'm going to say 7 because it kills the install.  It is also a very easily reproachable bug, which means that *random user* could cause it.

@David, This is what happens when I am not quite paying full attention to what I'm doing.  However, it needs to not cause Anaconda to crash.
Comment 5 Tim Flink 2011-07-21 11:15:47 EDT
I'm not sure that this hits any of the alpha release criteria. I think that it definitely hits the final criterion:

The installer must be able to create and install to any workable partition layout using any file system offered in a default installer configuration, LVM, software, hardware or BIOS RAID, or combination of the above

The closest alpha criterion that I'm seeing (assuming that the default partition layout doesn't hit this) would be:

The installer must be able to complete an installation using the entire disk, existing free space, or existing Linux partitions methods, with or without encryption enabled 

But I do think that using that criterion is a bit of a stretch.

Unless I'm missing something here, I'm thinking -1 alpha blocker and +1 final blocker. It sounds like a fix will be in shortly, though and this will be closed well before final.
Comment 6 Adam Williamson 2011-07-21 12:16:14 EDT
If this requires a custom layout, yes, it's not Alpha. The criterion you cite is pretty straightforward: those are actual options in the installer. So it's easy enough to check if any of them hits this bug. Just try doing and install and using those options - *not* the custom layout option.
Comment 7 Tim Flink 2011-07-22 16:44:40 EDT
Discussed in the 2011-07-22 blocker bug review meeting. We agreed that this does not hit any of the alpha release criteria and is rejected as an alpha blocker.

However, it does hit the final release criterion:

The installer must be able to create and install to any workable partition
layout using any file system offered in a default installer configuration, LVM,
software, hardware or BIOS RAID, or combination of the above

As such, it has been accepted as a final blocker.
Comment 8 David Lehman 2011-08-02 22:23:51 EDT
*** Bug 727688 has been marked as a duplicate of this bug. ***
Comment 9 Tim Flink 2011-09-30 16:50:09 EDT
It's been a while since this bug was reported and there have been some changes in anaconda since then.

Can you still reproduce this with beta?
Comment 10 John Dulaney 2011-09-30 17:34:43 EDT
I'll try when I get home.
Comment 11 Adam Williamson 2011-10-14 14:52:37 EDT
Discussed at 2011-10-14 blocker review. John, can you please confirm this one so we can close it? Thanks!
Comment 12 John Dulaney 2011-10-14 16:11:35 EDT
Oops, forgot to do this.

I can confirm that it is fixed.  Going ahead and closing.

Note You need to log in before you can comment on or make changes to this bug.