Bug 72315 - HP 7.3 will not install on HP ze5170
HP 7.3 will not install on HP ze5170
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.3
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
: 72316 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-22 19:10 EDT by Need Real Name
Modified: 2007-04-18 12:45 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-23 13:15:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
requested dump attached (33.07 KB, text/plain)
2002-08-23 13:14 EDT, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2002-08-22 19:10:53 EDT
Description of Problem:  Install crashes with variety of different error codes
when repeating same steps partition errors 116,117, partition signature error, 
anaconda runtime errors, install errors while installing components from disk 1 
(never make it to disk 2)

Errors on install of HP Pavillion ZE5170.
  Have tried running partition magic, only installing RH (removing all XP 
partions), installing from free space, using previously created Linux 
partitions,


Version-Release number of selected component (if applicable): RH 7.3


How Reproducible: Every install


Steps to Reproduce: Can not get to run successfully, always errors
1. 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:

Following is dump from Anaconda report created when it failed.  (Anaconda does 
not ALWAYS fail.  Sometimes the failures are almost immediate - IE the device 
will not be visible at all.  I will reboot, and there it is.  Or run once, 
error 116, run again - same steps, fails reporting that it could not format '/' 
partition.  Results are random.

Here is Anaconda results:
Traceback (innermost last):
  File "/usr/bin/anaconda", line 633, in ?
    intf.run(id, dispatch, configFileData)
  File "/usr/lib/anaconda/gui.py", line 353, in run
    self.icw.run (self.runres, configFileData)
  File "/usr/lib/anaconda/gui.py", line 814, in run
    mainloop ()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2676, in mainloop
    _gtk.gtk_main()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 130, in __call__
    ret = apply(self.func, a)
  File "/usr/lib/anaconda/iw/partition_gui.py", line 770, in newCB
    self.editPartitionRequest(request, isNew = 1)
  File "/usr/lib/anaconda/iw/partition_gui.py", line 1241, in 
editPartitionRequest
    if self.refresh():
  File "/usr/lib/anaconda/iw/partition_gui.py", line 1288, in refresh
    doPartitioning(self.diskset, self.partitions)
  File "/usr/lib/anaconda/autopart.py", line 752, in doPartitioning
    (ret, msg) = processPartitioning(diskset, requests, newParts)
  File "/usr/lib/anaconda/autopart.py", line 686, in processPartitioning
    setPreexistParts(diskset, requests.requests, newParts)
  File "/usr/lib/anaconda/autopart.py", line 623, in setPreexistParts
    disk = diskset.disks[request.drive]
KeyError: hda

Local variables in innermost frame:
diskset: <partitioning.DiskSet instance at 8496e60>
newParts: 
request: mountpoint: None   type: None   uniqueID:1
  size: 38154.3442383M   requestSize: 38154.3442383M  grow: 0   max: None
  start: 63L   end: 78140159L   partnum: None
  drive: hda   primary: None  
  format: None, options: None  device: hda-1, currentDrive: None
  raidlevel: None  raidspares: None  raidmembers: []
requests: [<partitioning.PartitionSpec instance at 84ea0e8>, 
<partitioning.PartitionSpec instance at 84fa1c0>, <partitioning.PartitionSpec 
instance at 85c3d80>]


Dispatcher instance, containing members:
skipSteps: {'reconfig
Comment 1 Michael Fulbright 2002-08-23 11:44:35 EDT
*** Bug 72316 has been marked as a duplicate of this bug. ***
Comment 2 Michael Fulbright 2002-08-23 11:46:35 EDT
It appears your /dev/hda drive is failing.

Please attach the entire log file.
Comment 3 Need Real Name 2002-08-23 13:14:59 EDT
Created attachment 72644 [details]
requested dump attached
Comment 4 Michael Fulbright 2002-08-26 12:27:46 EDT
There are errors coming from your first IDE hard drive which are causing the
issue you are seeing.

Note You need to log in before you can comment on or make changes to this bug.