Bug 723167 - error: rpmdb open failed
error: rpmdb open failed
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
anaconda_trace_hash:ba9479b6697549870...
:
: 727390 729053 (view as bug list)
Depends On:
Blocks: F16Alpha-accepted/F16AlphaFreezeExcept F16Beta/F16BetaBlocker
  Show dependency treegraph
 
Reported: 2011-07-19 05:56 EDT by He Rui
Modified: 2011-08-18 18:25 EDT (History)
7 users (show)

See Also:
Fixed In Version: anaconda-16.14.6-1.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-18 18:25:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (229.97 KB, text/plain)
2011-07-19 05:56 EDT, He Rui
no flags Details
rpmdb open failed in 16.13 also (1.61 MB, text/plain)
2011-07-22 13:59 EDT, Clyde E. Kunkel
no flags Details
tmp_kernelOops.tar.gz (572.72 KB, application/x-tar)
2011-08-04 03:51 EDT, He Rui
no flags Details
anaconda traceback and debug info (687.30 KB, text/plain)
2011-08-06 11:04 EDT, John Reiser
no flags Details
storage.log (320.47 KB, text/plain)
2011-08-06 11:05 EDT, John Reiser
no flags Details

  None (edit)
Description He Rui 2011-07-19 05:56:02 EDT
The following was filed automatically by anaconda:
anaconda 16.12 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 1434, in getReleaseString
    mi = ts.dbMatch('provides', 'initscripts')
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 1493, in findExistingRootDevices
    (arch, product, version) = getReleaseString(anaconda.rootPath)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/upgrade.py", line 81, in findRootParts
    upgradeany=flags.cmdline.has_key("upgradeany"))
  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 338, in dispatch
    self.dir = self.steps[self.step].target(self.anaconda)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 235, in go_forward
    self.dispatch()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/gui.py", line 1200, in nextClicked
    self.anaconda.dispatch.go_forward()
error: rpmdb open failed
Comment 1 He Rui 2011-07-19 05:56:07 EDT
Created attachment 513751 [details]
Attached traceback automatically from anaconda.
Comment 2 He Rui 2011-07-19 06:35:54 EDT
It happened every time when I boot pre-alpha installer(http://serverbeach1.fedoraproject.org/pub/alt/stage/20110714/x86_64/iso/) to a virt guest which has an installed system using gpt partition table.
Comment 3 Clyde E. Kunkel 2011-07-22 13:59:01 EDT
Created attachment 514758 [details]
rpmdb open failed in 16.13 also

this is from: Fedora-16-test-20110721-3-x86_64.iso.  Can't get around it.
Comment 4 Chris Lumens 2011-08-02 08:43:04 EDT
*** Bug 727390 has been marked as a duplicate of this bug. ***
Comment 5 Chris Lumens 2011-08-03 10:51:01 EDT
Can you try updates=http://clumens.fedorapeople.org/723167.img against a tree containing anaconda-16.14-1?  This looks pretty stupid, like we're trying to open an rpmdb on systems that won't ever contain one when trying to find an upgrade candidate.
Comment 6 Clyde E. Kunkel 2011-08-03 14:14:16 EDT
http://clumens.fedorapeople.org/723167.img works for me.  (Other issues surface, trying to bz them.)
Comment 7 He Rui 2011-08-03 22:38:10 EDT
(In reply to comment #5)
> Can you try updates=http://clumens.fedorapeople.org/723167.img against a tree
> containing anaconda-16.14-1?  This looks pretty stupid, like we're trying to
> open an rpmdb on systems that won't ever contain one when trying to find an
> upgrade candidate.

I cannot reproduce this issue on anaconda 16.14.
Comment 8 He Rui 2011-08-04 03:49:38 EDT
(In reply to comment #7)
> (In reply to comment #5)
> > Can you try updates=http://clumens.fedorapeople.org/723167.img against a tree
> > containing anaconda-16.14-1?  This looks pretty stupid, like we're trying to
> > open an rpmdb on systems that won't ever contain one when trying to find an
> > upgrade candidate.
> 
> I cannot reproduce this issue on anaconda 16.14.

I can reproduce the issue now when I boot F16-alphaTC1 to a guest which has F-15 installed. By using the updates, this issue didn't happen, but kernel oops happened as well as an error: cannot open Packages database in /mnt/sysimage/var/lib/rpm. Log attached.
Comment 9 He Rui 2011-08-04 03:51:05 EDT
Created attachment 516645 [details]
tmp_kernelOops.tar.gz
Comment 10 Chris Lumens 2011-08-04 10:29:42 EDT
If there are other errors, let's track those separately.
Comment 11 John Reiser 2011-08-06 11:04:22 EDT
Created attachment 516994 [details]
anaconda traceback and debug info

"error: rpmdb open failed"

Installing from DVD (Fedora 16 Alpha RC1) to a machine which has many partitions, including several non-upgradable (FC6, Ubuntu, ...)  I intended to do a fresh install overwriting an existing partition, but never got far enough to make that choice.

anaconda 16.14.2 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 1449, in getReleaseString
    mi = ts.dbMatch('provides', 'initscripts')
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 1508, in findExistingRootDevices
    (arch, product, version) = getReleaseString(anaconda.rootPath)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/upgrade.py", line 81, in findRootParts
    upgradeany=flags.cmdline.has_key("upgradeany"))
  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 348, in dispatch
    self.dir = self.steps[self.step].target(self.anaconda)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 235, in go_forward
    self.dispatch()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/gui.py", line 1198, in nextClicked
    self.anaconda.dispatch.go_forward()
error: rpmdb open failed
Comment 12 John Reiser 2011-08-06 11:05:20 EDT
Created attachment 516995 [details]
storage.log

/tmp/storage.log corresponding to attachment #516994 [details]
Comment 13 Adam Williamson 2011-08-08 17:31:35 EDT
Working on the assumption that 729053 is a dupe of this, we accepted the issue as NTH at the QA meeting today, so can we please get a new anaconda 16.14.x build with the fix for this added in? Thanks!
Comment 14 Adam Williamson 2011-08-08 17:32:34 EDT
*** Bug 729053 has been marked as a duplicate of this bug. ***
Comment 15 Fedora Update System 2011-08-09 00:25:38 EDT
anaconda-16.14.3-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/anaconda-16.14.3-1.fc16
Comment 16 Fedora Update System 2011-08-09 02:02:30 EDT
Package anaconda-16.14.3-1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-16.14.3-1.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/anaconda-16.14.3-1.fc16
then log in and leave karma (feedback).
Comment 17 Fedora Update System 2011-08-11 11:49:45 EDT
anaconda-16.14.4-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/anaconda-16.14.4-1.fc16
Comment 18 Fedora Update System 2011-08-15 12:55:30 EDT
anaconda-16.14.5-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/anaconda-16.14.5-1.fc16
Comment 19 Fedora Update System 2011-08-16 16:14:41 EDT
anaconda-16.14.6-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/anaconda-16.14.6-1.fc16
Comment 20 Fedora Update System 2011-08-18 18:24:14 EDT
anaconda-16.14.6-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.