Bug 729053 - traceback after first iteration of device discovery
traceback after first iteration of device discovery
Status: CLOSED DUPLICATE of bug 723167
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
16
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
AcceptedNTH
:
Depends On:
Blocks: F16Alpha-accepted/F16AlphaFreezeExcept F16Beta/F16BetaBlocker
  Show dependency treegraph
 
Reported: 2011-08-08 11:40 EDT by Clyde E. Kunkel
Modified: 2011-08-08 17:32 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-08 17:32:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Files in /tmp directory after traceback (309.41 KB, application/x-gzip)
2011-08-08 11:40 EDT, Clyde E. Kunkel
no flags Details

  None (edit)
Description Clyde E. Kunkel 2011-08-08 11:40:07 EDT
Created attachment 517246 [details]
Files in /tmp directory after traceback

Description of problem:
traceback during or at end of first device discovery.

Version-Release number of selected component (if applicable):
16.14.2

How reproducible:
every time

Steps to Reproduce:
1. boot Fedora 16 Alpha RC1 DVD
2. hit enter thru to first device dicovery process
3.
  
Actual results:
traceback

Expected results:
continue installation

Additional info:
I think this should be an alpha blocker

(cannot auto send error to bugzilla, attaching /tmp files)

This issue was raised by John Reiser on the anaconda list today as:
"Seriously, if the installer sees a Ubuntu or Debian root partition
on any drive then it will abort with "rpmdb open failed".  rhbz #723167
claims fixed in anaconda-16.15, but the latest Fedora 16 Alpha RC1
has only 16.14.2, and 16.15 has not appeared anywhere."
Comment 1 Tim Flink 2011-08-08 12:42:59 EDT
Discussed in the 2011-08-08 Fedora QA meeting. Since the effects of this bug only surface with an existing apt based linux installation, it doesn't clearly hit any of the release criteria and didn't seem appropriate as an alpha blocker bug.

Accepted as Fedora 16 Alpha NTH and re-proposed as Fedora 16 beta blocker bug.
Comment 2 Clyde E. Kunkel 2011-08-08 13:13:10 EDT
I understand.

But, let me say this:  the earlier in a software development process that you find and correct bugs, the less expensive the project (for open source, this is mostly time) and the less likely you are to encounter severe bugs later and suffer a delay in finishing. That said, the more testing you can achieve during an alpha phase (or, I guess, in this instance, pre-alpha) on a wide variety of systems the more likely you are to find and correct troublesome bugs.  I test on bare metal with other distros installed. I know that if I had tested in a VM with a single guest, then this bug would not have been hit.

Just my two cents.

Regards,

Old Fart
Comment 3 Adam Williamson 2011-08-08 17:28:39 EDT
Should this be marked as a dupe of #723167 ?
Comment 4 Adam Williamson 2011-08-08 17:32:34 EDT
dlehman says yes, will transfer the NTH state.

*** This bug has been marked as a duplicate of bug 723167 ***

Note You need to log in before you can comment on or make changes to this bug.