This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 723303 - device /dev/mapper/tmp--VolGroup01-xxxx does not exist
device /dev/mapper/tmp--VolGroup01-xxxx does not exist
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
AcceptedBlocker, AcceptedNTH
:
: 736412 (view as bug list)
Depends On:
Blocks: F16Beta-accepted/F16BetaFreezeExcept F16Blocker/F16FinalBlocker
  Show dependency treegraph
 
Reported: 2011-07-19 12:52 EDT by Clyde E. Kunkel
Modified: 2011-09-15 13:21 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-14 12:14:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
logs from install and error msgs from two attempts (logs from 1st attempt only) (381.07 KB, application/octet-stream)
2011-07-19 12:52 EDT, Clyde E. Kunkel
no flags Details
/tmp files from mount error (315.04 KB, application/x-gzip)
2011-08-17 14:58 EDT, Clyde E. Kunkel
no flags Details

  None (edit)
Description Clyde E. Kunkel 2011-07-19 12:52:03 EDT
Created attachment 513841 [details]
logs from install and error msgs from two attempts (logs from 1st attempt only)

Description of problem:
cannot mount existing lv on /mnt/<any name>

Version-Release number of selected component (if applicable):
generic installer 16.12 in desktop spin 20110717

How reproducible:
every time

Steps to Reproduce:
1. boot desktop spin 20110717
2. select install to hard drive
3. select custom layout
4. after selecting / and other ordinary paritions, select an existing LV to mount as /home or any point on /mnt
5. click next, answer yes to format,etc
  
Actual results:
after formating, get following error:

An error occurred mounting device /dev/mapper/VolGroup01-clydehome as /home: device /dev/mapper/tmp--VolGroup01-clydehome does not exist. This is a fatal error and the install cannot continue.

Press <Enter> to exit the installer.

Expected results:
normal install 

Additional info:
by not selecting any existing lvs to mount, except for /, installation proceeds normally (except for grub2 error and unbootable system at end).
Comment 1 David Lehman 2011-07-19 15:08:39 EDT
This is fallout from commit 2e73cc57a79d23b23e. The solution is probably to coerce the format's device attribute after setting up the device to ensure they stay in sync.
Comment 2 Clyde E. Kunkel 2011-07-21 14:39:22 EDT
Issue is still in 16.13.
Comment 3 Michael Schwendt 2011-08-03 07:35:28 EDT
Also affects F16 Alpha TC1 in exactly the same way. Anaconda 16.14 (afaik).
Comment 4 Clyde E. Kunkel 2011-08-03 14:19:40 EDT
Yep still there.  Skipping the mount of an LV other than root LV works, but now running into a new error dialogue that seems similar:

Unable to Mount Filesystem

An error occurred mounting device /dev/sdf1 as /mnt/masterboot: mount failed: (30, Read-only file system). This is a fatal error and the install cannot continue.

Press <Enter> to exit the installer.

Is this related or should I enter a new bz?
Comment 5 David Lehman 2011-08-03 19:28:50 EDT
Looks like a new bug to me.
Comment 6 David Lehman 2011-08-04 15:28:29 EDT
The failure occurs whenever you try to assign a mountpoint to an existing lv without reformatting it. Without reading the criteria, this seems like at least a Beta blocker.
Comment 7 Clyde E. Kunkel 2011-08-05 08:09:45 EDT
I understand.  My workaround is to modify fstab after installation completes and before first boot.  I have /home on an LV and reuse it from Fedora version to Fedora version.  

(Haven't seen a repeat of the 30, Read-only file system.)
Comment 8 Clyde E. Kunkel 2011-08-17 14:58:46 EDT
Created attachment 518735 [details]
/tmp files from mount error

Contents of /tmp from anaconda 16.14.6.  Included is a file (devmapper) showing the contents of /dev/mapper at the time the error dialogue (not traceback) appeared. There is no /dev/mapper/tmp--VolGroup01-clydehome in /dev/mapper, but plenty of various incantations of clydehome.
Comment 9 Clyde E. Kunkel 2011-08-17 15:08:17 EDT
Can't work around this error by specifying only the / partition and /boot partition.  Then run into 731480 which appears same as 727966.
Comment 10 David Lehman 2011-08-17 15:11:48 EDT
This is fixed by commit 12f5c4a9b234605b920145f4f3f90287b185c98c, which is
on rawhide and will be in the first post-alpha f16 composes.
Comment 11 Tim Flink 2011-09-01 13:10:09 EDT
Discussed in the 2011-08-26 blocker review meeting. Rejected as a Fedora 16 beta blocker because it uses custom layouts which aren't part of the beta release critera [1].

However, it was accepted as Fedora 16 beta NTH since a fix is already in.

[1] https://fedoraproject.org/wiki/Fedora_15_Beta_Release_Criteria
Comment 12 Adam Williamson 2011-09-01 13:21:30 EDT
should be a final blocker rather than a rejectedblocker, I believe.
Comment 13 Tim Flink 2011-09-01 13:50:25 EDT
(In reply to comment #12)
> should be a final blocker rather than a rejectedblocker, I believe.

Whoops, I was reading the minutes a little too fast. Thanks for catching that.

Accepted as a Fedora 16 final blocker as it violates the following final release criterion [1]:

The installer must be able to create and install to any workable partition layout using any file system offered in a default installer configuration, LVM, software, hardware or BIOS RAID, or combination of the above.

[1] https://fedoraproject.org/wiki/Fedora_16_Final_Release_Criteria
Comment 14 Adam Williamson 2011-09-08 12:47:56 EDT
This should be fixed in Beta TC1, as I read #10: clyde, can you verify? Thanks.
Comment 15 Clyde E. Kunkel 2011-09-08 13:03:48 EDT
(In reply to comment #14)
> This should be fixed in Beta TC1, as I read #10: clyde, can you verify? Thanks.

Can't.  I run into:

https://bugzilla.redhat.com/show_bug.cgi?id=734978
Comment 16 Clyde E. Kunkel 2011-09-08 17:23:20 EDT
tried the boot.iso at:
http://tflink.fedorapeople.org/iso/20110908_pre-betaTC2_x64.boot.iso

but I get a GPF on mdadm each time (x2).

I understand that there are a couple of raid issues with raid1 and 10 that need fixing (and fixes are in the pipeline?).  I do believe I am seeing them with this kernel.
Comment 17 Tim Flink 2011-09-08 17:37:59 EDT
(In reply to comment #16)
> tried the boot.iso at:
> http://tflink.fedorapeople.org/iso/20110908_pre-betaTC2_x64.boot.iso
> 
> but I get a GPF on mdadm each time (x2).
> 
> I understand that there are a couple of raid issues with raid1 and 10 that need
> fixing (and fixes are in the pipeline?).  I do believe I am seeing them with
> this kernel.

I didn't include the new kernel or mdadm builds in that boot.iso but I can build a new one if you want to try it.
Comment 18 Clyde E. Kunkel 2011-09-08 17:49:26 EDT
(In reply to comment #17)
>
> 
> I didn't include the new kernel or mdadm builds in that boot.iso but I can
> build a new one if you want to try it.


Hmmmm...strange, then this might be a regression due to something else.

However, build away.  We're having serious flooding here at present (not affecting me directly, but others I support), but I should be able to test something as long as the build is done with the next 30 minutes.
Comment 19 Clyde E. Kunkel 2011-09-10 18:09:42 EDT
This is probably resolved, but the definitive test has to wait for resolution of 737278.  Was able to do an install by specifying the devices to use and not checking the raid component devices.  Installer allowed specifying the home LV without barfing.
Comment 20 Clyde E. Kunkel 2011-09-14 11:16:17 EDT
(In reply to comment #19)
> This is probably resolved, but the definitive test has to wait for resolution
> of 737278.  Was able to do an install by specifying the devices to use and not
> checking the raid component devices.  Installer allowed specifying the home LV
> without barfing.

Fix confirmed with Mr. Flink's latest boot.iso:
http://tflink.fedorapeople.org/iso/20110914_preRC_boot2.x86_64.iso

Thanks!!
Comment 21 Adam Williamson 2011-09-14 12:14:24 EDT
Great, closing. thanks!
Comment 22 David Lehman 2011-09-15 13:21:03 EDT
*** Bug 736412 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.