Bug 736412 - FormatSetupError: invalid device specification
FormatSetupError: invalid device specification
Status: CLOSED DUPLICATE of bug 723303
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:9bfdfeed7317b113f040e306537...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-07 12:01 EDT by specht.tobias
Modified: 2011-09-15 13:21 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-15 13:21:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
anaconda-tb (1.19 MB, text/plain)
2011-09-11 14:21 EDT, specht.tobias
no flags Details

  None (edit)
Description specht.tobias 2011-09-07 12:01:11 EDT
abrt version: 2.0.5
executable:     /usr/bin/python
hashmarkername: anaconda
kernel:         3.0.0-1.fc16.x86_64
product:        Fedora
reason:         FormatSetupError: invalid device specification
time:           Wed Sep  7 15:53:39 2011
version:        16-Alpha

description:
:The following was filed automatically by anaconda:
:anaconda 16.14.6 exception report
:Traceback (most recent call first):
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/formats/__init__.py", line 334, in setup
:    raise FormatSetupError("invalid device specification")
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/formats/swap.py", line 132, in setup
:    DeviceFormat.setup(self, *args, **kwargs)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 2043, in turnOnSwap
:    device.format.setup()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 1305, in turnOnSwap
:    upgrading=upgrading)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/packages.py", line 151, in turnOnFilesystems
:    anaconda.storage.turnOnSwap()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 348, in dispatch
:    self.dir = self.steps[self.step].target(self.anaconda)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 235, in go_forward
:    self.dispatch()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/gui.py", line 1198, in nextClicked
:    self.anaconda.dispatch.go_forward()
:FormatSetupError: invalid device specification
Comment 1 David Lehman 2011-09-07 12:57:39 EDT
There is a file that matches /tmp/anaconda-tb-* which you can get to by switching to tty2 (ctl+alt+f2). Please transfer it out using scp or other means and attach it to this bug as an attachment of type text/plain. Thank you.
Comment 2 specht.tobias 2011-09-11 14:21:25 EDT
Created attachment 522618 [details]
anaconda-tb
Comment 3 Chris Lumens 2011-09-14 10:06:23 EDT
What steps did you take that resulted in this problem?  Is it at all reproducible?
Comment 4 specht.tobias 2011-09-15 04:12:55 EDT
Hi,
for me it is reproducible.
I'm working with LVM and the SWAP partition is also on an LVM volume.
The problem occurs when there is already a SWAP partition on LVM and I select this and go to "Edit" and close the dialog without doing any changes.
When I then go to "Next" the bug occur.
But when I go to "Edit" and say format, it's working.

I hope this helps.
Comment 5 David Lehman 2011-09-15 13:21:03 EDT
This appears to be a duplicate of bug 723303. The difference is that in this case the device is formatted as swap space while the other was a filesystem. This should be resolved in the F16 beta.

*** This bug has been marked as a duplicate of bug 723303 ***

Note You need to log in before you can comment on or make changes to this bug.