Bug 72403 - GNOME Calculator - using the keypad, 2,4,6 and 8 keys do not work with NumLock On
GNOME Calculator - using the keypad, 2,4,6 and 8 keys do not work with NumLoc...
Status: CLOSED DUPLICATE of bug 67885
Product: Red Hat Public Beta
Classification: Retired
Component: gnome-utils (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
Jay Turner
Depends On:
  Show dependency treegraph
Reported: 2002-08-23 10:55 EDT by Kevin Worthington
Modified: 2015-01-07 18:59 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-08-23 10:55:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Kevin Worthington 2002-08-23 10:55:45 EDT
Description of Problem:
When using GNOME Calculator, I notice that the '2' '4' '6' and '8'
keys on the keypad do not work. This is done with NumLock enabled. I
figure it has something to do with the fact that these are
also arrow keys, when the NumLock is not enabled. I'm using the
default key mappings for English, and the United States etc.

Version-Release number of selected component (if applicable):
[kw@kworthington kw]# rpm -qf /usr/bin/gnome-calculator
[kw@kworthington kw]#

How Reproducible:

Steps to Reproduce:
1. Have (null) installed with default U.S./English settings
2. run GNOME Calculator and have the NumLock Key enabled
3. try to enter in values that contain the numbers 2,4,6 and 8, using the keypad
on the right side of the keyboard

Actual Results:
nothing happens when 2,4,6, or 8 are pressed, using the keypad with numlock On

Expected Results:
2,4,6, and 8 should show up, the same as any other number does.

Additional Information:
On the (null) mailing list, Marc Deslauriers mentioned the following:
"What's really weird, is the Calculator work with all the number keys 
when numlock is OFF!", which I verified to be true as well.
Comment 1 Havoc Pennington 2002-08-23 11:20:46 EDT

*** This bug has been marked as a duplicate of 67885 ***

Note You need to log in before you can comment on or make changes to this bug.